summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Reffett <creffett@gentoo.org>2012-11-08 23:27:13 +0000
committerChris Reffett <creffett@gentoo.org>2012-11-08 23:27:13 +0000
commit8447a20009e6eaf131d2dc2a174edca000e5ecf3 (patch)
treef043646d02ff070d4c0b47476d88f93c018958b6 /kde-base/okular
parentremove old versions (diff)
downloadgentoo-2-8447a20009e6eaf131d2dc2a174edca000e5ecf3.tar.gz
gentoo-2-8447a20009e6eaf131d2dc2a174edca000e5ecf3.tar.bz2
gentoo-2-8447a20009e6eaf131d2dc2a174edca000e5ecf3.zip
Version bump KDE SC 4.9.3
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42618354)
Diffstat (limited to 'kde-base/okular')
-rw-r--r--kde-base/okular/ChangeLog7
-rw-r--r--kde-base/okular/okular-4.9.3.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/okular/ChangeLog b/kde-base/okular/ChangeLog
index def08fd50d9b..367b849afcad 100644
--- a/kde-base/okular/ChangeLog
+++ b/kde-base/okular/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/okular
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.156 2012/10/02 18:11:43 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/ChangeLog,v 1.157 2012/11/08 23:26:54 creffett Exp $
+
+*okular-4.9.3 (08 Nov 2012)
+
+ 08 Nov 2012; <creffett@gentoo.org> +okular-4.9.3.ebuild:
+ Version bump KDE SC 4.9.3
*okular-4.9.2 (02 Oct 2012)
diff --git a/kde-base/okular/okular-4.9.3.ebuild b/kde-base/okular/okular-4.9.3.ebuild
new file mode 100644
index 000000000000..e3f9c8058001
--- /dev/null
+++ b/kde-base/okular/okular-4.9.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/okular/okular-4.9.3.ebuild,v 1.1 2012/11/08 23:26:54 creffett Exp $
+
+EAPI=4
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="Okular is an universal document viewer based on KPDF for KDE 4."
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="chm crypt debug djvu ebook +jpeg +postscript +pdf +tiff"
+
+DEPEND="
+ media-libs/freetype
+ media-libs/qimageblitz
+ sys-libs/zlib
+ chm? ( dev-libs/chmlib )
+ crypt? ( app-crypt/qca:2 )
+ djvu? ( app-text/djvu )
+ ebook? ( app-text/ebook-tools )
+ jpeg? ( virtual/jpeg:0 )
+ pdf? ( >=app-text/poppler-0.20[qt4,-exceptions(-)] )
+ postscript? ( app-text/libspectre )
+ tiff? ( media-libs/tiff )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with chm)
+ $(cmake-utils_use_with crypt QCA2)
+ $(cmake-utils_use_with djvu DjVuLibre)
+ $(cmake-utils_use_with ebook EPub)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with postscript LibSpectre)
+ $(cmake-utils_use_with pdf PopplerQt4)
+ $(cmake-utils_use_with pdf Poppler)
+ $(cmake-utils_use_with tiff)
+ )
+
+ kde4-base_src_configure
+}