summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:39:00 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 01:39:00 +0000
commit6964ef3f0be7884abc09b82b45939aea8f161526 (patch)
tree60f01474d0eaa687e3d197400e3a1b1d69185f88 /kde-base/libplasma
parentFull auto: Version bump for KDE-4.1.3 (diff)
downloadgentoo-2-6964ef3f0be7884abc09b82b45939aea8f161526.tar.gz
gentoo-2-6964ef3f0be7884abc09b82b45939aea8f161526.tar.bz2
gentoo-2-6964ef3f0be7884abc09b82b45939aea8f161526.zip
Full auto: Version bump for KDE-4.1.3
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'kde-base/libplasma')
-rw-r--r--kde-base/libplasma/ChangeLog7
-rw-r--r--kde-base/libplasma/libplasma-4.1.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/libplasma/ChangeLog b/kde-base/libplasma/ChangeLog
index b929a5993593..9458fa90f082 100644
--- a/kde-base/libplasma/ChangeLog
+++ b/kde-base/libplasma/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/libplasma
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.12 2008/10/21 11:31:23 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.13 2008/11/09 01:39:00 scarabeus Exp $
+
+*libplasma-4.1.3 (08 Nov 2008)
+
+ 08 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org> +libplasma-4.1.3.ebuild:
+ Version bump.
21 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-libplasma-4.0.4.ebuild, -libplasma-4.0.5.ebuild:
diff --git a/kde-base/libplasma/libplasma-4.1.3.ebuild b/kde-base/libplasma/libplasma-4.1.3.ebuild
new file mode 100644
index 000000000000..f13170828401
--- /dev/null
+++ b/kde-base/libplasma/libplasma-4.1.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/libplasma-4.1.3.ebuild,v 1.1 2008/11/09 01:39:00 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdebase-workspace
+KMMODULE="libs/plasma"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl xinerama"
+
+RDEPEND=">=app-misc/strigi-0.5.11[qt4]
+ !<kde-base/plasma-3.96.0
+ >=kde-base/libkworkspace-${PV}:${SLOT}
+ >=kde-base/libtaskmanager-${PV}:${SLOT}
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/qt-webkit:4[debug?]
+ opengl? ( virtual/opengl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+KMEXTRACTONLY="krunner/org.freedesktop.ScreenSaver.xml
+ krunner/org.kde.krunner.Interface.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ libs/taskmanager/"
+KMSAVELIBS="true"
+
+# Disabling tests for now. 3 out of 3 broken now. last tested on 4.0.1.
+RESTRICT="test"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_configure
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # Outsmart our doc-handling, to avoid a collision with plasma.
+ rm -rf "${D}"/${KDEDIR}/share/doc/
+}