summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:21:16 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:21:16 +0000
commit4be3839458456e4b5cc2fec14c207b2d4a234da1 (patch)
treecfa99f022d2f5b84dc5f124d5946c019f5fa3110 /kde-base/kstars
parentAdded the KDE 4.0.5 version of ksquares. (diff)
downloadgentoo-2-4be3839458456e4b5cc2fec14c207b2d4a234da1.tar.gz
gentoo-2-4be3839458456e4b5cc2fec14c207b2d4a234da1.tar.bz2
gentoo-2-4be3839458456e4b5cc2fec14c207b2d4a234da1.zip
Added the KDE 4.0.5 version of kstars.
(Portage version: 2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+)
Diffstat (limited to 'kde-base/kstars')
-rw-r--r--kde-base/kstars/ChangeLog7
-rw-r--r--kde-base/kstars/kstars-4.0.5.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/kde-base/kstars/ChangeLog b/kde-base/kstars/ChangeLog
index 8a19ac52a39a..f24377ec2c40 100644
--- a/kde-base/kstars/ChangeLog
+++ b/kde-base/kstars/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kstars
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.97 2008/05/18 20:29:21 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/ChangeLog,v 1.98 2008/06/05 22:21:16 keytoaster Exp $
+
+*kstars-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org> +kstars-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of kstars.
18 May 2008; Markus Meier <maekke@gentoo.org> kstars-3.5.9.ebuild:
amd64/x86 stable, bug #221063
diff --git a/kde-base/kstars/kstars-4.0.5.ebuild b/kde-base/kstars/kstars-4.0.5.ebuild
new file mode 100644
index 000000000000..4e42a5c771f8
--- /dev/null
+++ b/kde-base/kstars/kstars-4.0.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kstars/kstars-4.0.5.ebuild,v 1.1 2008/06/05 22:21:16 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdeedu
+inherit kde4-meta
+
+DESCRIPTION="KDE Desktop Planetarium"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug fits htmlhandbook nova sbig usb"
+
+DEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ fits? ( sci-libs/cfitsio )
+ nova? ( >=sci-libs/libnova-0.12.1 )
+ sbig? ( sci-libs/indilib
+ usb? ( dev-libs/libusb ) )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ epatch "${FILESDIR}/${PN}-4.0.0-destdir.patch"
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with fits CFitsio)
+ $(cmake-utils_use_with nova Nova)
+ $(cmake-utils_use_with sbig SBIG)
+ $(cmake-utils_use_with usb USB)"
+
+ kde4-meta_src_compile
+
+ # FIXME Unhandled arguments - added sbig but not sure about use descriptions or flag names...
+ # WITH_SBIG - Switch which controls the detection of the proprietary and binary only SBIG CCD universal library. No ebuild for this package
+ # are available at the moment.
+ # ssh_tunnel -> INDI Server binds locally. Remote clients may only connect
+ # via SSH Tunneling.
+}