summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:20:13 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-06-05 22:20:13 +0000
commit8bf53fce0afdcced2f948888bf373075ac72f129 (patch)
tree2d147078bbbc91a0a15851c2632a2426e22250ff /kde-base/ksplash
parentAdded the KDE 4.0.5 version of kspaceduel. (diff)
downloadgentoo-2-8bf53fce0afdcced2f948888bf373075ac72f129.tar.gz
gentoo-2-8bf53fce0afdcced2f948888bf373075ac72f129.tar.bz2
gentoo-2-8bf53fce0afdcced2f948888bf373075ac72f129.zip
Added the KDE 4.0.5 version of ksplash.
(Portage version: 2.2_pre7/cvs/Linux 2.6.25-gentoo-r4 AMD Athlon(tm) 64 X2 Dual Core Processor 4200+)
Diffstat (limited to 'kde-base/ksplash')
-rw-r--r--kde-base/ksplash/ChangeLog8
-rw-r--r--kde-base/ksplash/ksplash-4.0.5.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ksplash/ChangeLog b/kde-base/ksplash/ChangeLog
index 65e88ddc379b..4d930f3bc852 100644
--- a/kde-base/ksplash/ChangeLog
+++ b/kde-base/ksplash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/ksplash
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.8 2008/05/16 00:23:23 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ChangeLog,v 1.9 2008/06/05 22:20:13 keytoaster Exp $
+
+*ksplash-4.0.5 (05 Jun 2008)
+
+ 05 Jun 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +ksplash-4.0.5.ebuild:
+ Added the KDE 4.0.5 version of ksplash.
*ksplash-4.0.4 (15 May 2008)
diff --git a/kde-base/ksplash/ksplash-4.0.5.ebuild b/kde-base/ksplash/ksplash-4.0.5.ebuild
new file mode 100644
index 000000000000..8b0c46c52ef0
--- /dev/null
+++ b/kde-base/ksplash/ksplash-4.0.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ksplash/ksplash-4.0.5.ebuild,v 1.1 2008/06/05 22:20:13 keytoaster Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+inherit kde4-meta
+
+DESCRIPTION="KDE splashscreen framework (the splashscreen of KDE itself, not of individual apps)"
+KEYWORDS="~amd64 ~x86"
+IUSE="3dnow altivec debug mmx sse sse2 xinerama"
+
+RDEPEND="
+ media-libs/libpng
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_has 3dnow X86_3DNOW)
+ $(cmake-utils_has altivec PPC_ALTIVEC)
+ $(cmake-utils_has mmx X86_MMX)
+ $(cmake-utils_has sse X86_SSE)
+ $(cmake-utils_has sse2 X86_SSE2)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+ kde4-meta_src_compile
+}