summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-05-27 19:38:07 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-05-27 19:38:07 +0000
commitb132d05eaf8230ed41d5a6f35183f36ba274d2b6 (patch)
treebf1c73b9b72330d1854f233798bc07cda4911ea1 /kde-base/kopete
parentAgain, forgot to revbump (diff)
downloadgentoo-2-b132d05eaf8230ed41d5a6f35183f36ba274d2b6.tar.gz
gentoo-2-b132d05eaf8230ed41d5a6f35183f36ba274d2b6.tar.bz2
gentoo-2-b132d05eaf8230ed41d5a6f35183f36ba274d2b6.zip
Revision bump, add patch for gadu, security bug 264613, add v4l2 use flag, bug 265248, add patch for icq, bug 257625
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog10
-rw-r--r--kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch24
-rw-r--r--kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch19
-rw-r--r--kde-base/kopete/kopete-3.5.10-r4.ebuild145
4 files changed, 197 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 402395dec8ee..a486798e00f4 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.188 2009/05/26 17:34:34 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.189 2009/05/27 19:38:07 tampakrap Exp $
+
+*kopete-3.5.10-r4 (27 May 2009)
+
+ 27 May 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kopete-3.5.10-r4.ebuild, +files/kopete-3.5.10-icq-protocol-change2.patch,
+ +files/kopete-3.5.10-libgadu-CVE-2008-4776.patch:
+ Revision bump, add patch for gadu, security bug 264613, add v4l2 use flag,
+ bug 265248, add patch for icq, bug 257625
*kopete-3.5.10-r3 (26 May 2009)
diff --git a/kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch b/kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch
new file mode 100644
index 000000000000..37a4afd4bdbb
--- /dev/null
+++ b/kde-base/kopete/files/kopete-3.5.10-icq-protocol-change2.patch
@@ -0,0 +1,24 @@
+diff -urNpa kopete-3.5.9.orig/kopete/protocols/oscar/liboscar/connection.cpp kopete-3.5.9/kopete/protocols/oscar/liboscar/connection.cpp
+--- kopete-3.5.9.orig/kopete/protocols/oscar/liboscar/connection.cpp 2009-02-04 17:34:44.000000000 +0300
++++ kopete-3.5.9/kopete/protocols/oscar/liboscar/connection.cpp 2009-02-04 17:40:47.000000000 +0300
+@@ -31,6 +31,10 @@
+
+ #include "oscartypeclasses.h"
+
++const Oscar::WORD StarSequences[] = {
++5695, 23595, 23620, 23049, 0x2886, 0x2493, 23620, 23049, 2853, 17372, 1255, 1796, 1657, 13606, 1930, 23918, 31234, 30120, 0x1BEA, 0x5342, 0x30CC, 0x2294, 0x5697, 0x25FA, 0x3C26, 0x3303, 0x078A, 0x0FC5, 0x25D6, 0x26EE,0x7570, 0x7F33, 0x4E94, 0x07C9, 0x7339, 0x42A8
++//0x39B1, 0x1F07
++};
+
+ class ConnectionPrivate
+ {
+@@ -208,7 +212,8 @@ void Connection::forcedSend( Transfer* r
+ void Connection::initSequence()
+ {
+ d->snacSequence = ( KApplication::random() & 0xFFFF );
+- d->flapSequence = ( KApplication::random() & 0xFFFF );
++ int startSequencesIndex = KApplication::random() % ((sizeof StarSequences) / (sizeof StarSequences[0]));
++ d->flapSequence = StarSequences[startSequencesIndex] - 1;
+ }
+
+ void Connection::distribute( Transfer * transfer ) const
diff --git a/kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch b/kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch
new file mode 100644
index 000000000000..84ef79bb71e9
--- /dev/null
+++ b/kde-base/kopete/files/kopete-3.5.10-libgadu-CVE-2008-4776.patch
@@ -0,0 +1,19 @@
+------------------------------------------------------------------------
+r638 | wojtekka | 2008-10-23 23:50:29 +0200 (Thu, 23 Oct 2008) | 2 lines
+
+Poprawka błędu analizowania pakietów GG_NOTIFY_REPLY* znalezionego przez Jakuba Zawadzkiego. Odpowiednio spreparowany pakiet wysłany przez serwer może spowodować naruszenie ochrony pamięci.
+
+------------------------------------------------------------------------
+Index: kopete-3.5.9/kopete/protocols/gadu/libgadu/events.c
+===================================================================
+--- kopete-3.5.9.orig/kopete/protocols/gadu/libgadu/events.c
++++ kopete-3.5.9/kopete/protocols/gadu/libgadu/events.c
+@@ -598,7 +598,7 @@ static int gg_watch_fd_connected(struct
+ if (GG_S_D(n->status)) {
+ unsigned char descr_len = *((char*) n + sizeof(struct gg_notify_reply60));
+
+- if (descr_len < length) {
++ if (sizeof(struct gg_notify_reply60) + descr_len <= length) {
+ if (!(e->event.notify60[i].descr = malloc(descr_len + 1))) {
+ gg_debug(GG_DEBUG_MISC, "// gg_watch_fd_connected() not enough memory for notify data\n");
+ goto fail;
diff --git a/kde-base/kopete/kopete-3.5.10-r4.ebuild b/kde-base/kopete/kopete-3.5.10-r4.ebuild
new file mode 100644
index 000000000000..87191b869a11
--- /dev/null
+++ b/kde-base/kopete/kopete-3.5.10-r4.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.10-r4.ebuild,v 1.1 2009/05/27 19:38:07 tampakrap Exp $
+
+KMNAME=kdenetwork
+EAPI="1"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="jingle ssl xscreensaver slp kernel_linux kdehiddenvisibility"
+PLUGINS="addbookmarks alias autoreplace connectionstatus contactnotes crypt highlight history latex netmeeting nowlistening
+ statistics texteffect translator webpresence"
+PROTOCOLS="gadu groupwise irc jabber oscar msn sametime sms v4l2 winpopup yahoo"
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+# Even more broken tests...
+RESTRICT="test"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="
+ =app-crypt/qca-1.0*
+ >=dev-libs/glib-2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ jabber? (
+ net-dns/libidn
+ )
+ jingle? (
+ dev-libs/expat
+ >=media-libs/speex-1.1.6
+ ~net-libs/ortp-0.7.1
+ )
+ kernel_linux? ( virtual/opengl )
+ sametime? ( =net-libs/meanwhile-1.0* )
+ sms? ( app-mobilephone/gsmlib )
+ xscreensaver? ( x11-libs/libXScrnSaver )
+"
+RDEPEND="
+ ${BOTH_DEPEND}
+ crypt? ( app-crypt/gnupg )
+ latex? (
+ media-gfx/imagemagick
+ virtual/latex-base
+ )
+ ssl? ( =app-crypt/qca-tls-1.0* )
+"
+# !kde-base/kdenetwork is handled by the eclass.
+# gnomemeeting is deprecated and ekiga is not yet ~ppc64
+# only needed for calling
+# netmeeting? ( net-im/gnomemeeting )"
+
+DEPEND="
+ ${BOTH_DEPEND}
+ x11-proto/videoproto
+ kernel_linux? (
+ virtual/os-headers
+ x11-libs/libXv
+ )
+ xscreensaver? ( x11-proto/scrnsaverproto )
+"
+
+pkg_setup() {
+ if use v4l2 && use kernel_linux && ! built_with_use x11-libs/qt:3 opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "x11-libs/qt:3 compiled with OpenGL support."
+ eerror "Please reemerge x11-libs/qt:3 with USE=\"opengl\"."
+ die "Please reemerge x11-libs/qt:3 with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ epatch "${FILESDIR}/${PN}-0.12_alpha1-xscreensaver.patch"
+ epatch "${FILESDIR}/${PN}-3.5.5-icqfix.patch"
+ epatch "${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${PN}-3.5-rolling_icon.patch"
+ epatch "${FILESDIR}/${P}-libgadu-CVE-2008-4776.patch"
+ epatch "${FILESDIR}/${P}-icq-protocol-change2.patch"
+
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use alias || kopete_disable plugin alias
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use crypt || kopete_disable plugin cryptography
+ use highlight || kopete_disable plugin highlight
+ use history || kopete_disable plugin history
+ use latex || kopete_disable plugin latex
+ use netmeeting || kopete_disable plugin netmeeting
+ use nowlistening || kopete_disable plugin nowlistening
+ use statistics || kopete_disable plugin statistics
+ use texteffect || kopete_disable plugin texteffect
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use groupwise || kopete_disable protocol groupwise
+ use irc || kopete_disable protocol irc
+ use jabber || kopete_disable protocol '\$(JABBER)'
+ use oscar || kopete_disable protocol oscar
+ use msn || kopete_disable protocol msn
+ use winpopup || kopete_disable protocol winpopup
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ local myconf="
+ --without-xmms
+ $(use_enable debug testbed)
+ $(use_enable jingle)
+ $(use_enable sametime meanwhile)
+ $(use_enable sms smsgsm)
+ $(use_with xscreensaver)
+ "
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ rm -f "${D}${KDEDIR}"/bin/{stun,relay}server
+}
+
+pkg_postinst() {
+ kde_pkg_postinst
+
+ elog "If you would like to use Off-The-Record encryption, emerge net-im/kopete-otr."
+}