summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2007-05-01 21:54:52 +0000
committerWulf Krueger <philantrop@gentoo.org>2007-05-01 21:54:52 +0000
commit400174912da1cf470429d9e4fd7445fd5671cb3f (patch)
tree919cd7a81ed5328d4f697f00e3a367fa8427122a /kde-base/kopete
parentRemoved mail-mta/qmail (diff)
downloadgentoo-2-400174912da1cf470429d9e4fd7445fd5671cb3f.tar.gz
gentoo-2-400174912da1cf470429d9e4fd7445fd5671cb3f.tar.bz2
gentoo-2-400174912da1cf470429d9e4fd7445fd5671cb3f.zip
Added conditional PDEPEND on net-im/kopete-otr for encryption. Dropped KEYWORDS alpha, ia64, ppc64, sparc, x86-fbsd because of the new use-conditional RDEPEND net-im/kopete-otr. Filed bug 176731 about this.
(Portage version: 2.1.2.5)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog10
-rw-r--r--kde-base/kopete/files/digest-kopete-3.5.6-r16
-rw-r--r--kde-base/kopete/kopete-3.5.6-r1.ebuild126
3 files changed, 141 insertions, 1 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index 8420c19ae8ac..f0d4ba5a938c 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.106 2007/04/29 16:34:48 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.107 2007/05/01 21:54:52 philantrop Exp $
+
+*kopete-3.5.6-r1 (01 May 2007)
+
+ 01 May 2007; Wulf C. Krueger <philantrop@gentoo.org>
+ +kopete-3.5.6-r1.ebuild:
+ Added conditional PDEPEND on net-im/kopete-otr for encryption.
+ Dropped KEYWORDS alpha, ia64, ppc64, sparc, x86-fbsd because of the new
+ use-conditional RDEPEND net-im/kopete-otr. Filed bug 176731 about this.
29 Apr 2007; Carsten Lohrke <carlo@gentoo.org> kopete-3.5.6.ebuild:
Remove virtual/x11 dependency.
diff --git a/kde-base/kopete/files/digest-kopete-3.5.6-r1 b/kde-base/kopete/files/digest-kopete-3.5.6-r1
new file mode 100644
index 000000000000..83ac15f107eb
--- /dev/null
+++ b/kde-base/kopete/files/digest-kopete-3.5.6-r1
@@ -0,0 +1,6 @@
+MD5 07d313f91154d3c2f4620b921277fdc8 kdenetwork-3.5-patchset-01.tar.bz2 2986
+RMD160 288113734e7767a7526f4b9311c1985ac8aa91bf kdenetwork-3.5-patchset-01.tar.bz2 2986
+SHA256 0bbde1adaa4e8fff02c1f1fd6ceb66ec9af14dd19ff64567ab0fd03926d7d05b kdenetwork-3.5-patchset-01.tar.bz2 2986
+MD5 0f428cccc4ea16aa53c427530874c591 kdenetwork-3.5.6.tar.bz2 9245468
+RMD160 2f93badae14fab4d7911c74d2f427e85ca104827 kdenetwork-3.5.6.tar.bz2 9245468
+SHA256 786e6c25d5cba4ed1eeac947c5554d7fe57de593abf6551c58c178043b82475e kdenetwork-3.5.6.tar.bz2 9245468
diff --git a/kde-base/kopete/kopete-3.5.6-r1.ebuild b/kde-base/kopete/kopete-3.5.6-r1.ebuild
new file mode 100644
index 000000000000..a9c6b6e00a77
--- /dev/null
+++ b/kde-base/kopete/kopete-3.5.6-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-3.5.6-r1.ebuild,v 1.1 2007/05/01 21:54:52 philantrop Exp $
+
+KMNAME=kdenetwork
+MAXKDEVER=$PV
+KM_DEPRANGE="3.5.0 $MAXKDEVER"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/kdenetwork-3.5-patchset-01.tar.bz2"
+
+DESCRIPTION="KDE multi-protocol IM client"
+HOMEPAGE="http://kopete.kde.org/"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="jingle sametime ssl xscreensaver slp kernel_linux latex crypt
+ winpopup sms irc yahoo gadu groupwise netmeeting statistics autoreplace
+ connectionstatus contactnotes translator webpresence texteffect highlight
+ alias autoreplace history nowlistening addbookmarks kdehiddenvisibility"
+
+# The kernel_linux? ( ) conditional dependencies are for webcams, not supported
+# on other kernels AFAIK
+BOTH_DEPEND="dev-libs/libxslt
+ dev-libs/libxml2
+ net-dns/libidn
+ >=dev-libs/glib-2
+ app-crypt/qca
+ sametime? ( =net-libs/meanwhile-1.0* )
+ jingle? (
+ >=media-libs/speex-1.1.6
+ dev-libs/expat
+ ~net-libs/ortp-0.7.1 )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrender
+ xscreensaver? ( x11-libs/libXScrnSaver )
+ kernel_linux? ( virtual/opengl )
+ sms? ( app-mobilephone/gsmlib )"
+
+RDEPEND="${BOTH_DEPEND}
+ ssl? ( app-crypt/qca-tls )
+ !kde-base/kopete
+ !kde-base/kdenetwork
+ latex? ( virtual/tetex
+ media-gfx/imagemagick )
+ crypt? ( app-crypt/gnupg )"
+# gnomemeeting is deprecated and ekiga is not yet ~ppc64
+# only needed for calling
+# netmeeting? ( net-im/gnomemeeting )"
+
+PDEPEND="crypt? ( net-im/kopete-otr )"
+
+DEPEND="${BOTH_DEPEND}
+ kernel_linux? ( virtual/os-headers )
+ x11-proto/videoproto
+ kernel_linux? ( x11-libs/libXv )
+ xscreensaver? ( x11-proto/scrnsaverproto )"
+
+pkg_setup() {
+ if use kernel_linux && ! built_with_use =x11-libs/qt-3* opengl; then
+ eerror "To support Video4Linux webcams in this package is required to have"
+ eerror "=x11-libs/qt-3* compiled with OpenGL support."
+ eerror "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ die "Please reemerge =x11-libs/qt-3* with USE=\"opengl\"."
+ fi
+}
+
+kopete_disable() {
+ einfo "Disabling $2 $1"
+ sed -i -e "s/$2//" "${S}/kopete/$1s/Makefile.am"
+}
+
+src_unpack() {
+ kde-meta_src_unpack
+
+ epatch "${FILESDIR}/kopete-0.12_alpha1-xscreensaver.patch"
+ # use ekiga instead of gnomemeeting by default
+ epatch "${FILESDIR}/gnomemeeting-ekiga.patch"
+
+ epatch "${FILESDIR}/${PN}-3.5.5-icqfix.patch"
+
+ epatch "${FILESDIR}/kdenetwork-3.5.5-linux-headers-2.6.18.patch"
+
+ use latex || kopete_disable plugin latex
+ use crypt || kopete_disable plugin cryptography
+ use netmeeting || kopete_disable plugin netmeeting
+ use statistics || kopete_disable plugin statistics
+ use autoreplace || kopete_disable plugin autoreplace
+ use connectionstatus || kopete_disable plugin connectionstatus
+ use contactnotes || kopete_disable plugin contactnotes
+ use translator || kopete_disable plugin translator
+ use webpresence || kopete_disable plugin webpresence
+ use texteffect || kopete_disable plugin texteffect
+ use highlight || kopete_disable plugin highlight
+ use alias || kopete_disable plugin alias
+ use addbookmarks || kopete_disable plugin addbookmarks
+ use history || kopete_disable plugin history
+ use nowlistening || kopete_disable plugin nowlistening
+
+ use winpopup || kopete_disable protocol winpopup
+ use gadu || kopete_disable protocol '\$(GADU)'
+ use irc || kopete_disable protocol irc
+ use groupwise || kopete_disable protocol groupwise
+ use yahoo || kopete_disable protocol yahoo
+
+ rm -f "${S}/configure"
+}
+
+src_compile() {
+ # External libgadu support - doesn't work, kopete requires a specific development snapshot of libgadu.
+ # Maybe we can enable it in the future.
+ local myconf="$(use_enable jingle)
+ $(use_enable sametime sametime-plugin)
+ --without-xmms --without-external-libgadu
+ $(use_with xscreensaver) $(use_enable sms smsgsm)
+ $(use_enable debug testbed)"
+
+ kde_src_compile
+}
+
+src_install() {
+ kde_src_install
+
+ rm -f "${D}${KDEDIR}"/bin/{stun,relay}server
+}