summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 19:26:27 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 19:26:27 +0000
commit107f2036945402969be426392b7328fbc38620e0 (patch)
tree08954bbebd0d79f494a909338f02e58ca7efc795 /kde-base/kopete
parentBump shiny new KDE 4.2.0 (diff)
downloadgentoo-2-107f2036945402969be426392b7328fbc38620e0.tar.gz
gentoo-2-107f2036945402969be426392b7328fbc38620e0.tar.bz2
gentoo-2-107f2036945402969be426392b7328fbc38620e0.zip
Bump shiny new KDE 4.2.0
(Portage version: 2.2_rc23/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kopete')
-rw-r--r--kde-base/kopete/ChangeLog7
-rw-r--r--kde-base/kopete/kopete-4.2.0.ebuild140
-rw-r--r--kde-base/kopete/metadata.xml63
3 files changed, 181 insertions, 29 deletions
diff --git a/kde-base/kopete/ChangeLog b/kde-base/kopete/ChangeLog
index e987681f49e2..85c5deeab8dc 100644
--- a/kde-base/kopete/ChangeLog
+++ b/kde-base/kopete/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kopete
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.165 2009/01/14 15:23:31 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/ChangeLog,v 1.166 2009/01/27 19:26:27 alexxy Exp $
+
+*kopete-4.2.0 (27 Jan 2009)
+
+ 27 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +kopete-4.2.0.ebuild:
+ Bump KDE-4.2.0
14 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> -kopete-4.1.2.ebuild,
-kopete-4.1.3.ebuild:
diff --git a/kde-base/kopete/kopete-4.2.0.ebuild b/kde-base/kopete/kopete-4.2.0.ebuild
new file mode 100644
index 000000000000..cb94fc107478
--- /dev/null
+++ b/kde-base/kopete/kopete-4.2.0.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kopete/kopete-4.2.0.ebuild,v 1.1 2009/01/27 19:26:27 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdenetwork"
+inherit kde4-meta
+
+DESCRIPTION="KDE multi-protocol IM client"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook ssl"
+
+# Available plugins
+#
+# addbookmarks: NO DEPS
+# alias: NO DEPS
+# autoreplace: NO DEPS
+# contactnotes: NO DEPS
+# highlight: NO DEPS
+# history: NO DEPS
+# latex: virtual/latex as RDEPEND
+# nowlistening: NO DEPS
+# otr: libotr
+# pipes: NO DEPS
+# privacy: NO DEPS
+# statistics: dev-db/sqlite:3
+# texteffect: NO DEPS
+# translator: NO DEPS
+# urlpicpreview: NO DEPS
+# webpresence: libxml2 libxslt
+# NOTE: By default we enable all plugins that don't have any dependencies
+PLUGINS="+addbookmarks +alias +autoreplace +contactnotes +highlight +history latex
++nowlistening otr +pipes +privacy +statistics +texteffect +translator +urlpicpreview webpresence"
+
+# Available protocols
+#
+# bonjour: NO DEPS
+# gadu: openssl
+# groupwise: app-crypt/qca:2
+# irc: NO DEPS, probably will fail so inform user about it
+# jabber: net-dns/libidn app-crypt/qca:2 ENABLED BY DEFAULT NETWORK
+# jingle: media-libs/speex net-libs/ortp
+# meanwhile: net-libs/meanwhile
+# msn: libmsn
+# oscar: NO DEPS
+# qq: NO DEPS
+# sms: NO DEPS
+# telepathy: net-libs/decibel
+# testbed: NO DEPS
+# winpopup: NO DEPS
+# wlm: libmsn
+# yahoo: NO DEPS
+PROTOCOLS="bonjour gadu groupwise +jabber jingle meanwhile msn oscar qq
+testbed winpopup wlm yahoo"
+
+# disabled protocols
+# telepathy: net-libs/decibel
+# irc: NO DEPS
+
+IUSE="${IUSE} ${PLUGINS} ${PROTOCOLS}"
+
+# Tests are KDE-ish.
+RESTRICT="test"
+
+COMMONDEPEND="
+ dev-libs/libpcre
+ x11-libs/libXScrnSaver
+ gadu? ( dev-libs/openssl )
+ groupwise? ( app-crypt/qca:2 )
+ jabber? (
+ app-crypt/qca:2
+ net-dns/libidn
+ jingle? (
+ >=media-libs/speex-1.2_rc1
+ >=net-libs/ortp-0.13
+ )
+ )
+ meanwhile? ( net-libs/meanwhile )
+ msn? ( net-libs/libmsn )
+ otr? ( net-libs/libotr )
+ statistics? ( dev-db/sqlite:3 )
+ webpresence? ( dev-libs/libxml2 dev-libs/libxslt )
+ wlm? ( net-libs/libmsn )
+"
+RDEPEND="${COMMONDEPEND}
+ latex? ( virtual/latex-base )
+"
+# telepathy? ( net-libs/decibel )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/scrnsaverproto
+"
+PDEPEND="
+ ssl? ( app-crypt/qca-ossl )
+"
+
+src_configure() {
+ local x
+ # Xmms isn't in portage, thus forcefully disabled.
+ mycmakeargs="${mycmakeargs} -DWITH_Xmms=OFF"
+ # enable protocols
+ for x in ${PROTOCOLS}; do
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ done
+ # enable plugins
+ for x in ${PLUGINS}; do
+ mycmakeargs="${mycmakeargs} $(cmake-utils_use_with ${x/+/})"
+ done
+ # additional defines
+ if use jingle && ! use jabber; then
+ elog "You enabled jingle but not jabber useflag. Jingle is integral part of"
+ elog "jabber protocol."
+ fi
+ if use jabber; then
+ mycmakeargs="${mycmakeargs} -DNO_JINGLE=$(use jingle && echo OFF || echo ON)"
+ fi
+
+ kde4-meta_src_configure
+}
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ #if use telepathy; then
+ # elog "To use kopete telepathy plugins, you need to start gabble first:"
+ # elog "GABBLE_PERSIST=1 telepathy-gabble &"
+ # elog "export TELEPATHY_DATA_PATH=/usr/share/telepathy/managers/"
+ #fi
+
+ elog "The messenger plugin has been renamed to wlm - adjust your use flags accordingly."
+
+ if ! use ssl; then
+ if use jabber || use wlm; then # || use irc; then
+ echo
+ elog "In order to use ssl in jabber, wlm and irc you'll need to"
+ elog "install app-crypt/qca-ossl package."
+ echo
+ fi
+ fi
+}
diff --git a/kde-base/kopete/metadata.xml b/kde-base/kopete/metadata.xml
index e698db3273f7..930cdcde6ca6 100644
--- a/kde-base/kopete/metadata.xml
+++ b/kde-base/kopete/metadata.xml
@@ -1,34 +1,41 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<use>
- <flag name="addbookmarks">Enable the addbookmarks plugin</flag>
- <flag name="alias">Enable the alias plugin</flag>
- <flag name="autoreplace">Enable the autoreplace plugin</flag>
- <flag name="connectionstatus">Builds Connection Status plugin</flag>
- <flag name="contactnotes">Enable the contactnotes plugin</flag>
- <flag name="gadu">Enable the gadu protocol plugin</flag>
- <flag name="groupwise">Enable the groupwise protocol plugin</flag>
- <flag name="highlight">Enable the highlight plugin</flag>
- <flag name="history">Enable the history plugin</flag>
- <flag name="irc">Builds IRC protocol handler</flag>
- <flag name="jabber">Enable the Jabber protocol plugin</flag>
- <flag name="nowlistening">Enable the nowlistening plugin</flag>
- <flag name="messenger">Enable the Windows LIVE!-Messenger protocol plugin</flag>
- <flag name="netmeeting">Builds netmeeting plugin (require gnomemeeting)</flag>
- <flag name="otr">Encryption for IMs, using libotr</flag>
- <flag name="pipes">Enable support for the pipes plugin</flag>
- <flag name="privacy">plugin to selectively filter messages</flag>
- <flag name="qq">enable support for the chinese network protocol</flag>
- <flag name="sametime">Enables support for the Sametime protocol for instant messaging</flag>
- <flag name="sms">Enable the sms protocol plugin</flag>
- <flag name="statistics">Enable the statistics plugin</flag>
- <flag name="testbed">Enable the testbed protocol plugin</flag>
- <flag name="texteffect">Enable the texteffect plugin</flag>
- <flag name="translator">Enable the translator plugin</flag>
- <flag name="urlpicpreview">plugin to allow users to send photos through URLs</flag>
- <flag name="webpresence">Enable the webpresence plugin</flag>
- <flag name="winpopup">Enable support for the winpopup plugin</flag>
+ <use>
+ <!-- PLUGINS -->
+ <flag name="addbookmarks">Automaticaly add incoming urls to bookmarks.</flag>
+ <flag name="alias">Enables creating of your own aliases for commands.</flag>
+ <flag name="autoreplace">Automaticaly replace selected text</flag>
+ <flag name="contactnotes">Enables writing personal notes for contacts.</flag>
+ <flag name="highlight">Allows you to specify highlights on specific events.</flag>
+ <flag name="history">Enables saving chat history.</flag>
+ <flag name="latex">Embed latex formatted text into messages.</flag>
+ <flag name="nowlistening">Shows song you currently listen to in your status/etc. Bindings for many players.</flag>
+ <flag name="otr">Allows crypting your chat (drugs and talking nonsense are considered as good alternatives ;]).</flag>
+ <flag name="pipes">Send messages to external pipe.</flag>
+ <flag name="privacy">Filter for incomming messages</flag>
+ <flag name="statistics">Everybody loves statistic graphs, especialy cake ones. ;]</flag>
+ <flag name="texteffect">Various fancy text effects for your messages (dont ever consider writing us with this enabled ;]).</flag>
+ <flag name="translator">Translate incoming and outgoing messages.</flag>
+ <flag name="urlpicpreview">Enables in conversation pictures preview.</flag>
+ <flag name="webpresence">Show your status and some more informations on web.</flag>
+ <!-- PROTOCOLS -->
+ <flag name="bonjour">Enable Link-Local Messaging via the bonjour protocol.</flag>
+ <flag name="gadu">Enable the Gadu protocol handler.</flag>
+ <flag name="groupwise">Enable the Groupwise protocol handler.</flag>
+ <flag name="irc">Enable the IRC protocol handler.</flag>
+ <flag name="jabber">Enable XMPP protocol handler (this is also gmail).</flag>
+ <flag name="meanwhile">Enable the Sametime protocol handler.</flag>
+ <flag name="messenger">Enable support for MSN and Windows live protocols (old implementation).</flag>
+ <flag name="msn">Enable support for MSN (old microsoft protocol).</flag>
+ <flag name="oscar">Enable support for AIM and ICQ protocols.</flag>
+ <flag name="qq">enable support for the chinese network protocol.</flag>
+ <flag name="sms">Enable the sms sending plugin.</flag>
+ <flag name="telepathy">Enable support for the realtime communication framework telepathy.</flag>
+ <flag name="testbed">Enable the testbed protocol.</flag>
+ <flag name="winpopup">Enable pop-up messages sending on windows. (same as good old "net send" messages ;])</flag>
+ <flag name="wlm">Enable "Windows live messenger" protocol support (New protocol from MS).</flag>
+ <flag name="yahoo">Enable yahoo protocol support.</flag>
</use>
<herd>kde</herd>
</pkgmetadata>