summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-05 22:17:51 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-04-05 22:17:51 +0000
commit085f46369864e3db98f52fcc1b04d2f068238aeb (patch)
tree15e884b76264388f1985321514b533e7f0f480e8 /kde-base/kdepim-l10n
parentUse Python 2 (bug #315879). (diff)
downloadgentoo-2-085f46369864e3db98f52fcc1b04d2f068238aeb.tar.gz
gentoo-2-085f46369864e3db98f52fcc1b04d2f068238aeb.tar.bz2
gentoo-2-085f46369864e3db98f52fcc1b04d2f068238aeb.zip
New ebuild for proper localization of kdepim-4.4 packages (when installed together with a newer kde release), fixes bug 336856
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepim-l10n')
-rw-r--r--kde-base/kdepim-l10n/ChangeLog11
-rw-r--r--kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild89
-rw-r--r--kde-base/kdepim-l10n/metadata.xml5
3 files changed, 105 insertions, 0 deletions
diff --git a/kde-base/kdepim-l10n/ChangeLog b/kde-base/kdepim-l10n/ChangeLog
new file mode 100644
index 000000000000..691d2afc491e
--- /dev/null
+++ b/kde-base/kdepim-l10n/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for kde-base/kdepim-l10n
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/ChangeLog,v 1.1 2011/04/05 22:17:51 dilfridge Exp $
+
+*kdepim-l10n-4.4.10 (05 Apr 2011)
+
+ 05 Apr 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +kdepim-l10n-4.4.10.ebuild, +metadata.xml:
+ New ebuild for proper localization of kdepim-4.4 packages (when installed
+ together with a newer kde release), fixes bug 336856
+
diff --git a/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild b/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild
new file mode 100644
index 000000000000..2d8d97c8ecb8
--- /dev/null
+++ b/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-l10n/kdepim-l10n-4.4.10.ebuild,v 1.1 2011/04/05 22:17:51 dilfridge Exp $
+
+EAPI=3
+
+inherit kde4-base
+
+DESCRIPTION="KDE PIM internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+DEPEND="
+ sys-devel/gettext
+"
+RDEPEND=""
+add_blocker kde-l10n 0 :4.4
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+handbook"
+
+MY_LANGS="ar bg ca ca@valencia cs csb da de el en_GB eo es et eu
+ fi fr fy ga gl gu he hi hr hu id is it ja kk km kn ko lt lv
+ mai mk ml nb nds nl nn pa pl pt pt_BR ro ru si sk sl sr sv tg
+ tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for MY_LANG in ${MY_LANGS} ; do
+ IUSE="${IUSE} linguas_${MY_LANG}"
+ SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE}/kde-l10n-${MY_LANG}-4.4.5.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ local LNG DIR
+ if [[ -z ${A} ]]; then
+ elog
+ elog "You either have the LINGUAS variable unset, or it only"
+ elog "contains languages not supported by ${P}."
+ elog "You won't have any additional language support."
+ elog
+ elog "${P} supports these language codes:"
+ elog "${MY_LANGS}"
+ elog
+ fi
+
+ # For EAPI >= 3, or if not using .tar.xz archives:
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # for all linguas do:
+ if [[ -n ${A} ]]; then
+ for LNG in ${LINGUAS}; do
+ DIR="kde-l10n-${LNG}-4.4.5"
+
+ # add subdir to toplevel cmake file
+ if [[ -d "${DIR}" ]] ; then
+ echo "add_subdirectory( ${DIR} )" >> "${S}"/CMakeLists.txt
+ fi
+
+ # remove everything except kdepim
+ for SUBDIR in data docs messages scripts ; do
+ echo > "${S}/${DIR}/${SUBDIR}/CMakeLists.txt"
+ [[ -d "${S}/${DIR}/${SUBDIR}/kdepim" ]] && ( echo "add_subdirectory(kdepim)" >> "${S}/${DIR}/${SUBDIR}/CMakeLists.txt" )
+ done
+ done
+ fi
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_build handbook docs)"
+ [[ -n ${A} ]] && kde4-base_src_configure
+}
+
+src_compile() {
+ [[ -n ${A} ]] && kde4-base_src_compile
+}
+
+src_test() {
+ [[ -n ${A} ]] && kde4-base_src_test
+}
+
+src_install() {
+ [[ -n ${A} ]] && kde4-base_src_install
+}
diff --git a/kde-base/kdepim-l10n/metadata.xml b/kde-base/kdepim-l10n/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/kde-base/kdepim-l10n/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>