summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-05-04 09:54:05 +0000
committerJohannes Huber <johu@gentoo.org>2012-05-04 09:54:05 +0000
commit45320bbcfcb2de6d1e5c5da4a19210b939cdab8f (patch)
tree208cb034cf1664dfd8bcbe744ddd3961de11e95d /kde-base/kdepim-common-libs
parentLive ebuild with USE="internal-glib" for embedded systems wrt #414101 (diff)
downloadgentoo-2-45320bbcfcb2de6d1e5c5da4a19210b939cdab8f.tar.gz
gentoo-2-45320bbcfcb2de6d1e5c5da4a19210b939cdab8f.tar.bz2
gentoo-2-45320bbcfcb2de6d1e5c5da4a19210b939cdab8f.zip
Add upstream patch to fix build with Qt 4.7 wrt #414569. Thanks to upstream maintainer Montel Laurent.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/kdepim-common-libs')
-rw-r--r--kde-base/kdepim-common-libs/ChangeLog8
-rw-r--r--kde-base/kdepim-common-libs/files/kdepim-common-libs-4.8.3-qt47-compat.patch13
-rw-r--r--kde-base/kdepim-common-libs/kdepim-common-libs-4.8.3.ebuild4
3 files changed, 23 insertions, 2 deletions
diff --git a/kde-base/kdepim-common-libs/ChangeLog b/kde-base/kdepim-common-libs/ChangeLog
index 4eede4ce2bff..2976b70f8b6f 100644
--- a/kde-base/kdepim-common-libs/ChangeLog
+++ b/kde-base/kdepim-common-libs/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdepim-common-libs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.31 2012/05/03 20:07:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/ChangeLog,v 1.32 2012/05/04 09:54:05 johu Exp $
+
+ 04 May 2012; Johannes Huber <johu@gentoo.org>
+ +files/kdepim-common-libs-4.8.3-qt47-compat.patch,
+ kdepim-common-libs-4.8.3.ebuild:
+ Add upstream patch to fix build with Qt 4.7 wrt #414569. Thanks to upstream
+ maintainer Montel Laurent.
*kdepim-common-libs-4.8.3 (03 May 2012)
diff --git a/kde-base/kdepim-common-libs/files/kdepim-common-libs-4.8.3-qt47-compat.patch b/kde-base/kdepim-common-libs/files/kdepim-common-libs-4.8.3-qt47-compat.patch
new file mode 100644
index 000000000000..a6c553260feb
--- /dev/null
+++ b/kde-base/kdepim-common-libs/files/kdepim-common-libs-4.8.3-qt47-compat.patch
@@ -0,0 +1,13 @@
+--- a/messageviewer/viewer_p.cpp
++++ b/messageviewer/viewer_p.cpp
+@@ -1930,8 +1930,10 @@ void ViewerPrivate::slotToggleHtmlMode()
+
+ void ViewerPrivate::slotFind()
+ {
++#if QT_VERSION >= 0x040800
+ if ( mViewer->hasSelection() )
+ mFindBar->setText( mViewer->selectedText() );
++#endif
+ mFindBar->show();
+ mFindBar->focusAndSetCursor();
+ }
diff --git a/kde-base/kdepim-common-libs/kdepim-common-libs-4.8.3.ebuild b/kde-base/kdepim-common-libs/kdepim-common-libs-4.8.3.ebuild
index aacd8fcc25cc..80f1818a6f68 100644
--- a/kde-base/kdepim-common-libs/kdepim-common-libs-4.8.3.ebuild
+++ b/kde-base/kdepim-common-libs/kdepim-common-libs-4.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/kdepim-common-libs-4.8.3.ebuild,v 1.1 2012/05/03 20:07:55 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdepim-common-libs/kdepim-common-libs-4.8.3.ebuild,v 1.2 2012/05/04 09:54:05 johu Exp $
EAPI=4
@@ -65,3 +65,5 @@ KMEXTRACTONLY="
"
KMSAVELIBS="true"
+
+PATCHES=( "${FILESDIR}/${P}-qt47-compat.patch" )