summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-08-26 14:43:50 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-08-26 14:43:50 +0000
commite53ded5e994b7be66f2bb3588a2bb629f9b9559a (patch)
treee666ef41a893cf59320e7d4ec0fca9f841e29ebf /kde-base/kdemultimedia
parentWon't work with gaim-0.82 (Manifest recommit) (diff)
downloadgentoo-2-e53ded5e994b7be66f2bb3588a2bb629f9b9559a.tar.gz
gentoo-2-e53ded5e994b7be66f2bb3588a2bb629f9b9559a.tar.bz2
gentoo-2-e53ded5e994b7be66f2bb3588a2bb629f9b9559a.zip
Add two other parallel make compilation fixes (Bug #53847)
Diffstat (limited to 'kde-base/kdemultimedia')
-rw-r--r--kde-base/kdemultimedia/ChangeLog7
-rw-r--r--kde-base/kdemultimedia/files/3.2.3-Makefile-synth.am.diff10
-rw-r--r--kde-base/kdemultimedia/files/3.3.0-Makefile-synth.am.diff10
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.2.3.ebuild5
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.3.0.ebuild3
5 files changed, 31 insertions, 4 deletions
diff --git a/kde-base/kdemultimedia/ChangeLog b/kde-base/kdemultimedia/ChangeLog
index 79e9afd7420a..bf6a5a683420 100644
--- a/kde-base/kdemultimedia/ChangeLog
+++ b/kde-base/kdemultimedia/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdemultimedia
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.119 2004/08/26 14:35:19 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.120 2004/08/26 14:43:50 caleb Exp $
+
+ 26 Aug 2004; Caleb Tennis <caleb@gentoo.org> kdemultimedia-3.2.3.ebuild,
+ kdemultimedia-3.3.0.ebuild, files/3.2.3-Makefile-synth.am.diff,
+ files/3.3.0-Makefile-synth.am.diff:
+ Add two other parallel make compilation fixes (Bug #53847)
26 Aug 2004; Caleb Tennis <caleb@gentoo.org> kdemultimedia-3.3.0.ebuild,
files/3.3.0-Makefile.am.diff:
diff --git a/kde-base/kdemultimedia/files/3.2.3-Makefile-synth.am.diff b/kde-base/kdemultimedia/files/3.2.3-Makefile-synth.am.diff
new file mode 100644
index 000000000000..2ded8a858f29
--- /dev/null
+++ b/kde-base/kdemultimedia/files/3.2.3-Makefile-synth.am.diff
@@ -0,0 +1,10 @@
+--- arts/modules/synth/Makefile.am 2003/08/26 08:43:25 1.8
++++ arts/modules/synth/Makefile.am 2004/08/18 05:52:18 1.9
+@@ -25,6 +25,7 @@ libartsmodulessynth_la_SOURCES = artsmod
+ synth_capture_wav_impl.cc \
+ synth_midi_test_impl.cc synth_sequence_impl.cc synth_sequence_freq_impl.cc \
+ synth_midi_debug_impl.cc objectcache_impl.cc synth_nil_impl.cc synth_debug_impl.cc synth_data_impl.cc
++libartsmodulessynth_la_COMPILE_FIRST = artsmodulessynth.h
+
+ libartsmodulessynth_la_LIBADD = \
+ $(top_builddir)/arts/runtime/libartsbuilder.la \
diff --git a/kde-base/kdemultimedia/files/3.3.0-Makefile-synth.am.diff b/kde-base/kdemultimedia/files/3.3.0-Makefile-synth.am.diff
new file mode 100644
index 000000000000..2ded8a858f29
--- /dev/null
+++ b/kde-base/kdemultimedia/files/3.3.0-Makefile-synth.am.diff
@@ -0,0 +1,10 @@
+--- arts/modules/synth/Makefile.am 2003/08/26 08:43:25 1.8
++++ arts/modules/synth/Makefile.am 2004/08/18 05:52:18 1.9
+@@ -25,6 +25,7 @@ libartsmodulessynth_la_SOURCES = artsmod
+ synth_capture_wav_impl.cc \
+ synth_midi_test_impl.cc synth_sequence_impl.cc synth_sequence_freq_impl.cc \
+ synth_midi_debug_impl.cc objectcache_impl.cc synth_nil_impl.cc synth_debug_impl.cc synth_data_impl.cc
++libartsmodulessynth_la_COMPILE_FIRST = artsmodulessynth.h
+
+ libartsmodulessynth_la_LIBADD = \
+ $(top_builddir)/arts/runtime/libartsbuilder.la \
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.2.3.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.2.3.ebuild
index 598fc9d9c47e..47c2f9a8860f 100644
--- a/kde-base/kdemultimedia/kdemultimedia-3.2.3.ebuild
+++ b/kde-base/kdemultimedia/kdemultimedia-3.2.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.2.3.ebuild,v 1.7 2004/08/12 19:52:03 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.2.3.ebuild,v 1.8 2004/08/26 14:43:50 caleb Exp $
-inherit kde-dist flag-o-matic
+inherit kde-dist flag-o-matic eutils
DESCRIPTION="KDE multimedia apps: noatun, kscd, artsbuilder..."
@@ -23,6 +23,7 @@ DEPEND="~kde-base/kdebase-${PV}
src_unpack() {
kde_src_unpack
+ epatch ${FILESDIR}/3.2.3-Makefile-synth.am.diff
}
src_compile() {
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.3.0.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.3.0.ebuild
index 6f9da1458570..9e4562cbb4f3 100644
--- a/kde-base/kdemultimedia/kdemultimedia-3.3.0.ebuild
+++ b/kde-base/kdemultimedia/kdemultimedia-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.3.0.ebuild,v 1.2 2004/08/26 14:35:19 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.3.0.ebuild,v 1.3 2004/08/26 14:43:50 caleb Exp $
inherit kde-dist flag-o-matic eutils
@@ -24,6 +24,7 @@ DEPEND="~kde-base/kdebase-${PV}
src_unpack() {
kde_src_unpack
epatch ${FILESDIR}/3.3.0-Makefile.am.diff
+ epatch ${FILESDIR}/3.3.0-Makefile-synth.am.diff
}
src_compile() {