summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2003-11-01 15:15:23 +0000
committerCaleb Tennis <caleb@gentoo.org>2003-11-01 15:15:23 +0000
commita06df005618a84ea666d6efba66b0d3793d7f082 (patch)
tree7c23f7ec77e9b5d1fb8d643e4fcc64e67ed18163 /kde-base/kdemultimedia/kdemultimedia-3.2.0_beta1.ebuild
parentNew beta version (diff)
downloadgentoo-2-a06df005618a84ea666d6efba66b0d3793d7f082.tar.gz
gentoo-2-a06df005618a84ea666d6efba66b0d3793d7f082.tar.bz2
gentoo-2-a06df005618a84ea666d6efba66b0d3793d7f082.zip
New beta version
Diffstat (limited to 'kde-base/kdemultimedia/kdemultimedia-3.2.0_beta1.ebuild')
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.2.0_beta1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.2.0_beta1.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.2.0_beta1.ebuild
new file mode 100644
index 000000000000..2d0eb2f0126a
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.2.0_beta1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.2.0_beta1.ebuild,v 1.1 2003/11/01 15:14:01 caleb Exp $
+inherit kde-dist flag-o-matic
+
+IUSE="nas esd motif slang tcltk oggvorbis cdr"
+DESCRIPTION="KDE multimedia apps: noatun, kscd, artsbuilder..."
+KEYWORDS="~x86"
+
+newdepend ">=sys-libs/ncurses-5.2
+ >=media-sound/cdparanoia-3.9.8
+ >=media-libs/libvorbis-1.0_beta4
+ >=media-video/xanim-2.80.1
+ nas? ( >=media-libs/nas-1.4.1 )
+ esd? ( >=media-sound/esound-0.2.22 )
+ motif? ( virtual/motif )
+ slang? ( >=sys-libs/slang-1.4.4 )
+ >=media-sound/mpg123-0.59r
+ tcltk? ( >=dev-lang/tk-8.0.5-r2 )
+ >=dev-libs/glib-1.3.3
+ oggvorbis? ( media-libs/libvorbis )
+ >=media-libs/xine-lib-1_beta10
+ gtk? ( =x11-libs/gtk+-1.2* )
+ alsa? ( >=media-libs/alsa-lib-0.5.9 )"
+
+RDEPEND="$RDEPEND
+ cdr? ( app-cdr/cdrtools >=app-cdr/cdrdao-1.1.5 )"
+
+replace-flags "-O3" "-O2"
+
+myaudio="--enable-audio=oss"
+myinterface="--enable-interface=xaw,ncurses"
+myconf="$myconf --enable-xaw --enable-ncurses"
+myconf="$myconf --with-xine-prefix=/usr"
+
+# make -j2 fails, at least on ppc
+use ppc && export MAKEOPTS="$MAKEOPTS -j1"
+
+# alsa 0.9 not supported
+use alsa && myconf="$myconf --with-alsa --with-arts-alsa" && myaudio="$myaudio,alsa" || myconf="$myconf --without-alsa --disable-alsa"
+use nas && myaudio="$myaudio,nas --with-nas-library=/usr/X11R6/lib/libaudio.so --with-nas-includes=/usr/X11R6/include" || myconf="$myconf --disable-nas"
+use esd && myaudio="$myaudio,esd" || myconf="$myconf --disable-esd"
+use motif && myinterface="$myinterface,motif" && myconf="$myconf --enable-motif"
+use slang && myinterface="$myinterface,slang" && myconf="$myconf --enable-slang"
+use tcltk && myinterface="$myinterface,tcltk" && myconf="$myconf --enable-tcltk"
+use oggvorbis && myconf="$myconf --with-vorbis=/usr" || myconf="$myconf --without-vorbis"
+
+use cdr || DO_NOT_COMPILE="$DO_NOT_COMPILE kaudiocreator"
+
+myconf="$myconf $myaudio $myinterface --with-cdda"
+
+src_unpack() {
+ kde_src_unpack
+}
+
+src_compile() {
+ kde_src_compile
+}