summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 12:01:47 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 12:01:47 +0000
commita3b47394f5ec405135c7f271ab15f4d3152d455c (patch)
tree8429411386f2a62107c35b79c4eaa7c57fc211cc /kde-base/kdemultimedia-kioslaves
parentVersion bump KDE 4.2.4 (diff)
downloadgentoo-2-a3b47394f5ec405135c7f271ab15f4d3152d455c.tar.gz
gentoo-2-a3b47394f5ec405135c7f271ab15f4d3152d455c.tar.bz2
gentoo-2-a3b47394f5ec405135c7f271ab15f4d3152d455c.zip
Version bump KDE 4.2.4
(Portage version: 2.2_rc33/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdemultimedia-kioslaves')
-rw-r--r--kde-base/kdemultimedia-kioslaves/ChangeLog8
-rw-r--r--kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.2.4.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/kde-base/kdemultimedia-kioslaves/ChangeLog b/kde-base/kdemultimedia-kioslaves/ChangeLog
index 8844a530c961..d1f0ab05dcad 100644
--- a/kde-base/kdemultimedia-kioslaves/ChangeLog
+++ b/kde-base/kdemultimedia-kioslaves/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdemultimedia-kioslaves
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.123 2009/06/03 15:21:53 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.124 2009/06/04 12:01:47 alexxy Exp $
+
+*kdemultimedia-kioslaves-4.2.4 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdemultimedia-kioslaves-4.2.4.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org>
-kdemultimedia-kioslaves-4.2.2.ebuild:
diff --git a/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.2.4.ebuild b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.2.4.ebuild
new file mode 100644
index 000000000000..2c4b255bacc8
--- /dev/null
+++ b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.2.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.2.4.ebuild,v 1.1 2009/06/04 12:01:47 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdemultimedia"
+KMMODULE="kioslave"
+inherit kde4-meta
+
+DESCRIPTION="KDE kioslaves from the kdemultimedia package"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +handbook encode flac vorbis"
+
+DEPEND="
+ >=kde-base/libkcddb-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkcompactdisc-${PV}:${SLOT}[kdeprefix=]
+ media-sound/cdparanoia
+ encode? (
+ flac? ( >=media-libs/flac-1.1.2 )
+ vorbis? ( media-libs/libvorbis )
+ )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ libkcompactdisc/
+"
+KMCOMPILEONLY="
+ libkcddb/
+"
+
+KMLOADLIBS="libkcddb"
+
+src_configure() {
+ if use encode; then
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with flac Flac)
+ $(cmake-utils_use_with vorbis OggVorbis)"
+ else
+ mycmakeargs="${mycmakeargs}
+ -DWITH_OggVorbis=OFF -DWITH_Flac=OFF"
+ fi
+
+ kde4-meta_src_configure
+}