summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 15:12:18 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2009-09-01 15:12:18 +0000
commit907d2d93db5df7fab3f9f1ec570d1071409a7e95 (patch)
tree064a8edb37e4a909eeaec72fab86c29c0e3c4e57 /kde-base/kdemultimedia-kioslaves
parentVersion bump KDE 4.3.1 (diff)
downloadgentoo-2-907d2d93db5df7fab3f9f1ec570d1071409a7e95.tar.gz
gentoo-2-907d2d93db5df7fab3f9f1ec570d1071409a7e95.tar.bz2
gentoo-2-907d2d93db5df7fab3f9f1ec570d1071409a7e95.zip
Version bump KDE 4.3.1
(Portage version: 2.2_rc38/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdemultimedia-kioslaves')
-rw-r--r--kde-base/kdemultimedia-kioslaves/ChangeLog8
-rw-r--r--kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.3.1.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/kde-base/kdemultimedia-kioslaves/ChangeLog b/kde-base/kdemultimedia-kioslaves/ChangeLog
index 954e40e53bee..2aae57b2f272 100644
--- a/kde-base/kdemultimedia-kioslaves/ChangeLog
+++ b/kde-base/kdemultimedia-kioslaves/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdemultimedia-kioslaves
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.131 2009/08/04 00:18:15 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/ChangeLog,v 1.132 2009/09/01 15:12:18 tampakrap Exp $
+
+*kdemultimedia-kioslaves-4.3.1 (01 Sep 2009)
+
+ 01 Sep 2009; Theo Chatzimichos <tampakrap@gentoo.org>
+ +kdemultimedia-kioslaves-4.3.1.ebuild:
+ Version bump
*kdemultimedia-kioslaves-4.3.0 (04 Aug 2009)
diff --git a/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.3.1.ebuild b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.3.1.ebuild
new file mode 100644
index 000000000000..397511855db1
--- /dev/null
+++ b/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.3.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia-kioslaves/kdemultimedia-kioslaves-4.3.1.ebuild,v 1.1 2009/09/01 15:12:18 tampakrap Exp $
+
+EAPI="2"
+
+KMNAME="kdemultimedia"
+KMMODULE="kioslave"
+inherit kde4-meta
+
+DESCRIPTION="KDE kioslaves from the kdemultimedia package"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook encode flac vorbis"
+
+# 4 of 9 tests fail. Last checked for 4.2.88
+RESTRICT=test
+
+DEPEND="
+ >=kde-base/libkcddb-${PV}:${SLOT}[kdeprefix=]
+ >=kde-base/libkcompactdisc-${PV}:${SLOT}[kdeprefix=]
+ media-sound/cdparanoia
+ encode? (
+ flac? ( >=media-libs/flac-1.1.2 )
+ vorbis? ( media-libs/libvorbis )
+ )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="
+ libkcompactdisc/
+"
+KMCOMPILEONLY="
+ libkcddb/
+"
+
+KMLOADLIBS="libkcddb"
+
+src_configure() {
+ if use encode; then
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with flac)
+ $(cmake-utils_use_with vorbis OggVorbis)"
+ else
+ mycmakeargs="${mycmakeargs}
+ -DWITH_OggVorbis=OFF -DWITH_Flac=OFF"
+ fi
+
+ kde4-meta_src_configure
+}