summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBo Ørsted Andresen <zlin@gentoo.org>2008-01-29 01:38:40 +0000
committerBo Ørsted Andresen <zlin@gentoo.org>2008-01-29 01:38:40 +0000
commitd414c385385047b2535390baa46ab0c7baf11ea3 (patch)
tree77a60965365a8551d779d14b2f5c28f9597909e0 /kde-base/kdeedu
parentFix HOMEPAGE (and SRC_URI as long as I'm here). Bug #207642 (diff)
downloadgentoo-2-d414c385385047b2535390baa46ab0c7baf11ea3.tar.gz
gentoo-2-d414c385385047b2535390baa46ab0c7baf11ea3.tar.bz2
gentoo-2-d414c385385047b2535390baa46ab0c7baf11ea3.zip
Fix the patch for compilation with USE=-opengl so it doesn't break USE=opengl (bug #207940).
(Portage version: 2.1.4)
Diffstat (limited to 'kde-base/kdeedu')
-rw-r--r--kde-base/kdeedu/ChangeLog7
-rw-r--r--kde-base/kdeedu/files/kdeedu-4.0.0-opengl.patch13
2 files changed, 14 insertions, 6 deletions
diff --git a/kde-base/kdeedu/ChangeLog b/kde-base/kdeedu/ChangeLog
index a9a462baeebf..78b7638a8e42 100644
--- a/kde-base/kdeedu/ChangeLog
+++ b/kde-base/kdeedu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeedu
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/ChangeLog,v 1.228 2008/01/28 23:33:03 philantrop Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/ChangeLog,v 1.229 2008/01/29 01:38:39 zlin Exp $
+
+ 29 Jan 2008; Bo Ørsted Andresen <zlin@gentoo.org>
+ files/kdeedu-4.0.0-opengl.patch:
+ Fix the patch for compilation with USE=-opengl so it doesn't break
+ USE=opengl (bug #207940).
28 Jan 2008; Wulf C. Krueger <philantrop@gentoo.org> kdeedu-3.5.8.ebuild:
Marked stable on amd64 as per bug 207634.
diff --git a/kde-base/kdeedu/files/kdeedu-4.0.0-opengl.patch b/kde-base/kdeedu/files/kdeedu-4.0.0-opengl.patch
index d29e975d37eb..0ca889f566e9 100644
--- a/kde-base/kdeedu/files/kdeedu-4.0.0-opengl.patch
+++ b/kde-base/kdeedu/files/kdeedu-4.0.0-opengl.patch
@@ -10,11 +10,14 @@ Index: kalgebra/src/CMakeLists.txt
algebrahighlighter.cpp
expressionedit.cpp
graph2d.cpp
-@@ -45,6 +44,7 @@
- target_link_libraries(kalgebra ${KDE4_KHTML_LIBS} analitza)
+@@ -33,6 +32,10 @@
+ functionimpl.cpp
+ )
- if(OPENGL_FOUND)
++if(OPENGL_FOUND)
+ set(kalgebra_SRCS ${kalgebra_SRCS} graph3d.cpp)
- target_link_libraries(kalgebra ${QT_QTOPENGL_LIBRARY} ${OPENGL_gl_LIBRARY} ${OPENGL_glu_LIBRARY})
- endif(OPENGL_FOUND)
++endif(OPENGL_FOUND)
++
+ kde4_add_library(analitza ${analitza_SRCS})
+ target_link_libraries(analitza ${QT_QTCORE_LIBRARY} ${QT_QTXML_LIBRARY} ${KDE4_KDECORE_LIBS})