summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-05-07 10:48:07 +0000
commit0650db9ab87aa55db42a5157e24d12132d2832ae (patch)
treefb6d626c063029446861ab8305a09ef01b29fd36 /kde-base/kdebase-data/kdebase-data-4.6.3.ebuild
parentVersion bump. Remove intermediate version. (diff)
downloadgentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.gz
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.tar.bz2
gentoo-2-0650db9ab87aa55db42a5157e24d12132d2832ae.zip
Version bump to KDE SC 4.6.3.
(Portage version: 2.2.0_alpha31/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/kdebase-data/kdebase-data-4.6.3.ebuild')
-rw-r--r--kde-base/kdebase-data/kdebase-data-4.6.3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/kde-base/kdebase-data/kdebase-data-4.6.3.ebuild b/kde-base/kdebase-data/kdebase-data-4.6.3.ebuild
new file mode 100644
index 000000000000..17f2533153e9
--- /dev/null
+++ b/kde-base/kdebase-data/kdebase-data-4.6.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebase-data/kdebase-data-4.6.3.ebuild,v 1.1 2011/05/07 10:47:49 scarabeus Exp $
+
+EAPI=4
+
+KMNAME="kdebase-runtime"
+KMNOMODULE="true"
+inherit kde4-meta
+
+DESCRIPTION="Icons, localization data and various .desktop files from kdebase."
+IUSE=""
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ $(add_kdebase_dep oxygen-icons)
+ x11-themes/hicolor-icon-theme
+"
+
+KMEXTRA="
+ l10n/
+ localization/
+ pics/
+"
+# Note that the eclass doesn't do this for us, because of KMNOMODULE="true".
+KMEXTRACTONLY="
+ config-runtime.h.cmake
+ kde4
+"
+
+src_configure() {
+ # Remove remnants of hicolor-icon-theme
+ sed -e "s:add_subdirectory[[:space:]]*([[:space:]]*hicolor[[:space:]]*):#donotwant:g" \
+ -i pics/CMakeLists.txt \
+ || die "failed to remove remnants of hicolor-icon-theme"
+
+ kde4-meta_src_configure
+}