summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-03-10 23:26:33 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-03-10 23:26:33 +0000
commit738043dcd5e9aa7682220d64e679f7645ac3a236 (patch)
treeabd10348f991c48f23e0eb9f95d03441b33eb764 /kde-base/kde-l10n
parentVersion bump to KDE 4.0.2. (diff)
downloadgentoo-2-738043dcd5e9aa7682220d64e679f7645ac3a236.tar.gz
gentoo-2-738043dcd5e9aa7682220d64e679f7645ac3a236.tar.bz2
gentoo-2-738043dcd5e9aa7682220d64e679f7645ac3a236.zip
Version bump to KDE 4.0.2.
(Portage version: 2.1.4.4)
Diffstat (limited to 'kde-base/kde-l10n')
-rw-r--r--kde-base/kde-l10n/ChangeLog11
-rw-r--r--kde-base/kde-l10n/kde-l10n-4.0.2.ebuild63
2 files changed, 73 insertions, 1 deletions
diff --git a/kde-base/kde-l10n/ChangeLog b/kde-base/kde-l10n/ChangeLog
index 0518df50a9a6..9be2dd40274a 100644
--- a/kde-base/kde-l10n/ChangeLog
+++ b/kde-base/kde-l10n/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for kde-base/kde-l10n
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.4 2008/02/19 11:54:02 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/ChangeLog,v 1.5 2008/03/10 23:26:33 philantrop Exp $
+
+*kde-l10n-4.0.2 (10 Mar 2008)
+
+ 10 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kde-l10n-4.0.2.ebuild:
+ Version bump to 4.0.2.
+
+ 10 Mar 2008; Wulf C. Krueger <philantrop@gentoo.org> ChangeLog:
+ Version bump to KDE 4.0.2
19 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> ChangeLog:
Manifest, bug 210682.
diff --git a/kde-base/kde-l10n/kde-l10n-4.0.2.ebuild b/kde-base/kde-l10n/kde-l10n-4.0.2.ebuild
new file mode 100644
index 000000000000..cc2403acacb3
--- /dev/null
+++ b/kde-base/kde-l10n/kde-l10n-4.0.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kde-l10n/kde-l10n-4.0.2.ebuild,v 1.1 2008/03/10 23:26:33 philantrop Exp $
+
+EAPI="1"
+
+inherit kde4-base
+
+DESCRIPTION="KDE internationalization package"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-devel/gettext-0.15"
+RDEPEND=""
+
+LANGS="ar be bg ca cs csb da de el en_GB eo es et eu fi fr fy ga gl hi hu it ja
+kk km ko lv mk nb nds ne nl nn pa pl pt pt_BR ru se sl sv th tr uk wa zh_CN zh_TW"
+
+URI_BASE="${SRC_URI/-${PV}.tar.bz2/}"
+SRC_URI=""
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+ SRC_URI="${SRC_URI} linguas_${X}? ( ${URI_BASE}/${PN}-${X}-${PV}.tar.bz2 )"
+done
+
+S="${WORKDIR}"
+
+src_unpack() {
+ if [[ -z ${A} ]]; then
+ echo
+ ewarn "You either have the LINGUAS variable unset, or it only"
+ ewarn "contains languages not supported by ${P}."
+ ewarn "You won't have any additional language support."
+ echo
+ ewarn "${P} supports these language codes:"
+ ewarn "${LANGS}"
+ echo
+ fi
+
+ [[ -n ${A} ]] && unpack ${A}
+ cd "${S}"
+
+ # Create a top-level CMakeLists.txt to include the selected LINGUAS as sub-directories of ${S}
+ for dir in * ; do
+ [[ -d ${dir} ]] && echo "add_subdirectory( ${dir} )" >> "${S}"/CMakeLists.txt
+ done
+}
+
+src_compile() {
+ if [[ -n ${A} ]]; then
+ kde4-base_src_compile
+ fi
+}
+
+src_install() {
+ if [[ -n ${A} ]]; then
+ kde4-base_src_install
+ fi
+}