summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 00:58:28 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 00:58:28 +0000
commite05feeb4d7470573c0e28d5cf19c19d76931ffb2 (patch)
tree08deb4a2c9aa15fab96d3415b7fe9db75664b64a /kde-base/kalzium
parentFull auto: Version bump for KDE-4.1.3 (diff)
downloadgentoo-2-e05feeb4d7470573c0e28d5cf19c19d76931ffb2.tar.gz
gentoo-2-e05feeb4d7470573c0e28d5cf19c19d76931ffb2.tar.bz2
gentoo-2-e05feeb4d7470573c0e28d5cf19c19d76931ffb2.zip
Full auto: Version bump for KDE-4.1.3
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-gentoo i686)
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog7
-rw-r--r--kde-base/kalzium/kalzium-4.1.3.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 0bf3aa60e738..1e381183e63e 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.102 2008/10/21 09:20:31 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.103 2008/11/09 00:58:28 scarabeus Exp $
+
+*kalzium-4.1.3 (09 Nov 2008)
+
+ 09 Nov 2008; Tomas Chvatal <scarabeus@gentoo.org> +kalzium-4.1.3.ebuild:
+ Version bump.
21 Oct 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
-kalzium-4.0.4.ebuild, -kalzium-4.0.5.ebuild:
diff --git a/kde-base/kalzium/kalzium-4.1.3.ebuild b/kde-base/kalzium/kalzium-4.1.3.ebuild
new file mode 100644
index 000000000000..e31f030ffaed
--- /dev/null
+++ b/kde-base/kalzium/kalzium-4.1.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-4.1.3.ebuild,v 1.1 2008/11/09 00:58:28 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdeedu
+CPPUNIT_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE: periodic table of the elements."
+KEYWORDS="~amd64 ~x86"
+IUSE="editor debug htmlhandbook solver"
+
+COMMONDEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ editor? ( >=dev-cpp/eigen-1.0.5
+ >=sci-chemistry/openbabel-2.2
+ || ( x11-libs/qt-opengl:4
+ =x11-libs/qt-4.3*:4[opengl] )
+ virtual/opengl )"
+DEPEND="${DEPEND} ${COMMONDEPEND}
+ solver? ( dev-ml/facile[ocamlopt] )"
+RDEPEND="${RDEPEND} ${COMMONDEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui libkdeedu/libscience"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with editor Eigen)
+ $(cmake-utils_use_with editor OpenBabel2)
+ $(cmake-utils_use_with editor OpenGL)
+ $(cmake-utils_use_with solver OCaml)
+ $(cmake-utils_use_with solver Libfacile)"
+
+ sed -i -e "s:add_subdirectory(cmake):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+ sed -i -e "s:add_subdirectory( cmake ):#dontwantit:g" CMakeLists.txt \
+ || die "disabling cmake includes failed"
+
+ kde4-meta_src_configure
+}
+
+src_compile() {
+ if use solver ; then
+ # Compile the solver on its own as the cmake-based build is
+ # currently broken. Fixes bug 206620.
+ cd "${S}/${PN}/src/solver"
+ emake || die "compiling the ocaml resolver failed"
+ mkdir -p "${WORKDIR}/${PN}_build/${PN}/src/"
+ cp * "${WORKDIR}/${PN}_build/${PN}/src/"
+ fi
+ kde4-meta_src_compile
+}