summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
committerJohannes Huber <johu@gentoo.org>2014-08-20 16:02:53 +0000
commitb5a8b2e1508f119b3da9007782069d7554f7973d (patch)
tree3039b14e2a5b6b94c65ead7c9d1b9e21cdab1b44 /kde-base/kaddressbook/kaddressbook-4.14.0.ebuild
parentStable for x86, wrt bug #520220 (diff)
downloadgentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.gz
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.tar.bz2
gentoo-2-b5a8b2e1508f119b3da9007782069d7554f7973d.zip
Version bump KDE SC 4.14.0
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 0xF3CFD2BD)
Diffstat (limited to 'kde-base/kaddressbook/kaddressbook-4.14.0.ebuild')
-rw-r--r--kde-base/kaddressbook/kaddressbook-4.14.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/kde-base/kaddressbook/kaddressbook-4.14.0.ebuild b/kde-base/kaddressbook/kaddressbook-4.14.0.ebuild
new file mode 100644
index 000000000000..f38113aef55d
--- /dev/null
+++ b/kde-base/kaddressbook/kaddressbook-4.14.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kaddressbook/kaddressbook-4.14.0.ebuild,v 1.1 2014/08/20 16:02:39 johu Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+KMNAME="kdepim"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Address Book"
+HOMEPAGE="http://www.kde.org/applications/office/kaddressbook/"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug"
+
+DEPEND="
+ >=dev-libs/grantlee-0.2.0
+ $(add_kdebase_dep kdepimlibs)
+ $(add_kdebase_dep kdepim-common-libs)
+ !kde-base/contactthemeeditor
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="
+ grantleeeditor/contactthemeeditor
+ plugins/kaddressbook/
+ plugins/ktexteditor/
+"
+KMCOMPILEONLY="
+ grantleetheme/
+ kaddressbookgrantlee/
+"
+KMEXTRACTONLY="
+ akonadi_next/
+ calendarsupport/
+ grantleeeditor/grantleethemeeditor/
+ libkleo/
+ pimcommon/
+"
+
+KMLOADLIBS="kdepim-common-libs"
+
+pkg_postinst() {
+ kde4-meta_pkg_postinst
+
+ if ! has_version kde-base/kdepim-kresources:${SLOT}; then
+ echo
+ elog "For groupware functionality, please install kde-base/kdepim-kresources:${SLOT}"
+ echo
+ fi
+}