summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 21:07:06 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-13 21:07:06 +0000
commit5d1a6a01f96256602cb80d96cf991e55d24ff4b3 (patch)
tree2b80052908654687e5f9c1e9450357dd30791f60 /kde-base/dolphin
parentBump kde to 4.1.4 (diff)
downloadgentoo-2-5d1a6a01f96256602cb80d96cf991e55d24ff4b3.tar.gz
gentoo-2-5d1a6a01f96256602cb80d96cf991e55d24ff4b3.tar.bz2
gentoo-2-5d1a6a01f96256602cb80d96cf991e55d24ff4b3.zip
Bump kde to 4.1.4
(Portage version: 2.2_rc21/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog9
-rw-r--r--kde-base/dolphin/dolphin-4.1.4.ebuild30
2 files changed, 37 insertions, 2 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 68456be88414..147aae5b9540 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.16 2008/12/06 19:12:56 patrick Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.17 2009/01/13 21:07:06 alexxy Exp $
+
+*dolphin-4.1.4 (13 Jan 2009)
+
+ 13 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.1.4.ebuild:
+ Bump to 4.1.4
07 Dec 2008; Patrick Lauer <patrick@gentoo.org> dolphin-4.1.3.ebuild:
Adding kde-base/kdebase-data to DEPEND, closes #247984
diff --git a/kde-base/dolphin/dolphin-4.1.4.ebuild b/kde-base/dolphin/dolphin-4.1.4.ebuild
new file mode 100644
index 000000000000..b146b2652b3c
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.1.4.ebuild,v 1.1 2009/01/13 21:07:06 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug htmlhandbook +semantic-desktop"
+
+DEPEND=">=kde-base/libkonq-${PV}:${SLOT}
+ kde-base/kdelibs:${SLOT}[semantic-desktop=]
+ kde-base/kdebase-data:${SLOT}
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}
+ >=dev-libs/soprano-2.0.7 )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_configure
+}