summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 20:23:03 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-03-04 20:23:03 +0000
commit592c1ac5e94ca405bf273a29d7a580356a610b97 (patch)
tree1af8bd1368299f10b64717fae2d3d5af1534b6b4 /kde-base/dolphin
parentBump KDE 4.2.1 (diff)
downloadgentoo-2-592c1ac5e94ca405bf273a29d7a580356a610b97.tar.gz
gentoo-2-592c1ac5e94ca405bf273a29d7a580356a610b97.tar.bz2
gentoo-2-592c1ac5e94ca405bf273a29d7a580356a610b97.zip
Bump KDE 4.2.1
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.2.1.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 4c46d29170e2..9255c84d1b3a 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.22 2009/02/28 10:30:30 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.23 2009/03/04 20:23:03 alexxy Exp $
+
+*dolphin-4.2.1 (04 Mar 2009)
+
+ 04 Mar 2009; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.2.1.ebuild:
+ Bump KDE 4.2.1
28 Feb 2009; Markus Meier <maekke@gentoo.org> metadata.xml:
semantic-desktop is a global USE-flag
diff --git a/kde-base/dolphin/dolphin-4.2.1.ebuild b/kde-base/dolphin/dolphin-4.2.1.ebuild
new file mode 100644
index 000000000000..47b90d031703
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.2.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.2.1.ebuild,v 1.1 2009/03/04 20:23:03 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase"
+KMMODULE="apps/${PN}"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug +semantic-desktop"
+
+DEPEND="
+ >=kde-base/libkonq-${PV}:${SLOT}
+ kde-base/kdelibs:${SLOT}[semantic-desktop=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT} )"
+RDEPEND="${DEPEND}"
+
+KMEXTRA="apps/doc/${PN}"
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+ kde4-meta_src_configure
+}