summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-01-10 11:53:50 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-01-10 11:53:50 +0000
commite34c3a2f03ed8d4afca61c9fe8544134d0418962 (patch)
tree0b1689a47d15be3b02dbcefedaa1c6034759911a /kde-base/dolphin/dolphin-4.5.5.ebuild
parentBug #351274 - Mask prefix USE flag. (diff)
downloadgentoo-2-e34c3a2f03ed8d4afca61c9fe8544134d0418962.tar.gz
gentoo-2-e34c3a2f03ed8d4afca61c9fe8544134d0418962.tar.bz2
gentoo-2-e34c3a2f03ed8d4afca61c9fe8544134d0418962.zip
Version bump KDE SC 4.5.5
Diffstat (limited to 'kde-base/dolphin/dolphin-4.5.5.ebuild')
-rw-r--r--kde-base/dolphin/dolphin-4.5.5.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/dolphin/dolphin-4.5.5.ebuild b/kde-base/dolphin/dolphin-4.5.5.ebuild
new file mode 100644
index 000000000000..43cd513528a6
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.5.5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.5.5.ebuild,v 1.1 2011/01/10 11:53:19 tampakrap Exp $
+
+EAPI="3"
+
+KDE_HANDBOOK="optional"
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep libkonq)
+ semantic-desktop? ( >=dev-libs/shared-desktop-ontologies-0.2 )
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kfind)
+"
+PDEPEND="
+ thumbnail? (
+ || (
+ $(add_kdebase_dep ffmpegthumbs)
+ $(add_kdebase_dep mplayerthumbs)
+ )
+ )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ )
+
+ kde4-meta_src_configure
+}