summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-01-25 14:19:15 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-01-25 14:19:15 +0000
commita78b28ea42b3e360f3866310cc632db48a96c038 (patch)
treea6018ffdd989f83f5fbe22bf1c6eb62c9f8529fe /kde-base/ark
parentVersion bump KDE 4.3.5 (diff)
downloadgentoo-2-a78b28ea42b3e360f3866310cc632db48a96c038.tar.gz
gentoo-2-a78b28ea42b3e360f3866310cc632db48a96c038.tar.bz2
gentoo-2-a78b28ea42b3e360f3866310cc632db48a96c038.zip
Version bump KDE 4.3.5
(Portage version: 2.2_rc61/cvs/Linux x86_64, RepoMan options: --force)
Diffstat (limited to 'kde-base/ark')
-rw-r--r--kde-base/ark/ChangeLog7
-rw-r--r--kde-base/ark/ark-4.3.5.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/kde-base/ark/ChangeLog b/kde-base/ark/ChangeLog
index 868dcea14d77..0ac3a3e2b164 100644
--- a/kde-base/ark/ChangeLog
+++ b/kde-base/ark/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/ark
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.145 2010/01/22 20:57:56 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ChangeLog,v 1.146 2010/01/25 14:19:15 scarabeus Exp $
+
+*ark-4.3.5 (25 Jan 2010)
+
+ 25 Jan 2010; Tomáš Chvátal <scarabeus@gentoo.org> +ark-4.3.5.ebuild:
+ Version bump
22 Jan 2010; Jonathan Callen <abcd@gentoo.org> ark-4.3.4.ebuild:
Keyword ~amd64-linux/~x86-linux
diff --git a/kde-base/ark/ark-4.3.5.ebuild b/kde-base/ark/ark-4.3.5.ebuild
new file mode 100644
index 000000000000..dbaa6bae7ff6
--- /dev/null
+++ b/kde-base/ark/ark-4.3.5.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.3.5.ebuild,v 1.1 2010/01/25 14:19:15 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+archive +bzip2 debug +handbook lzma zip"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+ archive? ( >=app-arch/libarchive-2.6.1[bzip2?,lzma?,zlib] )
+ lzma? ( app-arch/xz-utils )
+ zip? ( >=dev-libs/libzip-0.8 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with bzip2 BZip2)
+ $(cmake-utils_use_with lzma LibLZMA)
+ $(cmake-utils_use_with zip LibZip)
+ )
+ kde4-meta_src_configure
+}