summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 16:26:37 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 16:26:37 +0000
commitef4a82755ad67b0343c65ffe98aba0494d9e2075 (patch)
treecf512e22c020b34f7703c406c8c867c3cee09eed /kde-base/ark/ark-4.2.0.ebuild
parentBump shiny new KDE 4.2.0 (diff)
downloadgentoo-2-ef4a82755ad67b0343c65ffe98aba0494d9e2075.tar.gz
gentoo-2-ef4a82755ad67b0343c65ffe98aba0494d9e2075.tar.bz2
gentoo-2-ef4a82755ad67b0343c65ffe98aba0494d9e2075.zip
Bump shiny new KDE 4.2.0
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'kde-base/ark/ark-4.2.0.ebuild')
-rw-r--r--kde-base/ark/ark-4.2.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/kde-base/ark/ark-4.2.0.ebuild b/kde-base/ark/ark-4.2.0.ebuild
new file mode 100644
index 000000000000..077c9d0aa45a
--- /dev/null
+++ b/kde-base/ark/ark-4.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/ark/ark-4.2.0.ebuild,v 1.1 2009/01/27 16:26:37 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdeutils"
+inherit kde4-meta
+
+DESCRIPTION="KDE Archiving tool"
+KEYWORDS="~amd64 ~x86"
+IUSE="+archive debug htmlhandbook +zip"
+
+DEPEND="archive? ( app-arch/libarchive )
+ zip? ( >=dev-libs/libzip-0.8 )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with archive LibArchive)
+ $(cmake-utils_use_with zip LibZip)"
+
+ kde4-meta_src_configure
+}