summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2008-01-09 12:58:45 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2008-01-09 12:58:45 +0000
commitbba1af723daabc4c2bef2cf98a55e02b2786913a (patch)
tree7a9333372c1d761eef4e72f04a502d93c9a43657 /gnustep-base
parentVersion bump (diff)
downloadgentoo-2-bba1af723daabc4c2bef2cf98a55e02b2786913a.tar.gz
gentoo-2-bba1af723daabc4c2bef2cf98a55e02b2786913a.tar.bz2
gentoo-2-bba1af723daabc4c2bef2cf98a55e02b2786913a.zip
Version bump
(Portage version: 2.1.4_rc14)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog10
-rw-r--r--gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.43
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.0.4.ebuild82
3 files changed, 93 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index d85c49c2e359..51ce29f87e52 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.59 2007/12/08 20:11:58 voyageur Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.60 2008/01/09 12:58:44 voyageur Exp $
+
+*gnustep-make-2.0.4 (09 Jan 2008)
+
+ 09 Jan 2008; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-make-2.0.4.ebuild:
+ Version bump
08 Dec 2007; Bernard Cafarelli <voyageur@gentoo.org> -files/gnustep.csh,
-files/gnustep.sh, -gnustep-make-1.12.0-r1.ebuild,
diff --git a/gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.4 b/gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.4
new file mode 100644
index 000000000000..021c6154ed18
--- /dev/null
+++ b/gnustep-base/gnustep-make/files/digest-gnustep-make-2.0.4
@@ -0,0 +1,3 @@
+MD5 3aef218e5b17999049256892acca7552 gnustep-make-2.0.4.tar.gz 461957
+RMD160 0429777cddb8c7c429545d955c168e5bed507fb7 gnustep-make-2.0.4.tar.gz 461957
+SHA256 60c159673a0acf5ec598747344ddc3d3038482ebe64f910af0b5125cba8d2a44 gnustep-make-2.0.4.tar.gz 461957
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.0.4.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.0.4.ebuild
new file mode 100644
index 000000000000..fc8225510078
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.0.4.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.0.4.ebuild,v 1.1 2008/01/09 12:58:44 voyageur Exp $
+
+inherit gnustep-base eutils
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ gnustep-base_pkg_setup
+
+ if ! built_with_use sys-devel/gcc objc; then
+ ewarn "gcc must be compiled with Objective-C support! See the objc USE flag."
+ die "ObjC support not available"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.0.1-destdir.patch
+}
+
+src_compile() {
+ local myconf
+ myconf="--prefix=${GNUSTEP_PREFIX} --with-layout=gnustep"
+ myconf="$myconf --with-config-file=/etc/GNUstep/GNUstep.conf"
+ myconf="$myconf --enable-native-objc-exceptions"
+ econf $myconf || die "configure failed"
+
+ emake
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ cd Documentation
+ emake -j1 all install || die "doc make has failed"
+ cd ..
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval="-j1"
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ "${D}"${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ exeinto /etc/profile.d
+ doexe "${FILESDIR}"/gnustep-2.sh
+ doexe "${FILESDIR}"/gnustep-2.csh
+
+ dodir /etc/env.d
+ cat <<- EOF > "${D}"/etc/env.d/99gnustep
+PATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+ROOTPATH=${GNUSTEP_SYSTEM_TOOLS}:${GNUSTEP_LOCAL_TOOLS}
+LDPATH=${GNUSTEP_SYSTEM_LIBRARIES}:${GNUSTEP_LOCAL_LIBRARIES}
+MANPATH=${GNUSTEP_SYSTEM_DOC_MAN}:${GNUSTEP_LOCAL_DOC_MAN}
+INFOPATH=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+INFODIR=${GNUSTEP_SYSTEM_DOC_INFO}:${GNUSTEP_LOCAL_DOC_INFO}
+EOF
+}