summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-04-20 17:47:56 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-04-20 17:47:56 +0000
commit89955e3287d4ab7d0721e952bc74531232d4f612 (patch)
treeccd3a061b671405252c5031ac63c6f491972b469 /gnustep-base
parentVersion bump (diff)
downloadgentoo-2-89955e3287d4ab7d0721e952bc74531232d4f612.tar.gz
gentoo-2-89955e3287d4ab7d0721e952bc74531232d4f612.tar.bz2
gentoo-2-89955e3287d4ab7d0721e952bc74531232d4f612.zip
Version bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-back-xlib/ChangeLog10
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.0.ebuild47
2 files changed, 55 insertions, 2 deletions
diff --git a/gnustep-base/gnustep-back-xlib/ChangeLog b/gnustep-base/gnustep-back-xlib/ChangeLog
index 5bc113f186ef..81006baa5c5f 100644
--- a/gnustep-base/gnustep-back-xlib/ChangeLog
+++ b/gnustep-base/gnustep-back-xlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-back-xlib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/ChangeLog,v 1.60 2010/08/20 12:31:42 voyageur Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/ChangeLog,v 1.61 2011/04/20 17:47:56 voyageur Exp $
+
+*gnustep-back-xlib-0.20.0 (20 Apr 2011)
+
+ 20 Apr 2011; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-back-xlib-0.20.0.ebuild:
+ Version bump
20 Aug 2010; Bernard Cafarelli <voyageur@gentoo.org>
-gnustep-back-xlib-0.16.0.ebuild:
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.0.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.0.ebuild
new file mode 100644
index 000000000000..ca0c3669dbc1
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.20.0.ebuild,v 1.1 2011/04/20 17:47:56 voyageur Exp $
+
+inherit gnustep-base
+
+S=${WORKDIR}/gnustep-back-${PV}
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/gnustep-back-${PV}.tar.gz"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="opengl xim"
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ ~gnustep-base/gnustep-gui-${PV}
+ opengl? ( virtual/opengl virtual/glu )
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXft
+ x11-libs/libXrender
+ dev-libs/expat
+ media-libs/fontconfig
+ >=media-libs/freetype-2.1.9
+ !gnustep-base/gnustep-back-art
+ !gnustep-base/gnustep-back-cairo"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}