summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2011-06-06 19:27:59 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2011-06-06 19:27:59 +0000
commit19de5906d81126f9bf0573d1bbaae23998c2ea6b (patch)
tree3070d607bda3d291a965bc7be44903e245ccc116 /gnustep-base
parentEAPI=2; add use deps for bug #369273 (diff)
downloadgentoo-2-19de5906d81126f9bf0573d1bbaae23998c2ea6b.tar.gz
gentoo-2-19de5906d81126f9bf0573d1bbaae23998c2ea6b.tar.bz2
gentoo-2-19de5906d81126f9bf0573d1bbaae23998c2ea6b.zip
Version bump, fix issue compiling with clang
(Portage version: 2.2.0_alpha38/cvs/Linux x86_64)
Diffstat (limited to 'gnustep-base')
-rw-r--r--gnustep-base/gnustep-make/ChangeLog8
-rw-r--r--gnustep-base/gnustep-make/gnustep-make-2.6.1.ebuild84
2 files changed, 91 insertions, 1 deletions
diff --git a/gnustep-base/gnustep-make/ChangeLog b/gnustep-base/gnustep-make/ChangeLog
index a76d1d27d9ae..f00bac660a54 100644
--- a/gnustep-base/gnustep-make/ChangeLog
+++ b/gnustep-base/gnustep-make/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-make
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.98 2011/05/04 14:41:46 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/ChangeLog,v 1.99 2011/06/06 19:27:59 voyageur Exp $
+
+*gnustep-make-2.6.1 (06 Jun 2011)
+
+ 06 Jun 2011; Bernard Cafarelli <voyageur@gentoo.org>
+ +gnustep-make-2.6.1.ebuild:
+ Version bump, fix issue compiling with clang
04 May 2011; Bernard Cafarelli <voyageur@gentoo.org>
gnustep-make-2.6.0.ebuild:
diff --git a/gnustep-base/gnustep-make/gnustep-make-2.6.1.ebuild b/gnustep-base/gnustep-make/gnustep-make-2.6.1.ebuild
new file mode 100644
index 000000000000..13256685c658
--- /dev/null
+++ b/gnustep-base/gnustep-make/gnustep-make-2.6.1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-make/gnustep-make-2.6.1.ebuild,v 1.1 2011/06/06 19:27:59 voyageur Exp $
+
+EAPI="3"
+
+inherit gnustep-base eutils prefix
+
+DESCRIPTION="GNUstep Makefile Package"
+
+HOMEPAGE="http://www.gnustep.org"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+IUSE="native-exceptions"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=sys-devel/gcc-3.3[objc]
+ >=sys-devel/make-3.75"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Multilib-strict
+ sed -e "s#/lib#/$(get_libdir)#" -i FilesystemLayouts/fhs-system || die "sed failed"
+ epatch "${FILESDIR}"/${PN}-2.0.1-destdir.patch
+ cp "${FILESDIR}"/gnustep-4.{csh,sh} "${T}"/
+ eprefixify "${T}"/gnustep-4.{csh,sh}
+}
+
+src_configure() {
+ econf \
+ --with-layout=fhs-system \
+ --with-config-file="${EPREFIX}"/etc/GNUstep/GNUstep.conf \
+ $(use_enable native-exceptions native-objc-exceptions) \
+ || die "configure failed"
+}
+
+src_compile() {
+ emake || die "compilation failed"
+ # Prepare doc here (needed when no gnustep-make is already installed)
+ if use doc ; then
+ # If a gnustep-1 environment is set
+ unset GNUSTEP_MAKEFILES
+ pushd Documentation &> /dev/null
+ emake all install || die "doc make has failed"
+ popd &> /dev/null
+ fi
+}
+
+src_install() {
+ # Get GNUSTEP_* variables
+ . ./GNUstep.conf
+
+ local make_eval
+ use debug || make_eval="${make_eval} debug=no"
+ make_eval="${make_eval} verbose=yes"
+
+ emake ${make_eval} DESTDIR="${D}" install || die "install has failed"
+
+ # Copy the documentation
+ if use doc ; then
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}
+ cp -r Documentation/tmp-installation/System/Library/Documentation \
+ "${ED}"${GNUSTEP_SYSTEM_LIBRARY}
+ fi
+
+ dodoc FAQ README RELEASENOTES
+
+ exeinto /etc/profile.d
+ doexe "${T}"/gnustep-4.sh
+ doexe "${T}"/gnustep-4.csh
+}
+
+pkg_postinst() {
+ # Warn about new layout if old GNUstep directory is still here
+ if [ -e /usr/GNUstep/System ]; then
+ ewarn "Old layout directory detected (/usr/GNUstep/System)"
+ ewarn "Gentoo has switched to FHS layout for GNUstep packages"
+ ewarn "You must first update the configuration files from this package,"
+ ewarn "then remerge all packages still installed with the old layout"
+ ewarn "You can use gnustep-base/gnustep-updater for this task"
+ fi
+}