summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2006-12-05 20:22:42 +0000
committerFabian Groffen <grobian@gentoo.org>2006-12-05 20:22:42 +0000
commita7bc445e0bb18505a031fe3e364b8048c2d9cd36 (patch)
tree4419655952cc977f971a8e743b961072a610b301 /gnustep-base/gnustep-gui
parentRequire kbproto 1.0.3. (diff)
downloadgentoo-2-a7bc445e0bb18505a031fe3e364b8048c2d9cd36.tar.gz
gentoo-2-a7bc445e0bb18505a031fe3e364b8048c2d9cd36.tar.bz2
gentoo-2-a7bc445e0bb18505a031fe3e364b8048c2d9cd36.zip
Version bump
(Portage version: 2.1.1-r2)
Diffstat (limited to 'gnustep-base/gnustep-gui')
-rw-r--r--gnustep-base/gnustep-gui/ChangeLog8
-rw-r--r--gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.11.03
-rw-r--r--gnustep-base/gnustep-gui/files/gsnd.initd8
-rw-r--r--gnustep-base/gnustep-gui/gnustep-gui-0.11.0.ebuild92
4 files changed, 106 insertions, 5 deletions
diff --git a/gnustep-base/gnustep-gui/ChangeLog b/gnustep-base/gnustep-gui/ChangeLog
index 562f8a74bd28..0066b7f7de47 100644
--- a/gnustep-base/gnustep-gui/ChangeLog
+++ b/gnustep-base/gnustep-gui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnustep-base/gnustep-gui
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.42 2006/09/28 04:46:13 tsunam Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/ChangeLog,v 1.43 2006/12/05 20:22:42 grobian Exp $
+
+*gnustep-gui-0.11.0 (05 Dec 2006)
+
+ 05 Dec 2006; Fabian Groffen <grobian@gentoo.org> files/gsnd.initd,
+ +gnustep-gui-0.11.0.ebuild:
+ Version bump
28 Sep 2006; Joshua Jackson <tsunam@gentoo.org> gnustep-gui-0.10.3.ebuild:
Stable x86; bug #139385
diff --git a/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.11.0 b/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.11.0
new file mode 100644
index 000000000000..8a2a4f748b0c
--- /dev/null
+++ b/gnustep-base/gnustep-gui/files/digest-gnustep-gui-0.11.0
@@ -0,0 +1,3 @@
+MD5 7821a516ce5f683885116d78ac09b79e gnustep-gui-0.11.0.tar.gz 1602044
+RMD160 9428d9f0e3f3487b62499d7dfb716d58d5567d2d gnustep-gui-0.11.0.tar.gz 1602044
+SHA256 cdce927b9ed55bccf38f04378bd1687404719050a6cf680bd833a53c224bb2a2 gnustep-gui-0.11.0.tar.gz 1602044
diff --git a/gnustep-base/gnustep-gui/files/gsnd.initd b/gnustep-base/gnustep-gui/files/gsnd.initd
index ff67d53156bb..170d4d3b4398 100644
--- a/gnustep-base/gnustep-gui/files/gsnd.initd
+++ b/gnustep-base/gnustep-gui/files/gsnd.initd
@@ -1,7 +1,7 @@
#!/sbin/runscript
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2006 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/files/gsnd.initd,v 1.1 2006/03/25 08:57:34 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/files/gsnd.initd,v 1.2 2006/12/05 20:22:42 grobian Exp $
service_name="GNUstep sound daemon"
@@ -21,7 +21,7 @@ start() {
# Source GNUstep makefile
. ${GNUSTEP_SYSTEM_ROOT}/Makefiles/GNUstep.sh
else
- exit 1
+ return 1
fi
if [ -z "$GNUSTEP_FLATTENED" ];
@@ -41,5 +41,5 @@ stop() {
ebegin "Stopping ${service_name}"
# Kill processes
- killall gnustep_sndd
+ killall gnustep_sndd >& /dev/null
}
diff --git a/gnustep-base/gnustep-gui/gnustep-gui-0.11.0.ebuild b/gnustep-base/gnustep-gui/gnustep-gui-0.11.0.ebuild
new file mode 100644
index 000000000000..5f600e025c77
--- /dev/null
+++ b/gnustep-base/gnustep-gui/gnustep-gui-0.11.0.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-gui/gnustep-gui-0.11.0.ebuild,v 1.1 2006/12/05 20:22:42 grobian Exp $
+
+inherit gnustep
+
+DESCRIPTION="Library of GUI classes written in Obj-C"
+HOMEPAGE="http://www.gnustep.org/"
+SRC_URI="ftp://ftp.gnustep.org/pub/gnustep/core/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+IUSE="${IUSE} jpeg gif png gsnd doc cups"
+
+DEPEND="${GNUSTEP_CORE_DEPEND}
+ >=gnustep-base/gnustep-make-1.12.0
+ >=gnustep-base/gnustep-base-1.12.0
+ || (
+ ( x11-libs/libXt )
+ virtual/x11
+ )
+ >=media-libs/tiff-3
+ jpeg? ( >=media-libs/jpeg-6b )
+ gif? ( >=media-libs/giflib-4.1 )
+ png? ( >=media-libs/libpng-1.2 )
+ gsnd? (
+ >=media-libs/audiofile-0.2
+ )
+ cups? ( >=net-print/cups-1.1 )
+ app-text/aspell"
+# gsnd needs a recent portaudio that's not in the tree yet
+# =media-libs/portaudio-19*
+RDEPEND="${DEPEND}
+ ${DEBUG_DEPEND}
+ ${DOC_RDEPEND}"
+
+egnustep_install_domain "System"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+
+# if use gsnd;
+# then
+# sed -i -e "s:#include <portaudio.h>:#include <portaudio-2/portaudio.h>:g" ${S}/Tools/gsnd/gsnd.m
+# sed -i -e "s:-lportaudio:-lportaudio-2:g" ${S}/Tools/gsnd/GNUmakefile
+# sed -i -e "s:^BUILD_GSND=.*$:BUILD_GSND=gsnd:g" ${S}/config.make.in
+# fi
+}
+
+src_compile() {
+ egnustep_env
+
+ myconf="--with-tiff-include=/usr/include --with-tiff-library=/usr/lib"
+ use gif && myconf="$myconf --disable-ungif --enable-libgif"
+ myconf="$myconf `use_enable jpeg`"
+ myconf="$myconf `use_enable png`"
+ myconf="$myconf `use_enable cups`"
+
+ if use gsnd;
+ then
+ myconf="$myconf `use_enable gsnd`"
+ myconf="$myconf --with-audiofile-include=/usr/include --with-audiofile-lib=/usr/lib"
+# myconf="$myconf --with-include-flags=-I/usr/include/portaudio-2"
+ fi
+
+ econf $myconf || die "configure failed"
+
+ egnustep_make || die
+
+ if use doc;
+ then
+ cd ${S}/Documentation
+ egnustep_make || die
+ fi
+}
+
+src_install() {
+ egnustep_env
+ egnustep_install || die
+
+ if use doc;
+ then
+ cd ${S}/Documentation
+ egnustep_install || die
+ fi
+
+ use gsnd && newinitd ${FILESDIR}/gsnd.initd gsnd
+}