summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-05 19:43:20 +0000
commit57cfcbec70fd3ce8babfc5de34d5625964a04295 (patch)
treecd9d7a36b1389f7e6327a7101803aecbf8662d58 /gnome-libs
parent- bah. forgot digest. (diff)
downloadgentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.tar.gz
gentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.tar.bz2
gentoo-2-57cfcbec70fd3ce8babfc5de34d5625964a04295.zip
*** empty log message ***
Diffstat (limited to 'gnome-libs')
-rw-r--r--gnome-libs/eel/eel-1.0.ebuild11
-rw-r--r--gnome-libs/libgda/files/digest-libgda-0.2.91
-rw-r--r--gnome-libs/libgda/libgda-0.2.9.ebuild61
-rw-r--r--gnome-libs/medusa/medusa-0.5.1.ebuild11
4 files changed, 76 insertions, 8 deletions
diff --git a/gnome-libs/eel/eel-1.0.ebuild b/gnome-libs/eel/eel-1.0.ebuild
index b3e86d8c4c7f..157dce3bc524 100644
--- a/gnome-libs/eel/eel-1.0.ebuild
+++ b/gnome-libs/eel/eel-1.0.ebuild
@@ -9,8 +9,15 @@ DESCRIPTION="eel"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND=">=gnome-base/gnome-core-1.4
- >=gnome-base/gconf-1.0
+DEPEND=">=gnome-base/gnome-vfs-1.0.1
+ >=gnome-base/gdk-pixbuf-0.11.0
+ >=media-libs/freetype-2.0.1
+ >=gnome-libs/librsvg-1.0
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+RDEPEND=">=media-libs/freetype-2.0.1
+ >=gnome-base/gnome-vfs-1.0.1
+ >=gnome-base/gdk-pixbuf-0.11.0
>=gnome-libs/librsvg-1.0"
src_compile() {
diff --git a/gnome-libs/libgda/files/digest-libgda-0.2.9 b/gnome-libs/libgda/files/digest-libgda-0.2.9
new file mode 100644
index 000000000000..5f45483be561
--- /dev/null
+++ b/gnome-libs/libgda/files/digest-libgda-0.2.9
@@ -0,0 +1 @@
+MD5 572b2b19a2e959aaa150ab490c57fb76 libgda-0.2.9.tar.gz
diff --git a/gnome-libs/libgda/libgda-0.2.9.ebuild b/gnome-libs/libgda/libgda-0.2.9.ebuild
new file mode 100644
index 000000000000..b6ce9e4a5664
--- /dev/null
+++ b/gnome-libs/libgda/libgda-0.2.9.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gda lib"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/gnome-db/${A}"
+HOMEPAGE="http://www.gnome.org/gnome-db"
+
+DEPEND="virtual/glibc sys-apps/which
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ >=gnome-base/gconf-0.11
+ >=dev-perl/CORBA-ORBit-0.4.3
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-0.11
+ >=sys-libs/gdbm-1.8.0
+ >=sys-libs/readline-4.1
+ mysql? ( >=dev-db/mysql-3.23.26 )
+ postgres? ( >=dev-db/postgresql-7.1 )
+ odbc? ( >=dev-db/unixODBC-1.8.13 )
+ ldap? ( >=net-nds/openldap-1.2.11 )"
+
+src_compile() {
+ local myconf
+ if [ "`use mysql`" ] ; then
+ myconf="--with-mysql=/usr"
+ fi
+ if [ "`use ldap`" ] ; then
+ myconf="$myconf --with-ldap=/usr"
+ fi
+ if [ "`use odbc`" ]; then
+ myconf="$myconf --with-odbc"
+ fi
+ if [ "`use postgres`" ]; then
+ myconf="$myconf --with-postgres=/usr"
+ fi
+
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome $myconf
+ try make LDFLAGS=\"-lncurses\" LIBREADLINE=\"-lreadline -lncurses\"
+}
+
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=/etc/opt/gnome \
+ PREFIX=${D}/usr INSTALLMAN3DIR=${D}/usr/share/man/man3 \
+ GDA_oafinfodir=${D}/opt/gnome/share/oaf install
+ into /usr
+ dobin providers/gda-default-server/build_sqlite/{lemon,sqlite}
+ dodoc AUTHORS COPYING.* ChangeLog NEWS README
+}
+
+
+
+
diff --git a/gnome-libs/medusa/medusa-0.5.1.ebuild b/gnome-libs/medusa/medusa-0.5.1.ebuild
index b8ea4d049cf9..09e19f755fe5 100644
--- a/gnome-libs/medusa/medusa-0.5.1.ebuild
+++ b/gnome-libs/medusa/medusa-0.5.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-libs/medusa/medusa-0.5.1.ebuild,v 1.1 2001/05/10 01:50:35 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-libs/medusa/medusa-0.5.1.ebuild,v 1.2 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,19 +10,18 @@ SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${A}
ftp://gnome.eazel.com/pub/gnome/stable/sources/${PN}/${A}"
HOMEPAGE="http://www.gnome.org/"
-DEPEND=">=gnome-base/gnome-vfs-1.0
- >=sys-libs/db-1.8"
+DEPEND=">=gnome-base/gnome-vfs-1.0"
-src_compile() {
+src_compile() {
try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --sysconfdir=/etc/opt/gnome --mandir=/opt/gnome/share/man \
+ --sysconfdir=/etc/opt/gnome --mandir=/opt/gnome/man \
--sharedstatedir=/var/lib --localstatedir=/var/lib --enable-prefere-db1
try make medusainitdir=/tmp
}
src_install() {
try make prefix=${D}/opt/gnome sysconfdir=${D}/etc/opt/gnome \
- medusainitdir=/tmp mandir=${D}/opt/gnome/share/man install
+ medusainitdir=/tmp mandir=${D}/opt/gnome/man install
dodoc AUTHORS COPYING ChangeLog NEWS README
}