summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-11-13 12:14:33 +0000
committerPacho Ramos <pacho@gentoo.org>2014-11-13 12:14:33 +0000
commitfd72175a0d254a5b13f93ac31122d5e76a7eb2e2 (patch)
treecda33a99c93cec20b0befa34e51cfb8d64835f25 /gnome-extra
parentDrop package due bug #508854 (diff)
downloadgentoo-2-fd72175a0d254a5b13f93ac31122d5e76a7eb2e2.tar.gz
gentoo-2-fd72175a0d254a5b13f93ac31122d5e76a7eb2e2.tar.bz2
gentoo-2-fd72175a0d254a5b13f93ac31122d5e76a7eb2e2.zip
Drop old (#508854)
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/yelp/ChangeLog9
-rw-r--r--gnome-extra/yelp/files/yelp-2.30.2-freeze-move.patch116
-rw-r--r--gnome-extra/yelp/files/yelp-2.30.2-gthread.patch12
-rw-r--r--gnome-extra/yelp/files/yelp-2.30.2-print-crash.patch38
-rw-r--r--gnome-extra/yelp/files/yelp-2.30.2-uri-handler.patch28
-rw-r--r--gnome-extra/yelp/files/yelp-2.30.2-xz-support.patch229
-rw-r--r--gnome-extra/yelp/yelp-2.30.2-r200.ebuild73
-rw-r--r--gnome-extra/yelp/yelp-3.10.2.ebuild54
8 files changed, 8 insertions, 551 deletions
diff --git a/gnome-extra/yelp/ChangeLog b/gnome-extra/yelp/ChangeLog
index f798f1872aee..2a690e37d060 100644
--- a/gnome-extra/yelp/ChangeLog
+++ b/gnome-extra/yelp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/yelp
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.316 2014/07/23 15:18:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/ChangeLog,v 1.317 2014/11/13 12:14:33 pacho Exp $
+
+ 13 Nov 2014; Pacho Ramos <pacho@gentoo.org>
+ -files/yelp-2.30.2-freeze-move.patch, -files/yelp-2.30.2-gthread.patch,
+ -files/yelp-2.30.2-print-crash.patch, -files/yelp-2.30.2-uri-handler.patch,
+ -files/yelp-2.30.2-xz-support.patch, -yelp-2.30.2-r200.ebuild,
+ -yelp-3.10.2.ebuild:
+ Drop old (#508854)
23 Jul 2014; Agostino Sarubbo <ago@gentoo.org> yelp-3.12.0.ebuild:
Stable for x86, wrt bug #512012
diff --git a/gnome-extra/yelp/files/yelp-2.30.2-freeze-move.patch b/gnome-extra/yelp/files/yelp-2.30.2-freeze-move.patch
deleted file mode 100644
index 2b5e1840fde5..000000000000
--- a/gnome-extra/yelp/files/yelp-2.30.2-freeze-move.patch
+++ /dev/null
@@ -1,116 +0,0 @@
-commit fd70739a133053042360d14fd7e6bc9db884e021
-Author: Vincent Untz <vuntz@gnome.org>
-Date: Sun Feb 20 16:00:00 2011 +0100
-
- Fix small freezes when moving window
-
- This is similar to ce9025ff: we only save the window size after a
- timeout, to stop always saving a file which calls fsync() and is
- therefore slow.
-
- We also don't save the size if it hasn't changed.
-
- https://bugzilla.gnome.org/show_bug.cgi?id=642813
-
-diff --git a/src/yelp-window.c b/src/yelp-window.c
-index abad787..ea57576 100644
---- a/src/yelp-window.c
-+++ b/src/yelp-window.c
-@@ -284,6 +284,10 @@ struct _YelpWindowPriv {
- gulong cancel_handler;
- gulong finish_handler;
-
-+ guint resize_timeout;
-+ gint saved_width;
-+ gint saved_height;
-+
- gint toc_pause;
-
- GtkActionGroup *action_group;
-@@ -510,8 +514,12 @@ window_init (YelpWindow *window)
- width = YELP_CONFIG_WIDTH_DEFAULT;
- if (height == 0)
- height = YELP_CONFIG_HEIGHT_DEFAULT;
-+
- }
-
-+ window->priv->saved_width = width;
-+ window->priv->saved_height = height;
-+
- g_free (config_path);
- g_key_file_free (keyfile);
-
-@@ -538,6 +546,10 @@ window_finalize (GObject *object)
- YelpWindow *window = YELP_WINDOW (object);
- YelpWindowPriv *priv = window->priv;
-
-+ if (window->priv->resize_timeout)
-+ g_source_remove (window->priv->resize_timeout);
-+ window->priv->resize_timeout = 0;
-+
- g_object_unref (priv->action_group);
- g_object_unref (priv->ui_manager);
-
-@@ -1810,26 +1822,22 @@ window_set_loading (YelpWindow *window)
- /** Window Callbacks **********************************************************/
-
- static gboolean
--window_configure_cb (GtkWidget *widget,
-- GdkEventConfigure *event,
-- gpointer data)
-+save_window_size (YelpWindow *window,
-+ gpointer data)
- {
-- gint width, height;
- GKeyFile *keyfile;
- GError *config_error = NULL;
- gchar *sdata, *config_path;
- gsize config_size;
-
-- gtk_window_get_size (GTK_WINDOW (widget), &width, &height);
--
- keyfile = g_key_file_new();
-
- config_path = g_strconcat (g_get_home_dir(), YELP_CONFIG_PATH, NULL);
-
- g_key_file_set_integer (keyfile, YELP_CONFIG_GEOMETRY_GROUP,
-- YELP_CONFIG_WIDTH, width);
-+ YELP_CONFIG_WIDTH, window->priv->saved_width);
- g_key_file_set_integer (keyfile, YELP_CONFIG_GEOMETRY_GROUP,
-- YELP_CONFIG_HEIGHT, height);
-+ YELP_CONFIG_HEIGHT, window->priv->saved_height);
-
- sdata = g_key_file_to_data (keyfile, &config_size, NULL);
-
-@@ -1846,6 +1854,31 @@ window_configure_cb (GtkWidget *widget,
- return FALSE;
- }
-
-+static gboolean
-+window_configure_cb (GtkWidget *widget,
-+ GdkEventConfigure *event,
-+ gpointer data)
-+{
-+ gint width, height;
-+ YelpWindow *window = YELP_WINDOW (widget);
-+
-+ gtk_window_get_size (GTK_WINDOW (widget), &width, &height);
-+
-+ if (width == window->priv->saved_width &&
-+ height == window->priv->saved_height)
-+ return FALSE;
-+
-+ window->priv->saved_width = width;
-+ window->priv->saved_height = height;
-+
-+ if (window->priv->resize_timeout)
-+ g_source_remove (window->priv->resize_timeout);
-+
-+ window->priv->resize_timeout = g_timeout_add (200, (GSourceFunc) save_window_size, widget);
-+
-+ return FALSE;
-+}
-+
- /** Gecko Callbacks ***********************************************************/
-
- static void
diff --git a/gnome-extra/yelp/files/yelp-2.30.2-gthread.patch b/gnome-extra/yelp/files/yelp-2.30.2-gthread.patch
deleted file mode 100644
index bd84d7795ff2..000000000000
--- a/gnome-extra/yelp/files/yelp-2.30.2-gthread.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/configure.in b/configure.in
-index 9b5fd48..6c2fd89 100644
---- a/configure.in
-+++ b/configure.in
-@@ -68,6 +68,7 @@ AM_GLIB_DEFINE_LOCALEDIR([GNOMELOCALEDIR])
- PKG_CHECK_MODULES(YELP,
- [
- gio-2.0
-+ gthread-2.0
- gconf-2.0
- gnome-doc-utils >= 0.19.1
- gtk+-unix-print-2.0
diff --git a/gnome-extra/yelp/files/yelp-2.30.2-print-crash.patch b/gnome-extra/yelp/files/yelp-2.30.2-print-crash.patch
deleted file mode 100644
index a0833c9cdda1..000000000000
--- a/gnome-extra/yelp/files/yelp-2.30.2-print-crash.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-commit b1b83204de2eef17e746c82138325b997d1684fd
-Author: Vincent Untz <vuntz@gnome.org>
-Date: Sun Feb 20 14:48:40 2011 +0100
-
- Fix crash when printing a whole document
-
- We use g_strfreev() on an array with const strings. That's bad :-)
-
- https://bugzilla.gnome.org/show_bug.cgi?id=642808
-
-diff --git a/src/yelp-db-print.c b/src/yelp-db-print.c
-index b85eea6..6a48f84 100644
---- a/src/yelp-db-print.c
-+++ b/src/yelp-db-print.c
-@@ -477,17 +477,17 @@ dbprint_process (YelpDbprint *dbprint)
- params_max += 20;
- params = g_renew (gchar *, params, params_max);
- }
-- params[params_i++] = "db.chunk.extension";
-+ params[params_i++] = g_strdup ("db.chunk.extension");
- params[params_i++] = g_strdup ("\"\"");
-- params[params_i++] = "db.chunk.info_basename";
-+ params[params_i++] = g_strdup ("db.chunk.info_basename");
- params[params_i++] = g_strdup ("\"index\"");
-- params[params_i++] = "db.chunk.max_depth";
-+ params[params_i++] = g_strdup ("db.chunk.max_depth");
- params[params_i++] = g_strdup ("0");
-- params[params_i++] = "db2html.navbar.top";
-+ params[params_i++] = g_strdup ("db2html.navbar.top");
- params[params_i++] = g_strdup ("0");
-- params[params_i++] = "db2html.navbar.bottom";
-+ params[params_i++] = g_strdup ("db2html.navbar.bottom");
- params[params_i++] = g_strdup ("0");
-- params[params_i++] = "db2html.sidenav";
-+ params[params_i++] = g_strdup ("db2html.sidenav");
- params[params_i++] = g_strdup ("0");
-
- params[params_i] = NULL;
diff --git a/gnome-extra/yelp/files/yelp-2.30.2-uri-handler.patch b/gnome-extra/yelp/files/yelp-2.30.2-uri-handler.patch
deleted file mode 100644
index 7a7798d6b924..000000000000
--- a/gnome-extra/yelp/files/yelp-2.30.2-uri-handler.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From f79bf2d8e632771275e89b67a218b22bb699afa7 Mon Sep 17 00:00:00 2001
-From: Matthias Clasen <mclasen@redhat.com>
-Date: Wed, 22 Dec 2010 21:11:01 +0000
-Subject: Add schemehandler information to the desktop file
-
-This should arrange things so that gtk_show_uri (..."ghelp:epiphany"...)
-will just work.
----
-diff --git a/yelp.desktop.in.in b/yelp.desktop.in.in
-index 6c71b95..02e8cdf 100644
---- a/yelp.desktop.in.in
-+++ b/yelp.desktop.in.in
-@@ -2,7 +2,7 @@
- _Name=Help
- _Comment=Get help with GNOME
- OnlyShowIn=GNOME;
--Exec=yelp
-+Exec=yelp %u
- Icon=help-browser
- StartupNotify=true
- Terminal=false
-@@ -12,3 +12,4 @@ X-GNOME-Bugzilla-Bugzilla=GNOME
- X-GNOME-Bugzilla-Product=Yelp
- X-GNOME-Bugzilla-Component=general
- X-GNOME-Bugzilla-Version=@VERSION@
-+MimeType=x-scheme-handler/ghelp;x-scheme-handler/help;x-scheme-handler/info;x-scheme-handler/man;
---
-cgit v0.9
diff --git a/gnome-extra/yelp/files/yelp-2.30.2-xz-support.patch b/gnome-extra/yelp/files/yelp-2.30.2-xz-support.patch
deleted file mode 100644
index d2103f264182..000000000000
--- a/gnome-extra/yelp/files/yelp-2.30.2-xz-support.patch
+++ /dev/null
@@ -1,229 +0,0 @@
-http://svnweb.mageia.org/packages/cauldron/yelp/releases/2.30.2/4.mga1/SOURCES/
-
---- configure.in
-+++ configure.in
-@@ -180,10 +180,10 @@
- dnl ====================================
- dnl = lzmadec for help converters
- dnl ====================================
--LZMADEC_LIBS=
--AC_CHECK_LIB(lzmadec, lzmadec_open, [LZMADEC_LIBS=-llzmadec
-- AC_DEFINE(HAVE_LIBLZMADEC, 1, [Compile with liblzmadec support])])
--AC_SUBST(LZMADEC_LIBS)
-+LZMA_LIBS=
-+AC_CHECK_LIB(lzma, [lzma_code, lzma_auto_decoder, lzma_end], [LZMA_LIBS=-llzma
-+ AC_DEFINE(HAVE_LIBLZMA, 1, [Compile with liblzma support])])
-+AC_SUBST(LZMA_LIBS)
-
- dnl ====================================
- dnl = Bzip2, for the help converters
---- src/Makefile.am
-+++ src/Makefile.am
-@@ -58,7 +58,7 @@
- $(POPT_LIBS) \
- $(Z_LIBS) \
- $(BZ_LIBS) \
-- $(LZMADEC_LIBS) \
-+ $(LZMA_LIBS) \
- $(YELP_WEBKIT_LIBS) \
- $(X_LIBS)
-
-@@ -108,7 +108,7 @@
- yelp-transform.c yelp-transform.h \
- test-document.c
- test_document_CFLAGS = $(YELP_CFLAGS) $(AM_CFLAGS) $(YELP_DEFINES)
--test_document_LDADD = $(YELP_LIBS) $(Z_LIBS) $(BZ_LIBS) $(LZMADEC_LIBS)
-+test_document_LDADD = $(YELP_LIBS) $(Z_LIBS) $(BZ_LIBS) $(LZMA_LIBS)
- test_document_LDFLAGS = $(AM_LDFLAGS)
-
- test_man_parser_SOURCES = \
-@@ -119,7 +119,7 @@
- test-man-parser.c
- test_man_parser_CPPFLAGS = $(YELP_DEFINES) $(AM_CPPFLAGS)
- test_man_parser_CFLAGS = $(YELP_CFLAGS) $(AM_CFLAGS)
--test_man_parser_LDADD = $(YELP_LIBS) $(Z_LIBS) $(BZ_LIBS) $(LZMADEC_LIBS)
-+test_man_parser_LDADD = $(YELP_LIBS) $(Z_LIBS) $(BZ_LIBS) $(LZMA_LIBS)
- test_man_parser_LDFLAGS = $(AM_LDFLAGS)
-
- test_page_SOURCES = \
---- src/yelp-io-channel.c
-+++ src/yelp-io-channel.c
-@@ -26,6 +26,7 @@
-
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <glib.h>
- #include <glib/gi18n.h>
-
-@@ -36,11 +37,80 @@
- #ifdef HAVE_LIBBZ2
- #include <bzlib.h>
- #endif
--#ifdef HAVE_LIBLZMADEC
--#include <lzmadec.h>
-+#ifdef HAVE_LIBLZMA
-+#include <lzma.h>
- #endif
- #include <string.h>
-
-+#ifdef HAVE_LIBLZMA
-+typedef struct lzma_file {
-+ uint8_t buf[1<<15];
-+ lzma_stream strm;
-+ FILE *fp;
-+ lzma_bool eof;
-+} lzma_FILE;
-+
-+static lzma_FILE *lzma_open (const char *path)
-+{
-+ lzma_ret ret;
-+ lzma_FILE *lzma_file;
-+ lzma_stream tmp = (lzma_stream)LZMA_STREAM_INIT;
-+
-+ lzma_file = calloc (1, sizeof (*lzma_file));
-+ lzma_file->fp = fopen(path, "r");
-+ lzma_file->eof = 0;
-+ lzma_file->strm = tmp;
-+
-+ ret = lzma_auto_decoder (&lzma_file->strm, -1, 0);
-+
-+ if (ret != LZMA_OK) {
-+ fclose (lzma_file->fp);
-+ free (lzma_file);
-+ return NULL;
-+ }
-+ return lzma_file;
-+}
-+
-+static ssize_t lzma_read(lzma_FILE *lzma_file, void *buf, size_t len)
-+{
-+ lzma_ret ret;
-+ lzma_bool eof = 0;
-+
-+ if (!lzma_file)
-+ return -1;
-+ if (lzma_file->eof)
-+ return 0;
-+
-+ lzma_file->strm.next_out = buf;
-+ lzma_file->strm.avail_out = len;
-+ for (;;) {
-+ if (!lzma_file->strm.avail_in) {
-+ lzma_file->strm.next_in = (uint8_t *)lzma_file->buf;
-+ lzma_file->strm.avail_in = fread (lzma_file->buf, 1, sizeof (lzma_file->buf), lzma_file->fp);
-+ if (!lzma_file->strm.avail_in)
-+ eof = 1;
-+ }
-+ ret = lzma_code(&lzma_file->strm, LZMA_RUN);
-+ if (ret == LZMA_STREAM_END) {
-+ lzma_file->eof = 1;
-+ return len - lzma_file->strm.avail_out;
-+ }
-+ if (ret != LZMA_OK)
-+ return -1;
-+ if (!lzma_file->strm.avail_out)
-+ return len;
-+ if (eof)
-+ return -1;
-+ }
-+}
-+
-+static void lzma_close(lzma_FILE *lzma_file)
-+{
-+ lzma_end (&lzma_file->strm);
-+ fclose (lzma_file->fp);
-+}
-+#endif
-+
- typedef struct _YelpIOChannel YelpIOChannel;
- struct _YelpIOChannel {
- GIOChannel channel;
-@@ -48,8 +118,8 @@
- BZFILE *bzin;
- #endif
- gzFile gzin;
--#ifdef HAVE_LIBLZMADEC
-- lzmadec_FILE *lzin;
-+#ifdef HAVE_LIBLZMA
-+ lzma_FILE *lzin;
- #endif
- };
-
-@@ -99,9 +169,9 @@
- channel->bzin = bzopen (file, "r");
- else
- #endif
--#ifdef HAVE_LIBLZMADEC
-- if (g_str_has_suffix (file, ".lzma"))
-- channel->lzin = lzmadec_open(file);
-+#ifdef HAVE_LIBLZMA
-+ if (g_str_has_suffix (file, ".lzma") || g_str_has_suffix (file, ".xz"))
-+ channel->lzin = lzma_open (file);
- else
- #endif
-
-@@ -111,7 +181,7 @@
- #ifdef HAVE_LIBBZ2
- !channel->bzin &&
- #endif
--#ifdef HAVE_LIBLZMADEC
-+#ifdef HAVE_LIBLZMA
- !channel->lzin &&
- #endif
- !channel->gzin) {
-@@ -159,9 +229,10 @@
- bytes = bzread (yelp_channel->bzin, buffer, count);
- else
- #endif
--#if HAVE_LIBLZMADEC
-- if (yelp_channel->lzin)
-- bytes = lzmadec_read (yelp_channel->lzin, buffer, count);
-+#if HAVE_LIBLZMA
-+ if (yelp_channel->lzin) {
-+ bytes = lzma_read (yelp_channel->lzin, buffer, count);
-+ }
- else
- #endif
- bytes = gzread (yelp_channel->gzin, buffer, count);
-@@ -186,9 +257,9 @@
- if (yelp_channel->bzin)
- bzclose (yelp_channel->bzin);
- #endif
--#ifdef HAVE_LIBLZMADEC
-+#ifdef HAVE_LIBLZMA
- if (yelp_channel->lzin)
-- lzmadec_close (yelp_channel->lzin);
-+ lzma_close (yelp_channel->lzin);
- #endif
- if (yelp_channel->gzin)
- gzclose (yelp_channel->gzin);
---- src/yelp-uri.c
-+++ src/yelp-uri.c
-@@ -404,6 +404,13 @@
- NULL);
- if (g_file_test (fullpath, G_FILE_TEST_IS_REGULAR))
- goto gotit;
-+
-+ fullpath = g_strconcat (langdir, "/", sectiondir,
-+ "/", name, ".", sectiondir + 3, ".xz",
-+ NULL);
-+ if (g_file_test (fullpath, G_FILE_TEST_IS_REGULAR))
-+ goto gotit;
-+
- g_free (fullpath);
-
- fullpath = NULL;
-@@ -532,6 +539,12 @@
- else if (is_man_path (basename, "lzma"))
- ret->priv->doctype = YELP_URI_DOCUMENT_TYPE_MAN;
- }
-+ else if (g_str_equal (mime_type, "application/x-xz")) {
-+ if (g_str_has_suffix (basename, ".info.xz"))
-+ ret->priv->doctype = YELP_URI_DOCUMENT_TYPE_INFO;
-+ else if (is_man_path (basename, "xz"))
-+ ret->priv->doctype = YELP_URI_DOCUMENT_TYPE_MAN;
-+ }
- else if (g_str_equal (mime_type, "application/octet-stream")) {
- if (g_str_has_suffix (basename, ".info"))
- ret->priv->doctype = YELP_URI_DOCUMENT_TYPE_INFO;
diff --git a/gnome-extra/yelp/yelp-2.30.2-r200.ebuild b/gnome-extra/yelp/yelp-2.30.2-r200.ebuild
deleted file mode 100644
index 0208d90c42e4..000000000000
--- a/gnome-extra/yelp/yelp-2.30.2-r200.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-2.30.2-r200.ebuild,v 1.11 2014/01/05 07:21:33 tetromino Exp $
-
-# git clone git://git.gnome.org/yelp
-# cd yelp
-# git checkout webkit
-# git merge origin/gnome-2-30
-
-EAPI=4
-GCONF_DEBUG=yes
-inherit autotools eutils gnome2
-
-MY_P=${P}+webkit
-
-DESCRIPTION="Help browser for GNOME"
-HOMEPAGE="http://projects.gnome.org/yelp/"
-SRC_URI="mirror://gentoo/${MY_P}.tar.xz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 sparc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE="lzma"
-
-RDEPEND="app-arch/bzip2
- >=app-text/gnome-doc-utils-0.20.6
- >=app-text/rarian-0.8.1
- >=dev-libs/dbus-glib-0.98
- >=dev-libs/glib-2.16
- dev-libs/libxml2
- dev-libs/libxslt
- >=gnome-base/gconf-2
- sys-libs/zlib
- >=x11-libs/gtk+-2.18:2
- x11-libs/libSM
- x11-libs/libICE
- x11-libs/libX11
- x11-libs/startup-notification
- net-libs/webkit-gtk:2
- lzma? ( app-arch/xz-utils )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- gnome-base/gnome-common
- sys-devel/gettext
- virtual/pkgconfig"
-
-S=${WORKDIR}/${MY_P}
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog NEWS README TODO"
- G2CONF="--enable-maintainer-mode --with-search=basic"
-}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-uri-handler.patch \
- "${FILESDIR}"/${P}-print-crash.patch \
- "${FILESDIR}"/${P}-freeze-move.patch \
- "${FILESDIR}"/${P}-xz-support.patch \
- "${FILESDIR}"/${P}-gthread.patch
-
- sed -i -e '/CFLAGS/s:-pedantic -ansi::' configure.in || die #196621
-
- eautoreconf
-
- gnome2_src_prepare
-}
-
-src_configure() {
- export ac_cv_lib_lzma_lzma_code__lzma_auto_decoder__lzma_end=$(usex lzma)
-
- gnome2_src_configure
-}
diff --git a/gnome-extra/yelp/yelp-3.10.2.ebuild b/gnome-extra/yelp/yelp-3.10.2.ebuild
deleted file mode 100644
index 069e5e37fb88..000000000000
--- a/gnome-extra/yelp/yelp-3.10.2.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/yelp/yelp-3.10.2.ebuild,v 1.3 2014/03/09 12:01:12 pacho Exp $
-
-EAPI="5"
-GCONF_DEBUG="yes"
-
-inherit autotools eutils gnome2
-
-DESCRIPTION="Help browser for GNOME"
-HOMEPAGE="https://wiki.gnome.org/Apps/Yelp"
-
-LICENSE="GPL-2+"
-SLOT="0"
-IUSE=""
-KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
-
-RDEPEND="
- app-arch/bzip2:=
- >=app-arch/xz-utils-4.9:=
- dev-db/sqlite:3=
- >=dev-libs/glib-2.25.11:2
- >=dev-libs/libxml2-2.6.5:2
- >=dev-libs/libxslt-1.1.4
- >=gnome-extra/yelp-xsl-3.6.1
- >=net-libs/webkit-gtk-1.3.10:3
- >=x11-libs/gtk+-2.91.8:3
- x11-themes/gnome-icon-theme-symbolic
-"
-DEPEND="${RDEPEND}
- >=dev-util/gtk-doc-am-1.13
- >=dev-util/intltool-0.41.0
- >=sys-devel/gettext-0.17
- virtual/pkgconfig
- gnome-base/gnome-common
-"
-# If eautoreconf:
-# gnome-base/gnome-common
-
-src_prepare() {
- # Fix compatibility with Gentoo's sys-apps/man
- # https://bugzilla.gnome.org/show_bug.cgi?id=648854
- epatch "${FILESDIR}/${PN}-3.0.3-man-compatibility.patch"
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure \
- --disable-static \
- --enable-bz2 \
- --enable-lzma \
- ITSTOOL=$(type -P true)
-}