summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-06-23 19:22:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-06-23 19:22:50 +0000
commit9a48c4603086b4b92b049d51bf0d063a8e38ee30 (patch)
treeccb2c003509e17ea559301b8d1ba01b04541f32d /gnome-extra
parentVersion bumps: new TuxOnIce - 3.1.1.1, new genpatches. (diff)
downloadgentoo-2-9a48c4603086b4b92b049d51bf0d063a8e38ee30.tar.gz
gentoo-2-9a48c4603086b4b92b049d51bf0d063a8e38ee30.tar.bz2
gentoo-2-9a48c4603086b4b92b049d51bf0d063a8e38ee30.zip
Fix building with GCC 4.5+ wrt #323079 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/wp_tray/ChangeLog6
-rw-r--r--gnome-extra/wp_tray/files/wp_tray-0.5.5-gcc45.patch13
-rw-r--r--gnome-extra/wp_tray/wp_tray-0.5.5.ebuild26
3 files changed, 31 insertions, 14 deletions
diff --git a/gnome-extra/wp_tray/ChangeLog b/gnome-extra/wp_tray/ChangeLog
index 4ed7f6d2844b..6c19280ca269 100644
--- a/gnome-extra/wp_tray/ChangeLog
+++ b/gnome-extra/wp_tray/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for gnome-extra/wp_tray
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/ChangeLog,v 1.3 2010/06/23 19:13:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/ChangeLog,v 1.4 2010/06/23 19:22:50 ssuominen Exp $
+
+ 23 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> wp_tray-0.5.5.ebuild,
+ +files/wp_tray-0.5.5-gcc45.patch:
+ Fix building with GCC 4.5+ wrt #323079 by Diego E. Pettenò.
23 Jun 2010; Samuli Suominen <ssuominen@gentoo.org> wp_tray-0.5.5.ebuild:
Missing libpanelapplet-2.0 rdep wrt #320117 by Diego E. Pettenò.
diff --git a/gnome-extra/wp_tray/files/wp_tray-0.5.5-gcc45.patch b/gnome-extra/wp_tray/files/wp_tray-0.5.5-gcc45.patch
new file mode 100644
index 000000000000..3667fa97a138
--- /dev/null
+++ b/gnome-extra/wp_tray/files/wp_tray-0.5.5-gcc45.patch
@@ -0,0 +1,13 @@
+http://bugs.gentoo.org/323079
+
+--- src/Applet.hh
++++ src/Applet.hh
+@@ -77,7 +77,7 @@
+ std::auto_ptr<Gnome::UI::About> m_pAboutBox;
+
+ Gtk::EventBox m_GtkEventBox;
+- Gtk::Image::Image m_GtkImage;
++ Gtk::Image m_GtkImage;
+ Gtk::Tooltips m_GtkTooltips;
+
+ Glib::RefPtr<Gdk::Pixbuf> m_pGdkIcon;
diff --git a/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild b/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
index c27596f98bf0..a9287b3cc237 100644
--- a/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
+++ b/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
@@ -1,15 +1,16 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild,v 1.4 2010/06/23 19:13:01 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild,v 1.5 2010/06/23 19:22:50 ssuominen Exp $
-inherit gnome2 multilib eutils
+EAPI=2
+GCONF_DEBUG=no
+inherit eutils gnome2 multilib
DESCRIPTION="Wallpaper Manager for the Gnome Desktop"
HOMEPAGE="http://planetearthworm.com/projects/wp_tray"
-
SRC_URI="http://planetearthworm.com/projects/${PN}/files/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
@@ -24,19 +25,18 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
dev-libs/boost"
-src_compile() {
- local myconf
-
- myconf="${myconf} --with-boostfilesystem=/usr/$(get_libdir)/libboost_filesystem.so"
- myconf="${myconf} --with-boostregex=/usr/$(get_libdir)/libboost_regex.so"
+pkg_setup() {
+ G2CONF="${G2CONF} --with-boostfilesystem=/usr/$(get_libdir)/libboost_filesystem.so"
+ G2CONF="${G2CONF} --with-boostregex=/usr/$(get_libdir)/libboost_regex.so"
+ DOCS="AUTHORS ChangeLog NEWS README*"
+}
- econf ${myconf} || die "Configure failure"
- emake || die "Make failure"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+ gnome2_src_prepare
}
src_install() {
addpredict /root/.gconf
gnome2_src_install
}
-
-DOCS="AUTHORS ChangeLog INSTALL NEWS README*"