summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-08-16 21:16:59 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-08-16 21:16:59 +0000
commit6b0b92b34d0c776e889feb007a11912b3ee64abd (patch)
treea38bdaef2cc334ea7043cb39d30e20c6dd8d586b /gnome-extra
parentVulnerable (bug #245425). (diff)
downloadgentoo-2-6b0b92b34d0c776e889feb007a11912b3ee64abd.tar.gz
gentoo-2-6b0b92b34d0c776e889feb007a11912b3ee64abd.tar.bz2
gentoo-2-6b0b92b34d0c776e889feb007a11912b3ee64abd.zip
Version bump. About USE=glade removal, see upstream commit:7b4440c7.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gtkhtml/ChangeLog8
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.30.2.ebuild8
-rw-r--r--gnome-extra/gtkhtml/gtkhtml-3.30.3.ebuild48
3 files changed, 56 insertions, 8 deletions
diff --git a/gnome-extra/gtkhtml/ChangeLog b/gnome-extra/gtkhtml/ChangeLog
index df9036d5b26e..f69afd9805a9 100644
--- a/gnome-extra/gtkhtml/ChangeLog
+++ b/gnome-extra/gtkhtml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gtkhtml
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.216 2010/08/14 17:20:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/ChangeLog,v 1.217 2010/08/16 21:16:59 eva Exp $
+
+*gtkhtml-3.30.3 (16 Aug 2010)
+
+ 16 Aug 2010; Gilles Dartiguelongue <eva@gentoo.org> gtkhtml-3.30.2.ebuild,
+ +gtkhtml-3.30.3.ebuild:
+ Version bump. About USE=glade removal, see upstream commit:7b4440c7.
14 Aug 2010; Raúl Porcel <armin76@gentoo.org> gtkhtml-3.28.3.ebuild:
alpha/ia64/sh/sparc stable wrt #314899
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.30.2.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.30.2.ebuild
index 576968a34aff..25566a24d464 100644
--- a/gnome-extra/gtkhtml/gtkhtml-3.30.2.ebuild
+++ b/gnome-extra/gtkhtml/gtkhtml-3.30.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.30.2.ebuild,v 1.4 2010/08/01 11:16:16 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.30.2.ebuild,v 1.5 2010/08/16 21:16:59 eva Exp $
EAPI="2"
GCONF_DEBUG="no"
@@ -15,12 +15,6 @@ SLOT="3.14"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
IUSE=""
-# Glade support is disabled, because it's install broken by design:
-# Install directories for glade are queried from gladeui-1.0.pc which doesn't
-# take our prefix into account. On the other side, there are maybe 3 to 4
-# people in the world who really need to install the Glade file, so they can
-# fix it themselves :)
-
# We keep bonobo until we can make sure no apps in tree uses
# the old composer code.
RDEPEND=">=x11-libs/gtk+-2.18
diff --git a/gnome-extra/gtkhtml/gtkhtml-3.30.3.ebuild b/gnome-extra/gtkhtml/gtkhtml-3.30.3.ebuild
new file mode 100644
index 000000000000..ded03681e7c6
--- /dev/null
+++ b/gnome-extra/gtkhtml/gtkhtml-3.30.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gtkhtml/gtkhtml-3.30.3.ebuild,v 1.1 2010/08/16 21:16:59 eva Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="3.14"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE=""
+
+# We keep bonobo until we can make sure no apps in tree uses
+# the old composer code.
+RDEPEND=">=x11-libs/gtk+-2.18
+ >=x11-themes/gnome-icon-theme-2.22.0
+ >=gnome-base/orbit-2
+ >=app-text/enchant-1.1.7
+ gnome-base/gconf:2
+ >=app-text/iso-codes-0.49
+ >=net-libs/libsoup-2.26.0:2.4"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40.0
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ ELTCONF="--reverse-deps"
+ G2CONF="${G2CONF}
+ --disable-static"
+}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # FIXME: Fix compilation flags crazyness
+ sed 's/CFLAGS="$CFLAGS $WARNING_FLAGS"//' \
+ -i configure.ac configure || die "sed 1 failed"
+ sed -i -e 's:-DGTK_DISABLE_DEPRECATED=1 -DGDK_DISABLE_DEPRECATED=1 -DG_DISABLE_DEPRECATED=1 -DGNOME_DISABLE_DEPRECATED=1::g' \
+ a11y/Makefile.am a11y/Makefile.in || die "sed 2 failed"
+}