summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoe Sapp <nixphoeni@gentoo.org>2009-06-01 12:03:14 +0000
committerJoe Sapp <nixphoeni@gentoo.org>2009-06-01 12:03:14 +0000
commit46b2aa4fc426a15cef0cc05652a0287c6c91f16e (patch)
tree763bbbe6c23e839fb8570c1b68b60d036efd38ea /gnome-extra
parentarm/ia64/m68k/s390/sh/sparc stable wrt #248905 (diff)
downloadgentoo-2-46b2aa4fc426a15cef0cc05652a0287c6c91f16e.tar.gz
gentoo-2-46b2aa4fc426a15cef0cc05652a0287c6c91f16e.tar.bz2
gentoo-2-46b2aa4fc426a15cef0cc05652a0287c6c91f16e.zip
Added bash completion and an autostart .desktop file from upstream's bzr repo
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gdesklets-core/ChangeLog10
-rw-r--r--gnome-extra/gdesklets-core/files/gdesklets-core-0.36.1-bash-completion50
-rw-r--r--gnome-extra/gdesklets-core/files/gdesklets.desktop12
-rw-r--r--gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r2.ebuild (renamed from gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r1.ebuild)25
4 files changed, 89 insertions, 8 deletions
diff --git a/gnome-extra/gdesklets-core/ChangeLog b/gnome-extra/gdesklets-core/ChangeLog
index c6d4d611197d..30dcdba637b8 100644
--- a/gnome-extra/gdesklets-core/ChangeLog
+++ b/gnome-extra/gdesklets-core/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/gdesklets-core
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gdesklets-core/ChangeLog,v 1.103 2009/05/18 21:57:15 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gdesklets-core/ChangeLog,v 1.104 2009/06/01 12:03:14 nixphoeni Exp $
+
+*gdesklets-core-0.36.1-r2 (01 Jun 2009)
+
+ 01 Jun 2009; Joe Sapp <nixphoeni@gentoo.org>
+ -gdesklets-core-0.36.1-r1.ebuild, +gdesklets-core-0.36.1-r2.ebuild,
+ +files/gdesklets-core-0.36.1-bash-completion, +files/gdesklets.desktop:
+ Added bash completion and an autostart .desktop file to be included in the
+ next release
*gdesklets-core-0.36.1-r1 (15 May 2009)
diff --git a/gnome-extra/gdesklets-core/files/gdesklets-core-0.36.1-bash-completion b/gnome-extra/gdesklets-core/files/gdesklets-core-0.36.1-bash-completion
new file mode 100644
index 000000000000..8f6e1a1b0bd7
--- /dev/null
+++ b/gnome-extra/gdesklets-core/files/gdesklets-core-0.36.1-bash-completion
@@ -0,0 +1,50 @@
+# $Id: gdesklets-core-0.36.1-bash-completion,v 1.1 2009/06/01 12:03:14 nixphoeni Exp $
+# See http://devmanual.gentoo.org/tasks-reference/completion/index.html
+# Author: Joe Sapp
+
+_gdesklets()
+{
+ local cur prev opts
+
+ COMPREPLY=()
+
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="open start stop list restart profile shell status about
+ version configure help check"
+ running_opts="slay"
+ not_running_opts=""
+
+ # Do these take an additional paramater?
+ case "${prev}" in
+ open)
+ # First, look for .display files in the current directory
+ COMPREPLY=$(compgen -f -o filenames -X '!*.display' ${cur})
+
+ # If no filename completions are found, try for directory
+ # completions
+ # This, with the '-o filenames' argument on the 'complete'
+ # line below allows entering a directory name with the intent
+ # of finishing with a .display file
+ COMPREPLY=( ${COMPREPLY:-$(compgen -d ${cur})} )
+ return 0
+ ;;
+ profile)
+ local prof_output=$(gdesklets profile | grep "Available" | sed -e 's/.*: //' -e 's/,//')
+ COMPREPLY=( $(compgen -W "${prof_output}" -- ${cur}) )
+ return 0
+ ;;
+ esac
+
+ if [[ ${COMP_CWORD} -eq 1 ]] ; then
+ local status="$(gdesklets status)"
+ if [[ "${status}" == *not* ]] ; then
+ opts="${opts} ${not_running_opts}"
+ else
+ opts="${opts} ${running_opts}"
+ fi
+ COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
+ return 0
+ fi
+}
+complete -F _gdesklets -o filenames gdesklets
diff --git a/gnome-extra/gdesklets-core/files/gdesklets.desktop b/gnome-extra/gdesklets-core/files/gdesklets.desktop
new file mode 100644
index 000000000000..58458661c18e
--- /dev/null
+++ b/gnome-extra/gdesklets-core/files/gdesklets.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Name=gDesklets
+Type=Application
+Encoding=UTF-8
+Version=1.0
+Categories=Utility;
+X-GNOME-Autostart-enabled=true
+Exec=gdesklets start
+Icon=gdesklets
+GenericName=Desktop Widgets
+Comment=Eye candy for your desktop
+GenericName[es]=Widgets para Escritorio
diff --git a/gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r1.ebuild b/gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r2.ebuild
index 990c9a6e2762..244341166b56 100644
--- a/gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r1.ebuild
+++ b/gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r1.ebuild,v 1.1 2009/05/18 21:57:15 nixphoeni Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gdesklets-core/gdesklets-core-0.36.1-r2.ebuild,v 1.1 2009/06/01 12:03:14 nixphoeni Exp $
# desklets don't run with USE=debug
GCONF_DEBUG="no"
# We want the latest autoconf and automake (the default)
-inherit gnome2 python eutils autotools multilib
+inherit gnome2 python eutils autotools multilib bash-completion
MY_PN="gDesklets"
MY_P="${PN/-core/}-${PV/_/}"
@@ -69,8 +69,16 @@ src_install() {
gnome2_src_install
+ # Install bash completion script
+ BASH_COMPLETION_NAME="gDesklets"
+ dobashcompletion "${FILESDIR}/${PN}-${PV}-bash-completion"
+
+ # Install autostart script
+ insinto "/etc/xdg/autostart"
+ doins "${FILESDIR}/gdesklets.desktop"
+
# Install the gdesklets-control-getid script
- insinto /usr/$(get_libdir)/gdesklets
+ insinto "/usr/$(get_libdir)/gdesklets"
insopts -m0555
doins "${FILESDIR}/gdesklets-control-getid"
@@ -85,7 +93,7 @@ pkg_postinst() {
gnome2_pkg_postinst
# Compile pyc files on target system
- python_mod_optimize "${ROOT}"/usr/$(get_libdir)/gdesklets
+ python_mod_optimize "${ROOT}/usr/$(get_libdir)/gdesklets"
echo
elog "gDesklets Displays are required before the library"
@@ -99,14 +107,17 @@ pkg_postinst() {
elog "Next you'll need to start gDesklets using"
elog " ${ROOT}usr/bin/gdesklets start"
elog "If you're using GNOME this can be done conveniently through"
- elog "Applications->Accessories->gDesklets"
+ elog "Applications->Accessories->gDesklets or automatically each login"
+ elog "under System->Preferences->Sessions"
elog
elog "If you're updating from a version less than 0.35_rc1,"
elog "you can migrate your desklet configurations by"
elog "running"
elog " ${ROOT}usr/$(get_libdir)/gdesklets/gdesklets-migration-tool"
elog "after the first time you run gDesklets"
- echo
+ elog
+ BASH_COMPLETION_NAME="gDesklets"
+ bash-completion_pkg_postinst
}
@@ -115,6 +126,6 @@ pkg_postrm() {
gnome2_pkg_postrm
# Cleanup after our cavalier python compilation
# The function takes care of ${ROOT} for us
- python_mod_cleanup /usr/$(get_libdir)/gdesklets
+ python_mod_cleanup "/usr/$(get_libdir)/gdesklets"
}