summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-12-06 14:05:17 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-12-06 14:05:17 +0000
commit4448023b7cea3892c1a63dc54ea217ec9f98973c (patch)
treea90a70c021bf5d7d9f07cdc9eef6aaaed48e209f /gnome-extra
parentnew version of kino (diff)
downloadgentoo-2-4448023b7cea3892c1a63dc54ea217ec9f98973c.tar.gz
gentoo-2-4448023b7cea3892c1a63dc54ea217ec9f98973c.tar.bz2
gentoo-2-4448023b7cea3892c1a63dc54ea217ec9f98973c.zip
cleaned up a very ugly ebuild, hopefully fixed a problem with online help files linked to /var/tmp/portage
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/mc/ChangeLog10
-rw-r--r--gnome-extra/mc/files/digest-mc-4.5.55-r71
-rw-r--r--gnome-extra/mc/mc-4.5.55-r7.ebuild82
3 files changed, 92 insertions, 1 deletions
diff --git a/gnome-extra/mc/ChangeLog b/gnome-extra/mc/ChangeLog
index 43f4053b2e15..a1c592c59507 100644
--- a/gnome-extra/mc/ChangeLog
+++ b/gnome-extra/mc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for gnome-extra/mc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/ChangeLog,v 1.14 2002/11/14 09:43:44 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/ChangeLog,v 1.15 2002/12/06 14:05:17 bcowan Exp $
+
+*mc-4.5.55-r7 (06 Dec 2002)
+
+ 06 Dec 2002; Brad Cowan <bcowan@gentoo.org> mc-4.5.55-r7.ebuild,
+ files/digest-mc-4.5.55-r7:
+
+ Total rework of an ugly ebuild, hopefully fixes a problem with help,
+ files in var/tmp.
*mc-4.6.0_pre1-r4 (13 Nov 2002)
diff --git a/gnome-extra/mc/files/digest-mc-4.5.55-r7 b/gnome-extra/mc/files/digest-mc-4.5.55-r7
new file mode 100644
index 000000000000..60b693823ea7
--- /dev/null
+++ b/gnome-extra/mc/files/digest-mc-4.5.55-r7
@@ -0,0 +1 @@
+MD5 bb670d48589f26f00b7fce8d25f66bd6 mc-4.5.55.tar.gz 4849958
diff --git a/gnome-extra/mc/mc-4.5.55-r7.ebuild b/gnome-extra/mc/mc-4.5.55-r7.ebuild
new file mode 100644
index 000000000000..89a67ae1a5b2
--- /dev/null
+++ b/gnome-extra/mc/mc-4.5.55-r7.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/mc/mc-4.5.55-r7.ebuild,v 1.1 2002/12/06 14:05:17 bcowan Exp $
+
+IUSE="gpm nls samba ncurses X pam slang"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GNOME Midnight Commander"
+SRC_URI="http://www.gnome.org/projects/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/projects/mc/"
+
+DEPEND=">=sys-apps/e2fsprogs-1.19
+ =dev-libs/glib-1.2*
+ >=sys-devel/automake-1.5d-r1
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ pam? ( >=sys-libs/pam-0.72 )
+ ncurses? ( >=sys-libs/ncurses-5.2 )
+ slang? ( >=sys-libs/slang-1.4.2 )
+ nls? ( sys-devel/gettext )
+ samba? ( >=net-fs/samba-2.2.3a-r1 )
+ X? ( virtual/x11 )"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+src_compile() {
+
+ local myconf=""
+
+ use pam \
+ && myconf="${myconf} --with-pam" \
+ || myconf="${myconf} --without-pam"
+
+ use ncurses \
+ && myconf="${myconf} --with-ncurses" \
+ || ( use slang && myconf="${myconf} --with-slang" \
+ || myconf="${myconf} --with-included-slang" )
+
+ use gpm \
+ && myconf="${myconf} --with-gpm-mouse=/usr" \
+ || myconf="${myconf} --without-gpm-mouse"
+
+ use X \
+ && myconf="${myconf} --with-tm-x-support" \
+ || myconf="${myconf} --without-tm-x-support"
+
+ use samba \
+ && myconf="${myconf} --with-samba" \
+ && ( \
+ cd ${S}/vfs
+ cp smbfs.c smbfs.c.orig
+ sed -e "s:/etc/smb\.conf:/etc/samba/smb\.conf:" smbfs.c.orig > smbfs.c
+ cd samba
+ cp Makefile.in Makefile.in.orig
+ sed -e 's:$(LIBDIR)\(/codepages\):/var/lib/samba\1:' \
+ Makefile.in.orig > Makefile.in )
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ cd ${S}
+ libtoolize --force --copy
+ aclocal -I ${S}/macros
+ automake --add-missing
+
+ econf \
+ --with-vfs \
+ --with-netrc \
+ --with-ext2undel \
+ --without-gnome \
+ ${myconf} || die
+ make || die
+}
+
+src_install() {
+
+ einstall
+
+ dodoc ABOUT-NLS COPYING* FAQ INSTALL* NEWS README*
+}
+