summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-13 10:22:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-13 10:22:29 +0000
commit560e491124f62ebe02ed479135dce3858d3c41d7 (patch)
treee52baee76e35764dca08b84a878614c3c8afab91 /gnome-extra/gnome-user-share
parentFix building with x11-libs/libnotify >= 0.7 wrt #354135 by Diego Elio Pettenò. (diff)
downloadgentoo-2-560e491124f62ebe02ed479135dce3858d3c41d7.tar.gz
gentoo-2-560e491124f62ebe02ed479135dce3858d3c41d7.tar.bz2
gentoo-2-560e491124f62ebe02ed479135dce3858d3c41d7.zip
Fix building with x11-libs/libnotify wrt #354131 (imported Fedora patch) by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha23/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/gnome-user-share')
-rw-r--r--gnome-extra/gnome-user-share/ChangeLog8
-rw-r--r--gnome-extra/gnome-user-share/files/gnome-user-share-2.30.1-libnotify-0.7.patch31
-rw-r--r--gnome-extra/gnome-user-share/gnome-user-share-2.30.1.ebuild10
3 files changed, 46 insertions, 3 deletions
diff --git a/gnome-extra/gnome-user-share/ChangeLog b/gnome-extra/gnome-user-share/ChangeLog
index bb9005b79ce4..414f8e685a20 100644
--- a/gnome-extra/gnome-user-share/ChangeLog
+++ b/gnome-extra/gnome-user-share/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/gnome-user-share
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-user-share/ChangeLog,v 1.11 2011/02/08 22:41:35 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-user-share/ChangeLog,v 1.12 2011/02/13 10:22:29 ssuominen Exp $
+
+ 13 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ gnome-user-share-2.30.1.ebuild,
+ +files/gnome-user-share-2.30.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify wrt #354131 (imported Fedora patch) by
+ Diego Elio Pettenò.
08 Feb 2011; Gilles Dartiguelongue <eva@gentoo.org>
gnome-user-share-2.30.0.ebuild, gnome-user-share-2.30.1.ebuild:
diff --git a/gnome-extra/gnome-user-share/files/gnome-user-share-2.30.1-libnotify-0.7.patch b/gnome-extra/gnome-user-share/files/gnome-user-share-2.30.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..73c5a9ab8f01
--- /dev/null
+++ b/gnome-extra/gnome-user-share/files/gnome-user-share-2.30.1-libnotify-0.7.patch
@@ -0,0 +1,31 @@
+http://pkgs.fedoraproject.org/gitweb/?p=gnome-user-share.git;a=blob;f=notify.patch;hb=HEAD
+
+--- src/obexpush.c
++++ src/obexpush.c
+@@ -139,10 +139,9 @@ show_notification (const char *filename)
+ /* Translators: %s is the name of the filename received */
+ notification_text = g_strdup_printf(_("You received \"%s\" via Bluetooth"), display);
+ g_free (display);
+- notification = notify_notification_new_with_status_icon (_("You received a file"),
+- notification_text,
+- "dialog-information",
+- GTK_STATUS_ICON (statusicon));
++ notification = notify_notification_new (_("You received a file"),
++ notification_text,
++ "dialog-information");
+
+ notify_notification_set_timeout (notification, NOTIFY_EXPIRES_DEFAULT);
+
+@@ -218,10 +217,10 @@ device_is_authorised (const char *bdaddr
+ char *device_path;
+ GHashTable *props;
+
+- g_message ("checking adapter %s", g_ptr_array_index (adapters, i));
++ g_message ("checking adapter %s", (char *)g_ptr_array_index (adapters, i));
+
+ adapter = dbus_g_proxy_new_for_name (connection, "org.bluez",
+- g_ptr_array_index (adapters, i), "org.bluez.Adapter");
++ (char *)g_ptr_array_index (adapters, i), "org.bluez.Adapter");
+
+ if (dbus_g_proxy_call (adapter, "FindDevice", NULL,
+ G_TYPE_STRING, bdaddr, G_TYPE_INVALID,
diff --git a/gnome-extra/gnome-user-share/gnome-user-share-2.30.1.ebuild b/gnome-extra/gnome-user-share/gnome-user-share-2.30.1.ebuild
index 5ffed83911cf..4d1addd4144c 100644
--- a/gnome-extra/gnome-user-share/gnome-user-share-2.30.1.ebuild
+++ b/gnome-extra/gnome-user-share/gnome-user-share-2.30.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-user-share/gnome-user-share-2.30.1.ebuild,v 1.2 2011/02/08 22:41:35 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gnome-user-share/gnome-user-share-2.30.1.ebuild,v 1.3 2011/02/13 10:22:29 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="no"
-inherit gnome2 multilib
+inherit eutils gnome2 multilib
DESCRIPTION="Personal file sharing for the GNOME desktop"
HOMEPAGE="http://www.gnome.org/"
@@ -47,6 +47,12 @@ pkg_setup() {
--with-modules-path=/usr/$(get_libdir)/apache2/modules/"
}
+src_prepare() {
+ has_version ">=x11-libs/libnotify-0.7" && epatch \
+ "${FILESDIR}"/${P}-libnotify-0.7.patch
+ gnome2_src_prepare
+}
+
src_install() {
gnome2_src_install
# nautilus does not need la files