summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-04-27 21:47:31 +0000
committerMarinus Schraal <foser@gentoo.org>2004-04-27 21:47:31 +0000
commitcd02e55431f8586ad9f8ba079b1020cc082f7f68 (patch)
tree25a482ab9ea5b863b07de690e7e639e3320579b8 /gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild
parentAdd inherit eutils (diff)
downloadgentoo-2-cd02e55431f8586ad9f8ba079b1020cc082f7f68.tar.gz
gentoo-2-cd02e55431f8586ad9f8ba079b1020cc082f7f68.tar.bz2
gentoo-2-cd02e55431f8586ad9f8ba079b1020cc082f7f68.zip
fix gtk2.4 build
Diffstat (limited to 'gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild')
-rw-r--r--gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild b/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild
index 94eb0824df22..180b5f403848 100644
--- a/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild
+++ b/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild,v 1.9 2004/03/17 01:02:52 geoman Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gconf-editor/gconf-editor-2.4.0.ebuild,v 1.10 2004/04/27 21:47:31 foser Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="An editor to the GNOME 2 config system"
HOMEPAGE="http://www.gnome.org/"
@@ -18,3 +18,13 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
DOCS="AUTHORS ChangeLog COPYING README INSTALL NEWS"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${S}
+ # fix gtk+-2.4 build
+ epatch ${FILESDIR}/${P}-gtk+-2.4.patch
+
+}