summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-18 11:48:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-18 11:48:57 +0000
commita778436ef083dfc81e05196420909001fb529b41 (patch)
treef5c4bdae640c20c28dc4d0cbc7abd19387db520d /gnome-extra/at-spi
parentrevert one change that broke it ;) (diff)
downloadgentoo-2-a778436ef083dfc81e05196420909001fb529b41.tar.gz
gentoo-2-a778436ef083dfc81e05196420909001fb529b41.tar.bz2
gentoo-2-a778436ef083dfc81e05196420909001fb529b41.zip
fix python eclass use, bug #207667
fix some potential eautoreconf problems (Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-extra/at-spi')
-rw-r--r--gnome-extra/at-spi/ChangeLog9
-rw-r--r--gnome-extra/at-spi/at-spi-1.20.1.ebuild35
-rw-r--r--gnome-extra/at-spi/files/at-spi-1.20.1-drop-gtk-doc.patch29
3 files changed, 64 insertions, 9 deletions
diff --git a/gnome-extra/at-spi/ChangeLog b/gnome-extra/at-spi/ChangeLog
index df44245fea9c..32e3c2e3de6f 100644
--- a/gnome-extra/at-spi/ChangeLog
+++ b/gnome-extra/at-spi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-extra/at-spi
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.162 2007/11/29 05:12:27 jer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/ChangeLog,v 1.163 2008/02/18 11:48:57 eva Exp $
+
+ 18 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/at-spi-1.20.1-drop-gtk-doc.patch, at-spi-1.20.1.ebuild:
+ fix python eclass use, bug #207667
+ fix potential autoregen problems
29 Nov 2007; Jeroen Roovers <jer@gentoo.org> at-spi-1.20.1.ebuild:
Stable for HPPA (bug #199740).
diff --git a/gnome-extra/at-spi/at-spi-1.20.1.ebuild b/gnome-extra/at-spi/at-spi-1.20.1.ebuild
index ab1063a6db62..5d8753c85a03 100644
--- a/gnome-extra/at-spi/at-spi-1.20.1.ebuild
+++ b/gnome-extra/at-spi/at-spi-1.20.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.20.1.ebuild,v 1.7 2007/11/29 05:12:27 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/at-spi/at-spi-1.20.1.ebuild,v 1.8 2008/02/18 11:48:57 eva Exp $
WANT_AUTOMAKE="1.9"
-inherit virtualx autotools eutils gnome2
+inherit virtualx autotools eutils gnome2 python
DESCRIPTION="The Gnome Accessibility Toolkit"
HOMEPAGE="http://developer.gnome.org/projects/gap/"
@@ -14,12 +14,15 @@ SLOT="1"
KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
IUSE="doc"
+#next bump: check if we should activate Xevie or not
+
RDEPEND=">=dev-libs/atk-1.17
>=x11-libs/gtk+-2.10.0
>=gnome-base/gail-1.9.0
>=gnome-base/libbonobo-1.107
>=gnome-base/orbit-2
dev-libs/popt
+ >=dev-lang/python-2.4
x11-libs/libICE
x11-libs/libSM
@@ -42,13 +45,31 @@ DOCS="AUTHORS ChangeLog NEWS README TODO"
src_unpack() {
gnome2_src_unpack
- #
+ # bug number ?
epatch "${FILESDIR}"/${PN}-1.19.3-tests.patch
- cp aclocal.m4 old_macros.m4
- AT_M4DIR="." eautoreconf
+ # disable pyc compiling
+ mv py-compile py-compile.orig
+ ln -s $(type -P true) py-compile
+
+ # drop gtk-doc for autoreconf
+ use doc || epatch "${FILESDIR}/${P}-drop-gtk-doc.patch"
+
+ eautoreconf
}
src_test() {
- Xmake check || die "Testing phase failed"
+ Xemake check || die "Testing phase failed"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages/pyatspi
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+ python_version
+ python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages/pyatspi
}
diff --git a/gnome-extra/at-spi/files/at-spi-1.20.1-drop-gtk-doc.patch b/gnome-extra/at-spi/files/at-spi-1.20.1-drop-gtk-doc.patch
new file mode 100644
index 000000000000..a0f5007ed955
--- /dev/null
+++ b/gnome-extra/at-spi/files/at-spi-1.20.1-drop-gtk-doc.patch
@@ -0,0 +1,29 @@
+--- configure.in.old 2008-02-18 12:12:11.000000000 +0100
++++ configure.in 2008-02-18 12:13:02.000000000 +0100
+@@ -66,8 +66,14 @@
+ localedir='${prefix}/${DATADIRNAME}/locale'
+ AC_SUBST(localedir)
+
++dnl Crazy hack for dropping the dep on gtk-doc
++AC_DEFUN(GTK_DOC_CHECK, [])
+ GTK_DOC_CHECK([1.0])
+
++dnl Crazy hack for dropping the dep on gtk-doc
++AM_CONDITIONAL(ENABLE_GTK_DOC, 0, [])
++AM_CONDITIONAL(GTK_DOC_USE_LIBTOOL, 0, [])
++
+ AC_PATH_XTRA
+
+ if test x$no_x = xyes ; then
+--- Makefile.am.old 2008-02-18 12:13:08.000000000 +0100
++++ Makefile.am 2008-02-18 12:13:59.000000000 +0100
+@@ -1,4 +1,8 @@
+-SUBDIRS = docs idl libspi login-helper registryd atk-bridge cspi pyatspi test po
++SUBDIRS = idl libspi login-helper registryd atk-bridge cspi pyatspi test po
++
++if ENABLE_GTK_DOC
++SUBDIRS += docs
++endif
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ pkgconfig_DATA = libspi-1.0.pc cspi-1.0.pc libloginhelper-1.0.pc