summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-01 07:52:14 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-01 07:52:14 +0000
commiteedfbaa574b843b391476ff3b3bd82246ef57128 (patch)
tree8da150e6eda5a656f5c0271c04ce5dad68a0f733 /gnome-extra/activity-log-manager
parentAdd patch to compile with latest gcc, #406277, provided by Helmut Jarausch; m... (diff)
downloadgentoo-2-eedfbaa574b843b391476ff3b3bd82246ef57128.tar.gz
gentoo-2-eedfbaa574b843b391476ff3b3bd82246ef57128.tar.bz2
gentoo-2-eedfbaa574b843b391476ff3b3bd82246ef57128.zip
Version Bump
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/activity-log-manager')
-rw-r--r--gnome-extra/activity-log-manager/ChangeLog8
-rw-r--r--gnome-extra/activity-log-manager/activity-log-manager-0.9.2.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/gnome-extra/activity-log-manager/ChangeLog b/gnome-extra/activity-log-manager/ChangeLog
index cfc7c91b8c53..94f5c74fe5dc 100644
--- a/gnome-extra/activity-log-manager/ChangeLog
+++ b/gnome-extra/activity-log-manager/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/activity-log-manager
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.3 2012/02/15 18:29:05 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.4 2012/03/01 07:52:14 jlec Exp $
+
+*activity-log-manager-0.9.2 (01 Mar 2012)
+
+ 01 Mar 2012; Justin Lecher <jlec@gentoo.org>
+ +activity-log-manager-0.9.2.ebuild:
+ Version Bump
*activity-log-manager-0.9.1 (15 Feb 2012)
diff --git a/gnome-extra/activity-log-manager/activity-log-manager-0.9.2.ebuild b/gnome-extra/activity-log-manager/activity-log-manager-0.9.2.ebuild
new file mode 100644
index 000000000000..d1b10863a085
--- /dev/null
+++ b/gnome-extra/activity-log-manager/activity-log-manager-0.9.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/activity-log-manager-0.9.2.ebuild,v 1.1 2012/03/01 07:52:14 jlec Exp $
+
+EAPI=4
+
+inherit autotools gnome2 versionator
+
+DESCRIPTION="GUI which lets you easily control what gets logged by Zeitgeist"
+HOMEPAGE="https://launchpad.net/activity-log-manager/"
+SRC_URI="http://launchpad.net/history-manager/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VALASLOT="0.10"
+
+RDEPEND="
+ gnome-extra/zeitgeist
+ x11-libs/gtk+:3
+ dev-libs/libgee:0
+ dev-libs/glib:2"
+DEPEND="${RDEPEND}
+ dev-lang/vala:${VALASLOT}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+#S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ DOCS="README NEWS INSTALL ChangeLog AUTHORS"
+# no without possible
+# G2CONF="${G2CONF}
+# --without-ccpanel
+# --without-whoopsie"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.0.1-gold.patch \
+ "${FILESDIR}"/${PN}-0.9.1-ccpanel.patch
+ sed \
+ -e "/^almdocdir/s:=.*$:= \${prefix}/share/doc/${PF}:g" \
+ -i Makefile.am || die
+ sed \
+ -e 's:-g::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+ export VALAC="$(type -p valac-${VALASLOT})"
+ gnome2_src_prepare
+}