summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-03-25 13:38:30 +0000
committerJustin Lecher <jlec@gentoo.org>2012-03-25 13:38:30 +0000
commit74e363a87168b8eb973fa40c6b0691e9e0b67952 (patch)
tree8328f9d10108f74f539216517b9cde84fe6e29c2 /gnome-extra/activity-log-manager
parentRemove old. (diff)
downloadgentoo-2-74e363a87168b8eb973fa40c6b0691e9e0b67952.tar.gz
gentoo-2-74e363a87168b8eb973fa40c6b0691e9e0b67952.tar.bz2
gentoo-2-74e363a87168b8eb973fa40c6b0691e9e0b67952.zip
Version Bump
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'gnome-extra/activity-log-manager')
-rw-r--r--gnome-extra/activity-log-manager/ChangeLog8
-rw-r--r--gnome-extra/activity-log-manager/activity-log-manager-0.9.4.ebuild58
2 files changed, 65 insertions, 1 deletions
diff --git a/gnome-extra/activity-log-manager/ChangeLog b/gnome-extra/activity-log-manager/ChangeLog
index a9bd343d27dd..cc38c92dc7f9 100644
--- a/gnome-extra/activity-log-manager/ChangeLog
+++ b/gnome-extra/activity-log-manager/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-extra/activity-log-manager
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.6 2012/03/15 06:53:46 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/ChangeLog,v 1.7 2012/03/25 13:38:30 jlec Exp $
+
+*activity-log-manager-0.9.4 (25 Mar 2012)
+
+ 25 Mar 2012; Justin Lecher <jlec@gentoo.org>
+ +activity-log-manager-0.9.4.ebuild:
+ Version Bump
15 Mar 2012; Justin Lecher <jlec@gentoo.org>
-activity-log-manager-0.9.0.1.ebuild, -activity-log-manager-0.9.1.ebuild,
diff --git a/gnome-extra/activity-log-manager/activity-log-manager-0.9.4.ebuild b/gnome-extra/activity-log-manager/activity-log-manager-0.9.4.ebuild
new file mode 100644
index 000000000000..027132013f02
--- /dev/null
+++ b/gnome-extra/activity-log-manager/activity-log-manager-0.9.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/activity-log-manager/activity-log-manager-0.9.4.ebuild,v 1.1 2012/03/25 13:38:30 jlec Exp $
+
+EAPI=4
+
+inherit autotools gnome2 versionator
+
+DESCRIPTION="GUI which lets you easily control what gets logged by Zeitgeist"
+HOMEPAGE="https://launchpad.net/activity-log-manager/"
+SRC_URI="http://launchpad.net/history-manager/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VALASLOT="0.10"
+
+RDEPEND="
+ dev-libs/libzeitgeist
+ dev-libs/libgee:0
+ dev-libs/glib:2
+ gnome-extra/zeitgeist
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/pango"
+DEPEND="${RDEPEND}
+ dev-lang/vala:${VALASLOT}
+ dev-util/intltool
+ sys-devel/gettext
+"
+
+#S="${WORKDIR}/${MY_PN}-${PV}"
+
+pkg_setup() {
+ DOCS="README NEWS INSTALL ChangeLog AUTHORS"
+# no without possible
+# G2CONF="${G2CONF}
+# --without-ccpanel
+# --without-whoopsie"
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.9.0.1-gold.patch \
+ "${FILESDIR}"/${PN}-0.9.1-ccpanel.patch
+ sed \
+ -e "/^almdocdir/s:=.*$:= \${prefix}/share/doc/${PF}:g" \
+ -i Makefile.am || die
+ sed \
+ -e 's:-g::g' \
+ -i src/Makefile.am || die
+ eautoreconf
+ export VALAC="$(type -p valac-${VALASLOT})"
+ gnome2_src_prepare
+}