summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2013-04-07 11:46:49 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2013-04-07 11:46:49 +0000
commitf9596efe121cfd4dfbf6f4ad0ae110ecb2bd6b67 (patch)
tree264ed23879fa8078494bdc6d2ef44fd1168836d2 /gnome-base
parentVersion bump. (diff)
downloadgentoo-2-f9596efe121cfd4dfbf6f4ad0ae110ecb2bd6b67.tar.gz
gentoo-2-f9596efe121cfd4dfbf6f4ad0ae110ecb2bd6b67.tar.bz2
gentoo-2-f9596efe121cfd4dfbf6f4ad0ae110ecb2bd6b67.zip
Make gsettings-schema-convert support multiple python, needed for correct build of ibus-1.5.
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key C6085806)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gconf/ChangeLog8
-rw-r--r--gnome-base/gconf/gconf-3.2.6-r1.ebuild115
2 files changed, 122 insertions, 1 deletions
diff --git a/gnome-base/gconf/ChangeLog b/gnome-base/gconf/ChangeLog
index 5cd31215bbd1..c7eadba725ed 100644
--- a/gnome-base/gconf/ChangeLog
+++ b/gnome-base/gconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gconf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.278 2013/04/03 18:43:29 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/ChangeLog,v 1.279 2013/04/07 11:46:49 eva Exp $
+
+*gconf-3.2.6-r1 (07 Apr 2013)
+
+ 07 Apr 2013; Gilles Dartiguelongue <eva@gentoo.org> +gconf-3.2.6-r1.ebuild:
+ Make gsettings-schema-convert support multiple python, needed for correct
+ build of ibus-1.5.
03 Apr 2013; Fabian Groffen <grobian@gentoo.org> gconf-3.2.6.ebuild:
No EPREFIX in CONFIG_PROTECT*
diff --git a/gnome-base/gconf/gconf-3.2.6-r1.ebuild b/gnome-base/gconf/gconf-3.2.6-r1.ebuild
new file mode 100644
index 000000000000..b565524bc9db
--- /dev/null
+++ b/gnome-base/gconf/gconf-3.2.6-r1.ebuild
@@ -0,0 +1,115 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gconf/gconf-3.2.6-r1.ebuild,v 1.1 2013/04/07 11:46:49 eva Exp $
+
+EAPI="5"
+GCONF_DEBUG="yes"
+GNOME_ORG_MODULE="GConf"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_{5,6,7} )
+PYTHON_REQ_USE="xml"
+
+inherit eutils gnome2 python-r1
+
+DESCRIPTION="GNOME configuration system and daemon"
+HOMEPAGE="http://projects.gnome.org/gconf/"
+
+LICENSE="LGPL-2+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="debug gtk +introspection ldap orbit policykit"
+
+RDEPEND="
+ >=dev-libs/glib-2.31:2
+ >=dev-libs/dbus-glib-0.74:=
+ >=sys-apps/dbus-1:=
+ >=dev-libs/libxml2-2:2
+ gtk? ( >=x11-libs/gtk+-2.90:3 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ ldap? ( net-nds/openldap:= )
+ orbit? ( >=gnome-base/orbit-2.4:2 )
+ policykit? ( sys-auth/polkit:= )
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ dev-libs/libxslt
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ kill_gconf
+}
+
+src_prepare() {
+ # Do not start gconfd when installing schemas, fix bug #238276, upstream #631983
+ epatch "${FILESDIR}/${PN}-2.24.0-no-gconfd.patch"
+
+ # Do not crash in gconf_entry_set_value() when entry pointer is NULL, upstream #631985
+ epatch "${FILESDIR}/${PN}-2.28.0-entry-set-value-sigsegv.patch"
+
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --enable-gsettings-backend \
+ $(use_enable gtk) \
+ $(usex gtk --with-gtk=3.0 "") \
+ $(use_enable introspection) \
+ $(use_with ldap openldap) \
+ $(use_enable orbit) \
+ $(use_enable policykit defaults-service) \
+ ORBIT_IDL=$(type -P orbit-idl-2)
+}
+
+src_install() {
+ gnome2_src_install
+ python_replicate_script "${ED}"/usr/bin/gsettings-schema-convert || die
+
+ keepdir /etc/gconf/gconf.xml.mandatory
+ keepdir /etc/gconf/gconf.xml.defaults
+ # Make sure this directory exists, bug #268070, upstream #572027
+ keepdir /etc/gconf/gconf.xml.system
+
+ echo "CONFIG_PROTECT_MASK=\"/etc/gconf\"" > 50gconf
+ echo 'GSETTINGS_BACKEND="gconf"' >> 50gconf
+ doenvd 50gconf
+ dodir /root/.gconfd
+}
+
+pkg_preinst() {
+ kill_gconf
+}
+
+pkg_postinst() {
+ kill_gconf
+
+ # change the permissions to avoid some gconf bugs
+ einfo "changing permissions for gconf dirs"
+ find "${EPREFIX}"/etc/gconf/ -type d -exec chmod ugo+rx "{}" \;
+
+ einfo "changing permissions for gconf files"
+ find "${EPREFIX}"/etc/gconf/ -type f -exec chmod ugo+r "{}" \;
+
+ if ! use orbit; then
+ ewarn "You are using dbus for GConf's IPC. If you are upgrading from"
+ ewarn "<=gconf-3.2.3, or were previously using gconf with USE=orbit,"
+ ewarn "you will need to now restart your desktop session (for example,"
+ ewarn "by logging out and then back in)."
+ ewarn "Otherwise, gconf-based applications may crash with 'Method ..."
+ ewarn "on interface \"org.gnome.GConf.Server\" doesn't exist' errors."
+ fi
+}
+
+kill_gconf() {
+ # This function will kill all running gconfd-2 that could be causing troubles
+ if [ -x "${EPREFIX}"/usr/bin/gconftool-2 ]
+ then
+ "${EPREFIX}"/usr/bin/gconftool-2 --shutdown
+ fi
+
+ return 0
+}