summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-02-08 19:04:13 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-02-08 19:04:13 +0000
commit72e4bd778c6203ddf91229bcf6d6132086de0ac2 (patch)
tree8d84590edb847d8a415a0b7126e385d14a9c737f /gnome-base
parentVersion bump. (diff)
downloadgentoo-2-72e4bd778c6203ddf91229bcf6d6132086de0ac2.tar.gz
gentoo-2-72e4bd778c6203ddf91229bcf6d6132086de0ac2.tar.bz2
gentoo-2-72e4bd778c6203ddf91229bcf6d6132086de0ac2.zip
Fix building with x11-libs/libnotify >= 0.7 wrt #354117 by Diego Elio Pettenò.
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-applets/ChangeLog8
-rw-r--r--gnome-base/gnome-applets/files/gnome-applets-2.32.1.1-libnotify-0.7.patch53
-rw-r--r--gnome-base/gnome-applets/gnome-applets-2.32.1.1.ebuild4
3 files changed, 63 insertions, 2 deletions
diff --git a/gnome-base/gnome-applets/ChangeLog b/gnome-base/gnome-applets/ChangeLog
index e340d7d318ee..d83dcd65137e 100644
--- a/gnome-base/gnome-applets/ChangeLog
+++ b/gnome-base/gnome-applets/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/gnome-applets
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/ChangeLog,v 1.333 2011/01/18 14:19:25 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/ChangeLog,v 1.334 2011/02/08 19:04:13 ssuominen Exp $
+
+ 08 Feb 2011; Samuli Suominen <ssuominen@gentoo.org>
+ gnome-applets-2.32.1.1.ebuild,
+ +files/gnome-applets-2.32.1.1-libnotify-0.7.patch:
+ Fix building with x11-libs/libnotify >= 0.7 wrt #354117 by Diego Elio
+ Pettenò.
18 Jan 2011; <nirbheek@gentoo.org> gnome-applets-2.32.1.1.ebuild:
Fix accidental SLOT change in gnome-applets-2.32
diff --git a/gnome-base/gnome-applets/files/gnome-applets-2.32.1.1-libnotify-0.7.patch b/gnome-base/gnome-applets/files/gnome-applets-2.32.1.1-libnotify-0.7.patch
new file mode 100644
index 000000000000..f2b889ec0324
--- /dev/null
+++ b/gnome-base/gnome-applets/files/gnome-applets-2.32.1.1-libnotify-0.7.patch
@@ -0,0 +1,53 @@
+--- battstat/battstat_applet.c
++++ battstat/battstat_applet.c
+@@ -42,6 +42,9 @@
+
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #include "battstat.h"
+@@ -435,7 +438,12 @@
+ GTK_ICON_LOOKUP_USE_BUILTIN,
+ NULL);
+
+- NotifyNotification *n = notify_notification_new (_("Your battery is now fully recharged"), "", /* "battery" */ NULL, applet);
++ NotifyNotification *n = notify_notification_new (_("Your battery is now fully recharged"), "", /* "battery" */ NULL
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , applet);
++#endif
+
+ /* XXX: it would be nice to pass this as a named icon */
+ notify_notification_set_icon_from_pixbuf (n, icon);
+--- gweather/gweather-applet.c
++++ gweather/gweather-applet.c
+@@ -30,6 +30,9 @@
+ #ifdef HAVE_LIBNOTIFY
+ #include <libnotify/notify.h>
+ #include <libnotify/notification.h>
++#ifndef NOTIFY_CHECK_VERSION
++#define NOTIFY_CHECK_VERSION(x,y,z) 0
++#endif
+ #endif
+
+ #define GWEATHER_I_KNOW_THIS_IS_UNSTABLE
+@@ -471,8 +474,12 @@
+ if (icon == NULL)
+ icon = "stock-unknown";
+
+- n = notify_notification_new (message, detail, icon,
+- gw_applet->container);
++ n = notify_notification_new (message, detail, icon
++#if NOTIFY_CHECK_VERSION (0, 7, 0)
++ );
++#else
++ , gw_applet->container);
++#endif
+
+ notify_notification_show (n, &error);
+ if (error)
diff --git a/gnome-base/gnome-applets/gnome-applets-2.32.1.1.ebuild b/gnome-base/gnome-applets/gnome-applets-2.32.1.1.ebuild
index e9177f1c536b..ca26b1d35c1b 100644
--- a/gnome-base/gnome-applets/gnome-applets-2.32.1.1.ebuild
+++ b/gnome-base/gnome-applets/gnome-applets-2.32.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-2.32.1.1.ebuild,v 1.5 2011/01/18 14:19:25 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-2.32.1.1.ebuild,v 1.6 2011/02/08 19:04:13 ssuominen Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -83,6 +83,8 @@ pkg_setup() {
}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libnotify-0.7.patch
+
gnome2_src_prepare
# disable pyc compiling