summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-07-17 20:11:02 +0000
committerPacho Ramos <pacho@gentoo.org>2013-07-17 20:11:02 +0000
commit5dbf319349149c942f5608fc0b51794411b64731 (patch)
tree54b44fe36ab2b7945c3ee8d530834de9283bbbfc /gnome-base
parentadd ~arm, bug #473472 (diff)
downloadgentoo-2-5dbf319349149c942f5608fc0b51794411b64731.tar.gz
gentoo-2-5dbf319349149c942f5608fc0b51794411b64731.tar.bz2
gentoo-2-5dbf319349149c942f5608fc0b51794411b64731.zip
Version bump
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/dconf/ChangeLog7
-rw-r--r--gnome-base/dconf/dconf-0.16.1.ebuild74
2 files changed, 80 insertions, 1 deletions
diff --git a/gnome-base/dconf/ChangeLog b/gnome-base/dconf/ChangeLog
index 5398a4754d95..a561860e70ad 100644
--- a/gnome-base/dconf/ChangeLog
+++ b/gnome-base/dconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for gnome-base/dconf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.46 2013/06/26 13:42:44 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/ChangeLog,v 1.47 2013/07/17 20:11:02 pacho Exp $
+
+*dconf-0.16.1 (17 Jul 2013)
+
+ 17 Jul 2013; Pacho Ramos <pacho@gentoo.org> +dconf-0.16.1.ebuild:
+ Version bump
26 Jun 2013; Alexandre Rostovtsev <tetromino@gentoo.org> dconf-0.14.1.ebuild,
dconf-0.16.0.ebuild:
diff --git a/gnome-base/dconf/dconf-0.16.1.ebuild b/gnome-base/dconf/dconf-0.16.1.ebuild
new file mode 100644
index 000000000000..396f3f42be32
--- /dev/null
+++ b/gnome-base/dconf/dconf-0.16.1.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/dconf/dconf-0.16.1.ebuild,v 1.1 2013/07/17 20:11:02 pacho Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2 bash-completion-r1 virtualx
+
+DESCRIPTION="Simple low-level configuration system"
+HOMEPAGE="https://wiki.gnome.org/dconf"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+# TODO: coverage ?
+IUSE="test +X"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~arm-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.35.2:2
+ sys-apps/dbus
+ X? (
+ >=dev-libs/libxml2-2.7.7:2
+ >=x11-libs/gtk+-3.4:3 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.50
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-gcov \
+ --enable-man \
+ $(use_enable X editor) \
+ VALAC=$(type -P valac-0.18) # harmless even if valac-0.18 not found
+}
+
+src_test() {
+ Xemake check
+}
+
+src_install() {
+ gnome2_src_install
+
+ # GSettings backend may be one of: memory, gconf, dconf
+ # Only dconf is really considered functional by upstream
+ # must have it enabled over gconf if both are installed
+ echo 'CONFIG_PROTECT_MASK="/etc/dconf"' >> 51dconf
+ echo 'GSETTINGS_BACKEND="dconf"' >> 51dconf
+ doenvd 51dconf
+
+ # Install bash-completion file properly to the system
+ rm -rv "${ED}usr/share/bash-completion" || die
+ dobashcomp "${S}/bin/completion/dconf"
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ # Kill existing dconf-service processes as recommended by upstream due to
+ # possible changes in the dconf private dbus API.
+ # dconf-service will be dbus-activated on next use.
+ pids=$(pgrep -x dconf-service)
+ if [[ $? == 0 ]]; then
+ ebegin "Stopping dconf-service; it will automatically restart on demand"
+ kill ${pids}
+ eend $?
+ fi
+}