summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGabriele Giorgetti <stroke@gentoo.org>2002-06-19 17:53:37 +0000
committerGabriele Giorgetti <stroke@gentoo.org>2002-06-19 17:53:37 +0000
commit11b62b7dfcd6fbc1c652797d9eb4771bfeaaa648 (patch)
treeee09e15821cc4975323347333f8be611cbcb0f70 /gnome-base/librsvg
parentnew version, hit stable. (diff)
downloadgentoo-2-11b62b7dfcd6fbc1c652797d9eb4771bfeaaa648.tar.gz
gentoo-2-11b62b7dfcd6fbc1c652797d9eb4771bfeaaa648.tar.bz2
gentoo-2-11b62b7dfcd6fbc1c652797d9eb4771bfeaaa648.zip
Added missing GTK+2 dep. (librsvg was failing to build without GTK+2 emerged)
Diffstat (limited to 'gnome-base/librsvg')
-rw-r--r--gnome-base/librsvg/ChangeLog11
-rw-r--r--gnome-base/librsvg/files/digest-librsvg-2.0.0-r11
-rw-r--r--gnome-base/librsvg/librsvg-2.0.0-r1.ebuild49
3 files changed, 58 insertions, 3 deletions
diff --git a/gnome-base/librsvg/ChangeLog b/gnome-base/librsvg/ChangeLog
index 3c3f335bafb0..a3ad69dc8c65 100644
--- a/gnome-base/librsvg/ChangeLog
+++ b/gnome-base/librsvg/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for gnome-base/librsvg
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.3 2002/06/19 17:09:55 stroke Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.4 2002/06/19 17:53:32 stroke Exp $
-*librsvg-2.0.0 (19 May 2002)
- 22 May 2002; Gabriele Giorgetti <stroke@gentoo.org> librsvg-2.0.0.ebuild:
+*librsvg-2.0.0-r1 (19 Jun 2002)
+ 19 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> librsvg-2.0.0-r1.ebuild:
+ Added missing GTK+2 depencie. (librsvg was failing to build if no GTK+2
+ emerged).
+
+*librsvg-2.0.0 (19 Jun 2002)
+ 19 Jun 2002; Gabriele Giorgetti <stroke@gentoo.org> librsvg-2.0.0.ebuild:
Yay! version 2.0.0
*librsvg-1.1.6-r2 (22 May 2002)
diff --git a/gnome-base/librsvg/files/digest-librsvg-2.0.0-r1 b/gnome-base/librsvg/files/digest-librsvg-2.0.0-r1
new file mode 100644
index 000000000000..e47fe96e2a31
--- /dev/null
+++ b/gnome-base/librsvg/files/digest-librsvg-2.0.0-r1
@@ -0,0 +1 @@
+MD5 6a216a7f75956ce936755f365be1a16d librsvg-2.0.0.tar.bz2 154789
diff --git a/gnome-base/librsvg/librsvg-2.0.0-r1.ebuild b/gnome-base/librsvg/librsvg-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..fa5e151eae1b
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.0.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.0.0-r1.ebuild,v 1.1 2002/06/19 17:53:37 stroke Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="rendering svg library"
+SRC_URI="ftp://ftp.gnome.org/pub/gnome/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="2"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ >=x11-libs/gtk+-2.0.5
+ >=media-libs/libart_lgpl-2.3.8-r1
+ >=dev-libs/libxml2-2.4.17
+ >=x11-libs/pango-1.0.3"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-platform-gnome-2 \
+ --enable-debug=yes || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYIN* README INSTALL NEWS TODO
+}
+
+