summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-02 20:40:20 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-02 20:40:20 +0000
commitc3acd4ddfd886cfc0ed123a55fb0fc803aa26f7b (patch)
tree5c8cb4c496d1af3e58f922cbd9664a27dee29b63 /gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild
parentDrop DEPRECATED flags, bug #384743 (diff)
downloadgentoo-2-c3acd4ddfd886cfc0ed123a55fb0fc803aa26f7b.tar.gz
gentoo-2-c3acd4ddfd886cfc0ed123a55fb0fc803aa26f7b.tar.bz2
gentoo-2-c3acd4ddfd886cfc0ed123a55fb0fc803aa26f7b.zip
Drop DEPRECATED flags, bug #384807; remove old.
(Portage version: 2.1.10.20/cvs/Linux x86_64)
Diffstat (limited to 'gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild')
-rw-r--r--gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild b/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild
index 10417e0face0..23733f9f3dd1 100644
--- a/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild
+++ b/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild,v 1.6 2011/03/22 19:17:54 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libgnomeprint/libgnomeprint-2.18.8.ebuild,v 1.7 2011/10/02 20:40:20 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
@@ -42,3 +42,14 @@ pkg_setup() {
# dependencies on an untracked library.
G2CONF="${G2CONF} $(use_with cups) --without-papi --disable-static"
}
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Drop DEPRECATED flags, bug #384807
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED::g' \
+ configure.in configure || die
+ sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' \
+ libgnomeprint/ttsubset/Makefile.am \
+ libgnomeprint/ttsubset/Makefile.in || die
+}