summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-10-04 15:12:02 +0000
committerMart Raudsepp <leio@gentoo.org>2008-10-04 15:12:02 +0000
commita3be1055ab9440c37a44beeb5336108c3d9f76ec (patch)
tree05ecc576a841605c84edfbd1fa517cf63a5c29e5 /gnome-base/libbonoboui
parentMarked ~hppa (bug #239121). (diff)
downloadgentoo-2-a3be1055ab9440c37a44beeb5336108c3d9f76ec.tar.gz
gentoo-2-a3be1055ab9440c37a44beeb5336108c3d9f76ec.tar.bz2
gentoo-2-a3be1055ab9440c37a44beeb5336108c3d9f76ec.zip
New version; super/hyper/meta support in bonobo keybindings, code cleanups and gnome-vfs dependency removal
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'gnome-base/libbonoboui')
-rw-r--r--gnome-base/libbonoboui/ChangeLog8
-rw-r--r--gnome-base/libbonoboui/libbonoboui-2.24.0.ebuild44
2 files changed, 51 insertions, 1 deletions
diff --git a/gnome-base/libbonoboui/ChangeLog b/gnome-base/libbonoboui/ChangeLog
index 69dd5e467f87..34c86573fc65 100644
--- a/gnome-base/libbonoboui/ChangeLog
+++ b/gnome-base/libbonoboui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for gnome-base/libbonoboui
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/ChangeLog,v 1.164 2008/09/25 14:20:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/ChangeLog,v 1.165 2008/10/04 15:12:02 leio Exp $
+
+*libbonoboui-2.24.0 (04 Oct 2008)
+
+ 04 Oct 2008; Mart Raudsepp <leio@gentoo.org> +libbonoboui-2.24.0.ebuild:
+ New version; super/hyper/meta support in bonobo keybindings, code cleanups
+ and gnome-vfs dependency removal
25 Sep 2008; Jeroen Roovers <jer@gentoo.org> libbonoboui-2.22.0.ebuild:
Stable for HPPA (bug #236971).
diff --git a/gnome-base/libbonoboui/libbonoboui-2.24.0.ebuild b/gnome-base/libbonoboui/libbonoboui-2.24.0.ebuild
new file mode 100644
index 000000000000..5715d3e4827f
--- /dev/null
+++ b/gnome-base/libbonoboui/libbonoboui-2.24.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/libbonoboui-2.24.0.ebuild,v 1.1 2008/10/04 15:12:02 leio Exp $
+
+inherit eutils virtualx gnome2
+
+DESCRIPTION="User Interface part of libbonobo"
+HOMEPAGE="http://developer.gnome.org/arch/gnome/componentmodel/bonobo.html"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+# GTK+ dep due to bug #126565
+RDEPEND=">=gnome-base/libgnomecanvas-1.116
+ >=gnome-base/libbonobo-2.22
+ >=gnome-base/libgnome-2.13.7
+ >=dev-libs/libxml2-2.4.20
+ >=gnome-base/gconf-2
+ >=x11-libs/gtk+-2.8.12
+ >=dev-libs/glib-2.6.0
+ >=gnome-base/libglade-1.99.11
+ >=dev-libs/popt-1.5"
+
+DEPEND="${RDEPEND}
+ x11-apps/xrdb
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.40
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+src_compile() {
+ addpredict "/root/.gnome2_private"
+
+ gnome2_src_compile
+}
+
+src_test() {
+ addwrite "/root/.gnome2_private"
+ Xemake check || die
+}