summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-03-10 22:30:16 +0000
committerMart Raudsepp <leio@gentoo.org>2008-03-10 22:30:16 +0000
commit1b8d030c193034363d55062ff95bd6c98fb7c9aa (patch)
tree6a816818ccbfecdf4e8051f2489a02cb52f65f94 /gnome-base/gnome-applets
parentRemove old (diff)
downloadgentoo-2-1b8d030c193034363d55062ff95bd6c98fb7c9aa.tar.gz
gentoo-2-1b8d030c193034363d55062ff95bd6c98fb7c9aa.tar.bz2
gentoo-2-1b8d030c193034363d55062ff95bd6c98fb7c9aa.zip
Remove GNOME 2.18
(Portage version: 2.1.4.4)
Diffstat (limited to 'gnome-base/gnome-applets')
-rw-r--r--gnome-base/gnome-applets/files/gnome-applets-2.18.0-acpi-procfs.patch137
-rw-r--r--gnome-base/gnome-applets/files/gnome-applets-2.18.0-gtk+-2.12-compat.patch12
-rw-r--r--gnome-base/gnome-applets/gnome-applets-2.18.0-r3.ebuild116
-rw-r--r--gnome-base/gnome-applets/gnome-applets-2.20.0.ebuild110
4 files changed, 0 insertions, 375 deletions
diff --git a/gnome-base/gnome-applets/files/gnome-applets-2.18.0-acpi-procfs.patch b/gnome-base/gnome-applets/files/gnome-applets-2.18.0-acpi-procfs.patch
deleted file mode 100644
index 3b02e15ce817..000000000000
--- a/gnome-base/gnome-applets/files/gnome-applets-2.18.0-acpi-procfs.patch
+++ /dev/null
@@ -1,137 +0,0 @@
-
-From: Daniel Drake <dsd@gentoo.org>
-
-2.6.21 compatibility fix (based on patch by Alan Swanson). Also improved error
-passing/handling. (#427562)
-
-http://bugzilla.gnome.org/show_bug.cgi?id=427562
-https://bugs.gentoo.org/show_bug.cgi?id=176757
-
-Index: battstat/acpi-linux.c
-===================================================================
---- battstat/acpi-linux.c (revision 10278)
-+++ battstat/acpi-linux.c (revision 10280)
-@@ -191,7 +191,6 @@
- static gboolean update_battery_info(struct acpi_info * acpiinfo)
- {
- char batt_info[60];
-- gulong acpi_ver;
- GHashTable *hash;
- DIR * procdir;
- struct dirent * procdirentry;
-@@ -201,23 +200,6 @@
- acpiinfo->low_capacity = 0;
- acpiinfo->critical_capacity = 0;
-
-- hash = read_file ("/proc/acpi/info", buf, sizeof (buf));
-- if (!hash)
-- return FALSE;
--
-- acpi_ver = read_ulong (hash, "version");
-- g_hash_table_destroy (hash);
--
-- if (acpi_ver < (gulong)20020208) {
-- acpiinfo->ac_state_state = "status";
-- acpiinfo->batt_state_state = "status";
-- acpiinfo->charging_state = "state";
-- } else {
-- acpiinfo->ac_state_state = "state";
-- acpiinfo->batt_state_state = "state";
-- acpiinfo->charging_state = "charging state";
-- }
--
- procdir=opendir("/proc/acpi/battery/");
- if (!procdir)
- return FALSE;
-@@ -252,16 +234,40 @@
- * initializes the stored battery and AC adapter information. */
- gboolean acpi_linux_init(struct acpi_info * acpiinfo)
- {
-+ GHashTable *hash;
-+ char buf[BUFSIZ];
-+ gchar *pbuf;
-+ gulong acpi_ver;
- int fd;
-
- g_assert(acpiinfo);
-+
-+ if (g_file_get_contents ("/sys/module/acpi/parameters/acpica_version", &pbuf, NULL, NULL)) {
-+ acpi_ver = strtoul (pbuf, NULL, 10);
-+ g_free (pbuf);
-+ } else if (hash = read_file ("/proc/acpi/info", buf, sizeof (buf))) {
-+ acpi_ver = read_ulong (hash, "version");
-+ g_hash_table_destroy (hash);
-+ } else
-+ return FALSE;
-+
-+ if (acpi_ver < (gulong)20020208) {
-+ acpiinfo->ac_state_state = "status";
-+ acpiinfo->batt_state_state = "status";
-+ acpiinfo->charging_state = "state";
-+ } else {
-+ acpiinfo->ac_state_state = "state";
-+ acpiinfo->batt_state_state = "state";
-+ acpiinfo->charging_state = "charging state";
-+ }
-+
-+ if (!update_battery_info(acpiinfo) || !update_ac_info(acpiinfo))
-+ return FALSE;
-
- fd = open("/proc/acpi/event", 0);
- if (fd >= 0) {
- acpiinfo->event_fd = fd;
- acpiinfo->channel = g_io_channel_unix_new(fd);
-- update_battery_info(acpiinfo);
-- update_ac_info(acpiinfo);
- return TRUE;
- }
-
-@@ -273,8 +279,6 @@
- if (connect(fd, (struct sockaddr *) &addr, sizeof(addr)) == 0) {
- acpiinfo->event_fd = fd;
- acpiinfo->channel = g_io_channel_unix_new(fd);
-- update_battery_info(acpiinfo);
-- update_ac_info(acpiinfo);
- return TRUE;
- }
- }
-@@ -323,7 +327,6 @@
- {
- gsize i;
- int evt;
-- gboolean result = FALSE;
- GString *buffer;
- GError *gerror=NULL;
- buffer=g_string_new(NULL);
-@@ -333,21 +336,18 @@
- evt = parse_acpi_event(buffer);
- switch (evt) {
- case ACPI_EVENT_AC:
-- update_ac_info(acpiinfo);
-- result = TRUE;
-- break;
-+ return update_ac_info(acpiinfo);
- case ACPI_EVENT_BATTERY_INFO:
-- update_battery_info(acpiinfo);
-- /* Update AC info on battery info updates. This works around
-- * a bug in ACPI (as per bug #163013).
-- */
-- update_ac_info(acpiinfo);
-- result = TRUE;
-- break;
-+ if (update_battery_info(acpiinfo)) {
-+ /* Update AC info on battery info updates. This works around
-+ * a bug in ACPI (as per bug #163013).
-+ */
-+ return update_ac_info(acpiinfo);
-+ }
-+ /* fall-through */
-+ default:
-+ return FALSE;
- }
--
--
-- return result;
- }
-
- /*
diff --git a/gnome-base/gnome-applets/files/gnome-applets-2.18.0-gtk+-2.12-compat.patch b/gnome-base/gnome-applets/files/gnome-applets-2.18.0-gtk+-2.12-compat.patch
deleted file mode 100644
index b08ee1fdf03f..000000000000
--- a/gnome-base/gnome-applets/files/gnome-applets-2.18.0-gtk+-2.12-compat.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- mixer.orig/Makefile.am 2007-09-29 11:03:19.000000000 +1000
-+++ mixer/Makefile.am 2007-09-29 13:41:49.000000000 +1000
-@@ -1,9 +1,6 @@
- SUBDIRS = docs
-
- INCLUDES = -I. -I$(srcdir) \
-- -DG_DISABLE_DEPRECATED \
-- -DGTK_DISABLE_DEPRECATED \
-- -DGDK_DISABLE_DEPRECATED \
- $(MIXER_CFLAGS) \
- $(GNOME_APPLETS_CFLAGS) \
- $(GNOMEDESKTOP_CFLAGS)
diff --git a/gnome-base/gnome-applets/gnome-applets-2.18.0-r3.ebuild b/gnome-base/gnome-applets/gnome-applets-2.18.0-r3.ebuild
deleted file mode 100644
index 44866085790f..000000000000
--- a/gnome-base/gnome-applets/gnome-applets-2.18.0-r3.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-2.18.0-r3.ebuild,v 1.8 2007/11/23 17:42:19 jer Exp $
-
-inherit eutils gnome2 autotools
-
-DESCRIPTION="Applets for the GNOME Desktop and Panel"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2 FDL-1.1 LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="acpi apm doc gnome gstreamer hal ipv6"
-
-RDEPEND=">=x11-libs/gtk+-2.6
- >=dev-libs/glib-2.6
- >=gnome-base/libgnome-2.8
- >=gnome-base/libgnomeui-2.8
- >=gnome-base/gconf-2.8
- >=gnome-base/gnome-panel-2.13.4
- >=gnome-base/libglade-2.4
- >=gnome-base/gail-1.1
- >=x11-libs/libxklavier-2.91
- >=x11-libs/libwnck-2.9.3
- >=app-admin/system-tools-backends-1.1.3
- >=gnome-base/gnome-desktop-2.11.1
- >=x11-libs/libnotify-0.3.2
- hal? ( >=sys-apps/hal-0.5.3 )
- >=dev-libs/dbus-glib-0.71
- >=x11-themes/gnome-icon-theme-2.15.91
- >=dev-libs/libxml2-2.5.0
- >=virtual/python-2.4
- apm? ( sys-apps/apmd )
- x11-apps/xrdb x11-libs/libX11
- gnome? (
- gnome-base/libgnomekbd
- gnome-base/control-center
-
- >=gnome-extra/gucharmap-1.4
- >=gnome-base/libgtop-2.11.92
- >=gnome-base/gnome-vfs-2.15.4
-
- >=dev-python/pygtk-2.6
- >=dev-python/gnome-python-2.10
- )
- gstreamer? (
- >=media-libs/gstreamer-0.10.2
- >=media-libs/gst-plugins-base-0.10.2
- )"
-
-DEPEND="${RDEPEND}
- >=app-text/scrollkeeper-0.1.4
- >=dev-util/pkgconfig-0.19
- >=dev-util/intltool-0.35
- dev-libs/libxslt
- doc? (
- app-text/docbook-sgml-utils
- >=app-text/gnome-doc-utils-0.3.2
- ~app-text/docbook-xml-dtd-4.3
- )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-pkg_setup() {
- G2CONF="--disable-scrollkeeper --enable-flags \
- $(use_with hal)
- $(use_enable ipv6)
- $(use_enable doc gtk-doc)"
-
- if use gstreamer; then
- G2CONF="${G2CONF} --with-gstreamer=0.10"
- fi
-
- if ! use ppc && ! use apm && ! use acpi; then
- G2CONF="${G2CONF} --disable-battstat"
- fi
-
- if use ppc && ! use apm; then
- G2CONF="${G2CONF} --disable-battstat"
- fi
-}
-
-src_unpack() {
- gnome2_src_unpack
- epatch "${FILESDIR}/${P}-acpi-procfs.patch"
- epatch "${FILESDIR}/${P}-gtk+-2.12-compat.patch"
- AT_M4DIR="m4" eautoreconf
-}
-
-src_install() {
- gnome2_src_install
-
- APPLETS="accessx-status battstat charpick cpufreq drivemount geyes \
- gkb-new gswitchit gweather invest-applet mini-commander \
- mixer modemlights multiload null_applet stickynotes trashapplet"
-
- for applet in ${APPLETS} ; do
- docinto ${applet}
-
- for d in AUTHORS ChangeLog NEWS README README.themes TODO ; do
- [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
- done
- done
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- if use acpi && ! use hal ; then
- elog "It is highly recommended that you install acpid if you use the"
- elog "battstat applet to prevent any issues with other applications "
- elog "trying to read acpi information."
- fi
-}
diff --git a/gnome-base/gnome-applets/gnome-applets-2.20.0.ebuild b/gnome-base/gnome-applets/gnome-applets-2.20.0.ebuild
deleted file mode 100644
index 01bab5897510..000000000000
--- a/gnome-base/gnome-applets/gnome-applets-2.20.0.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/gnome-applets/gnome-applets-2.20.0.ebuild,v 1.8 2007/11/29 06:02:30 jer Exp $
-
-inherit eutils gnome2 autotools
-
-DESCRIPTION="Applets for the GNOME Desktop and Panel"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2 FDL-1.1 LGPL-2"
-SLOT="2"
-KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE="acpi apm doc gnome gstreamer hal ipv6 test"
-
-RDEPEND=">=x11-libs/gtk+-2.11
- >=dev-libs/glib-2.13
- >=gnome-base/libgnome-2.8
- >=gnome-base/libgnomeui-2.8
- >=gnome-base/gconf-2.8
- >=gnome-base/gnome-panel-2.13.4
- >=gnome-base/libglade-2.4
- >=gnome-base/gail-1.1
- >=x11-libs/libxklavier-2.91
- >=x11-libs/libwnck-2.9.3
- >=app-admin/system-tools-backends-1.1.3
- >=gnome-base/gnome-desktop-2.11.1
- >=x11-libs/libnotify-0.3.2
- hal? ( >=sys-apps/hal-0.5.3 )
- >=dev-libs/dbus-glib-0.71
- >=x11-themes/gnome-icon-theme-2.15.91
- >=dev-libs/libxml2-2.5.0
- >=virtual/python-2.4
- apm? ( sys-apps/apmd )
- x11-apps/xrdb x11-libs/libX11
- gnome? (
- gnome-base/libgnomekbd
- gnome-base/control-center
-
- >=gnome-extra/gucharmap-1.4
- >=gnome-base/libgtop-2.11.92
- >=gnome-base/gnome-vfs-2.15.4
-
- >=dev-python/pygtk-2.6
- >=dev-python/gnome-python-2.10
- )
- gstreamer? (
- >=media-libs/gstreamer-0.10.2
- >=media-libs/gst-plugins-base-0.10.2
- )"
-
-DEPEND="${RDEPEND}
- >=app-text/scrollkeeper-0.1.4
- >=dev-util/pkgconfig-0.19
- >=dev-util/intltool-0.35
- dev-libs/libxslt
- doc? (
- app-text/docbook-sgml-utils
- >=app-text/gnome-doc-utils-0.3.2
- ~app-text/docbook-xml-dtd-4.3
- )
- test? ( ~app-text/docbook-xml-dtd-4.3 )"
-
-DOCS="AUTHORS ChangeLog NEWS README"
-
-MAKEOPTS="${MAKEOPTS} -j1"
-
-pkg_setup() {
- G2CONF="--disable-scrollkeeper --enable-flags \
- $(use_with hal)
- $(use_enable ipv6)
- $(use_enable doc gtk-doc)"
-
- if use gstreamer; then
- G2CONF="${G2CONF} --with-gstreamer=0.10"
- fi
-
- if ! use ppc && ! use apm && ! use acpi; then
- G2CONF="${G2CONF} --disable-battstat"
- fi
-
- if use ppc && ! use apm; then
- G2CONF="${G2CONF} --disable-battstat"
- fi
-}
-
-src_install() {
- gnome2_src_install
-
- APPLETS="accessx-status battstat charpick cpufreq drivemount geyes \
- gkb-new gswitchit gweather invest-applet mini-commander \
- mixer modemlights multiload null_applet stickynotes trashapplet"
-
- for applet in ${APPLETS} ; do
- docinto ${applet}
-
- for d in AUTHORS ChangeLog NEWS README README.themes TODO ; do
- [ -s ${applet}/${d} ] && dodoc ${applet}/${d}
- done
- done
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
-
- if use acpi && ! use hal ; then
- elog "It is highly recommended that you install acpid if you use the"
- elog "battstat applet to prevent any issues with other applications "
- elog "trying to read acpi information."
- fi
-}