summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-11-08 12:08:56 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-11-08 12:08:56 +0000
commitc7cb7f944c8b4f276d3f1aca9f4d0d209a2052e5 (patch)
tree13f8da97a10c5e1e8b91f45ca0bb28d06b6b7666 /gnome-base/bonobo
parentfixed to use --mandir. fixed little destdir issue with a patch; the sed (diff)
downloadgentoo-2-c7cb7f944c8b4f276d3f1aca9f4d0d209a2052e5.tar.gz
gentoo-2-c7cb7f944c8b4f276d3f1aca9f4d0d209a2052e5.tar.bz2
gentoo-2-c7cb7f944c8b4f276d3f1aca9f4d0d209a2052e5.zip
updated to latest version
Diffstat (limited to 'gnome-base/bonobo')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.15.ebuild53
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.151
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.15.ebuild b/gnome-base/bonobo/bonobo-1.0.15.ebuild
new file mode 100644
index 000000000000..bbac89b5815a
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.15.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.15.ebuild,v 1.1 2001/11/08 12:08:56 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.7
+ >=gnome-base/ORBit-0.5.12
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.15 b/gnome-base/bonobo/files/digest-bonobo-1.0.15
new file mode 100644
index 000000000000..3744bdc11f9e
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.15
@@ -0,0 +1 @@
+MD5 185140e01a5ac4f5e3abff8fd5d6b0cb bonobo-1.0.15.tar.gz 1273856