summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikael Hallendal <hallski@gentoo.org>2001-10-25 14:58:40 +0000
committerMikael Hallendal <hallski@gentoo.org>2001-10-25 14:58:40 +0000
commit058ab448fd05a2345dae0cb25f7439eabdfaee26 (patch)
treebeb6b80d4d4338993fd8829a0d2cd64d52f1262a /gnome-base/bonobo
parentupdated to 1.1.90, didn't get 1.0.2 to work with pdf and it seems to be bette... (diff)
downloadgentoo-2-058ab448fd05a2345dae0cb25f7439eabdfaee26.tar.gz
gentoo-2-058ab448fd05a2345dae0cb25f7439eabdfaee26.tar.bz2
gentoo-2-058ab448fd05a2345dae0cb25f7439eabdfaee26.zip
updated to latest versions
Diffstat (limited to 'gnome-base/bonobo')
-rw-r--r--gnome-base/bonobo/bonobo-1.0.11.ebuild53
-rw-r--r--gnome-base/bonobo/files/digest-bonobo-1.0.111
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-base/bonobo/bonobo-1.0.11.ebuild b/gnome-base/bonobo/bonobo-1.0.11.ebuild
new file mode 100644
index 000000000000..3d374d299f10
--- /dev/null
+++ b/gnome-base/bonobo/bonobo-1.0.11.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/bonobo/bonobo-1.0.11.ebuild,v 1.1 2001/10/25 14:58:40 hallski Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A set of language and system independant CORBA interfaces"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/stable/sources/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.gnome.org/"
+
+
+RDEPEND=">=gnome-base/oaf-0.6.6-r1
+ >=gnome-base/ORBit-0.5.10-r1
+ >=gnome-base/gnome-print-0.30"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ sys-devel/perl
+ >=dev-util/intltool-0.11"
+
+src_compile() {
+ local myconf
+
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+
+ CFLAGS="${CFLAGS} `gnome-config --cflags print`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ ${myconf} || die
+
+ make || die # make -j 4 didn't work
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog README
+ dodoc NEWS TODO
+}
+
+
+
+
+
diff --git a/gnome-base/bonobo/files/digest-bonobo-1.0.11 b/gnome-base/bonobo/files/digest-bonobo-1.0.11
new file mode 100644
index 000000000000..4a410e3e81ba
--- /dev/null
+++ b/gnome-base/bonobo/files/digest-bonobo-1.0.11
@@ -0,0 +1 @@
+MD5 2c6b63010a033a75f556a3939ec75099 bonobo-1.0.11.tar.gz