summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-12-07 00:04:32 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-12-07 00:04:32 +0000
commit796321d989b82ac3afe2034eb5dbb457177efb44 (patch)
tree248ffb24f4e63652f2f17928da91e795bcb9fa58 /games-util
parentstable x86, bug 197806 (diff)
downloadgentoo-2-796321d989b82ac3afe2034eb5dbb457177efb44.tar.gz
gentoo-2-796321d989b82ac3afe2034eb5dbb457177efb44.tar.bz2
gentoo-2-796321d989b82ac3afe2034eb5dbb457177efb44.zip
Use wxversion to force wxpython-2.6 when multiple slots are available. Bug
201317. (Portage version: 2.1.4_rc7)
Diffstat (limited to 'games-util')
-rw-r--r--games-util/mattricks/ChangeLog7
-rw-r--r--games-util/mattricks/files/mattricks-0.7-wxversion.patch17
-rw-r--r--games-util/mattricks/mattricks-0.7.ebuild9
3 files changed, 30 insertions, 3 deletions
diff --git a/games-util/mattricks/ChangeLog b/games-util/mattricks/ChangeLog
index 9131a738b45a..8ebccf9dd1ff 100644
--- a/games-util/mattricks/ChangeLog
+++ b/games-util/mattricks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-util/mattricks
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/ChangeLog,v 1.8 2007/02/24 19:24:13 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/ChangeLog,v 1.9 2007/12/07 00:04:32 dirtyepic Exp $
+
+ 07 Dec 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/mattricks-0.7-wxversion.patch, mattricks-0.7.ebuild:
+ Use wxversion to force wxpython-2.6 when multiple slots are available. Bug
+ 201317.
24 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> mattricks-0.7.ebuild:
Works with wxpython-2.6 as well
diff --git a/games-util/mattricks/files/mattricks-0.7-wxversion.patch b/games-util/mattricks/files/mattricks-0.7-wxversion.patch
new file mode 100644
index 000000000000..b3076355686b
--- /dev/null
+++ b/games-util/mattricks/files/mattricks-0.7-wxversion.patch
@@ -0,0 +1,17 @@
+diff -Naur Mattricks-0.7-orig/Mattricks/Commonwx.py Mattricks-0.7/Mattricks/Commonwx.py
+--- Mattricks-0.7-orig/Mattricks/Commonwx.py 2004-04-15 06:20:07.000000000 -0600
++++ Mattricks-0.7/Mattricks/Commonwx.py 2007-12-04 21:05:15.000000000 -0600
+@@ -17,6 +17,13 @@
+ # along with this program; if not, write to the Free Software
+ # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
++try:
++ import wxversion
++ wxversion.select("2.6")
++except Exception, e:
++ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
++ sys.exit(1)
++
+ from wxPython.wx import *
+ from Common import *
+
diff --git a/games-util/mattricks/mattricks-0.7.ebuild b/games-util/mattricks/mattricks-0.7.ebuild
index c97c5ad9c674..4356bc5a1cf6 100644
--- a/games-util/mattricks/mattricks-0.7.ebuild
+++ b/games-util/mattricks/mattricks-0.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/mattricks-0.7.ebuild,v 1.4 2007/02/24 19:24:13 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/mattricks/mattricks-0.7.ebuild,v 1.5 2007/12/07 00:04:32 dirtyepic Exp $
-inherit distutils
+inherit distutils eutils
MY_P=${P/m/M}
DESCRIPTION="Hattrick Manager"
@@ -18,3 +18,8 @@ DEPEND="<dev-python/wxpython-2.8
dev-python/pyxml"
S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}"/${P}-wxversion.patch
+}