summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-04 19:10:01 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-04 19:10:01 +0000
commite7efd05f55c3c78673d2f2b10ea5cef2d4cc34e7 (patch)
treeee03a9f46c6c84a65753c0a42db1e8f5e7941c43 /games-util/xqf/xqf-1.0.5.ebuild
parentRemove old version. (diff)
downloadgentoo-2-e7efd05f55c3c78673d2f2b10ea5cef2d4cc34e7.tar.gz
gentoo-2-e7efd05f55c3c78673d2f2b10ea5cef2d4cc34e7.tar.bz2
gentoo-2-e7efd05f55c3c78673d2f2b10ea5cef2d4cc34e7.zip
Version bump
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'games-util/xqf/xqf-1.0.5.ebuild')
-rw-r--r--games-util/xqf/xqf-1.0.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-util/xqf/xqf-1.0.5.ebuild b/games-util/xqf/xqf-1.0.5.ebuild
new file mode 100644
index 000000000000..358d5f9abbbd
--- /dev/null
+++ b/games-util/xqf/xqf-1.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/xqf/xqf-1.0.5.ebuild,v 1.1 2006/11/04 19:10:01 nyhm Exp $
+
+DESCRIPTION="A server browser for many FPS games (frontend for qstat)"
+HOMEPAGE="http://www.linuxgames.com/xqf/"
+SRC_URI="mirror://sourceforge/xqf/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE="bzip2 geoip nls"
+
+RDEPEND="=x11-libs/gtk+-2*
+ >=games-util/qstat-2.8
+ nls? ( virtual/libintl )
+ geoip? ( dev-libs/geoip )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_compile() {
+ econf \
+ $(use_enable nls) \
+ $(use_enable geoip) \
+ $(use_enable bzip2) \
+ --enable-gtk2 \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}