summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-08-23 17:15:46 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-08-23 17:15:46 +0000
commit9b44da58de71045f09c8bc3b2c948e7e4d218d4d (patch)
tree77354b90deb331f7afe929afe712e3e917d6210c /games-util/ucon64/ucon64-2.0.0.ebuild
parentStable on mips for bug #103337. (diff)
downloadgentoo-2-9b44da58de71045f09c8bc3b2c948e7e4d218d4d.tar.gz
gentoo-2-9b44da58de71045f09c8bc3b2c948e7e4d218d4d.tar.bz2
gentoo-2-9b44da58de71045f09c8bc3b2c948e7e4d218d4d.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-util/ucon64/ucon64-2.0.0.ebuild')
-rw-r--r--games-util/ucon64/ucon64-2.0.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/games-util/ucon64/ucon64-2.0.0.ebuild b/games-util/ucon64/ucon64-2.0.0.ebuild
new file mode 100644
index 000000000000..9ba8bd0fa768
--- /dev/null
+++ b/games-util/ucon64/ucon64-2.0.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/ucon64/ucon64-2.0.0.ebuild,v 1.1 2005/08/23 17:15:46 mr_bones_ Exp $
+
+DESCRIPTION="The backup tool and wonderful emulator's Swiss Army knife program"
+HOMEPAGE="http://ucon64.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ucon64/${P}-src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/zlib"
+
+S=${WORKDIR}/${P}-src
+
+src_compile() {
+ local myconf
+
+ if [ ! -e /usr/include/sys/io.h ]; then
+ ewarn "Disabling support for parallel port"
+ myconf="${myconf} --disable-parallel"
+ fi
+
+ cd src
+ econf ${myconf} || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin src/ucon64 || die "dobin failed"
+ dolib.so src/libdiscmage/discmage.so || die "dolib.so failed"
+ dodoc GoodCodes.txt
+ dohtml -x src -r -A png,jpg *
+}
+
+pkg_postinst() {
+ echo
+ einfo "In order to use ${PN}, please create the directory ~/.ucon64/dat"
+ einfo "The command to do that is:"
+ einfo " mkdir -p ~/.ucon64/dat"
+ einfo "Then, you can copy your DAT file collection to ~/.ucon64/dat"
+ echo
+ einfo "To enable Discmage support, cp /usr/lib/discmage.so to ~/.ucon64"
+ einfo "The command to do that is:"
+ einfo " cp /usr/lib/discmage.so ~/.ucon64/"
+ echo
+ einfo "Be sure to check ~/.ucon64rc for some options after"
+ einfo "you've run uCON64 for the first time"
+}